Skip navigation

Can't restore to 1 partition after bootcamp

14035 Views 13 Replies Latest reply: Apr 10, 2014 12:23 AM by APLLE GEEK RSS
hipdeejay Level 1 Level 1 (0 points)
Currently Being Moderated
Jun 3, 2013 11:55 PM

Ok so I ran into a weird problem, and after searching for a while I can't seem to find a solution.

Can't find anyone else who has had the same problem either.

 

I'm currently running a 2012 RMBP. I had bootcamp installed running Windows 7.

 

Today I wanted to remove the Bootcamp partition to free up some space on my HD.

So I went to Bootcamp Utility and selected the option to restore Mac to 1 partition and remove bootcamp

 

After a while it gives me an error message, something like "cannot remove bootcamp partition or restore mac to single partition"

 

Ok...

 

But not the bootcamp partition is gone from the bootcamp utility. It's also gone from Disk utility and the Finder.

But the space that the partition was occupying (about 20+ gigs) did not change.

So it's like it's still there but I cannot erase it or get that space back for some reason.

 

I've tried everything. I tried rebooting using CMD+R and going to disk utilities from there also. But the bootcamp partition

doesn't show up at all. But the space it was taking is still there.

 

Also in Disk Utility I cannot "erase free space", it's greyed out. I can't do anything. It's like the bootcamp partition is gone, but

the space is still being taken up. So it was never really removed.


I don't know what else to do. Any ideas? Has this happened to anyone else?

  • mende1 Level 10 Level 10 (89,490 points)
    Currently Being Moderated
    Jun 4, 2013 12:00 AM (in response to hipdeejay)

    It looks like Boot Camp Assistant deleted your Boot Camp partition but it didn't resize the OS X partition. You have to add the space taken by your Boot Camp volume to your OS X volume.

     

    To do this, open Disk Utility (in /Applications/Utilities). Then, choose the hard drive at the top of the sidebar and go to Partition tab. You will see a bar with your OS X partition and grey space at the end, so you just have to press the bottom right corner of the OS X partition and drag it to the end of the bar. Finally, press Apply and your Boot Camp partition space will be added to the OS X partition

  • whaletail935 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 7, 2013 2:02 AM (in response to hipdeejay)

    I encountered the same, or very similar problem with my 2012 15" rMBP.  Upon trying to uninstall Windows 7 and its associated 60GB Partition via Boot Camp Assistant (BCA), some sort of error (dialog disappeared too quickly to recall specifics) apparently prevented completetion.  During my second attempt, the process appeared to stall at about 25-30% completion.  After the "progress bar" hadn't moved for 10 minutes, I quit BCA.

     

    My third attempt ended at the second BCA screen, as the initial three options (for installing Windows) were again available.  I thought perhaps I had actually erased the Windows Partition, but Disk Utility still displayed an unnamed 60GB Partition.  Unfortunately, resizing my boot volume to 768GB triggered a file system verification error, as did Mende1's thoughtful solution.

     

    Finally, after highlighting my SSD (not my boot volume Partition) and selecting "Verify Disk", the "Repair disk in Recovery Mode" error suspended Verification.  After rebooting in Recovery Mode (command + R after chime), repairing the drive in Disk Utility did just that, and I was able to simply resize my boot volume Partition, removing the empty partition.  I guess BCA had uninstalled Windows 7, but failed to remove the partition.

     

    Sorry for the longwinded post, but since the OP's solution didn't work for me, I thought I would share the process that worked for me.

     

    Michael Henk

  • wonder3 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 19, 2013 9:49 AM (in response to mende1)

    This actually did help fix my problem. My partition tab only showed one partition but there was an area of space that was shaded blue that was the amount of space I had set aside for my Bootcamp drive that had not been restored. I was missing about 30 gigs of space. The partitions wouldn't let me use the bar to change the amount of space but it would let me type in the amount of space I wanted the drive to be.

     

    So the fix that worked for me was to type in "200" in the Size tab under Partition Information. It then corrected my 200 amount to 199.19 and I then pressed Apply. After a couple minutes of working the space was restored and my drive went from 168 gb capacity to 199.19 gb. Very simple fix that did not require me to Bootcamp again.

  • idan007 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 11, 2013 5:42 AM (in response to wonder3)

    Thanks Wonder3! it worked just perfect..

  • Keepofisland Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 16, 2013 5:14 PM (in response to hipdeejay)

    I've tried all these solutions but just in vain. Even if I try to repartition in recovery mode, the error message "couldn't modify partition map because file system verification failed" keeps showing up. Any suggestion?

  • wonder3 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 16, 2013 5:22 PM (in response to Keepofisland)

    Im no expert on the matter but if the file system verification is failing you may need to verify your disk permissions and repair the disk. Load your OSX install disks, boot from those, open disk utility, and verify and repair the disk and permissions then try this process again. Make sure you do it from you OSX disks.

  • Keepofisland Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 16, 2013 10:08 PM (in response to wonder3)

    Thanks to wonder3. It works. I reboot my early 2011 MBP with original OXS disk and verify/repair both permission and disk by disk utility and then do the partition again. lots bugs found by the verify processes so I think this shuold be the problem and the OXS disk somehow can fix them. Hope my experience helps.

  • dalstott Level 4 Level 4 (2,470 points)
    Currently Being Moderated
    Sep 17, 2013 4:05 PM (in response to Keepofisland)

    FYI for future reference. If you create a external drive bootable clone of the Mac partition you have a ready solution to any problems of getting rid of a Boot Camp partition or reclaiming the space. Simply boot from the Mac clone and with disk utility erase and partition (1) the internal drive (Mac OS Extended (Journaled with GUID table). Finally back clone the external drive to the internal drive. Cloning will optimize the disk and leave unfragmented free space. It is one of the best ways to back up your drive.

     

    http://www.bombich.com/

     

    http://www.shirt-pocket.com/SuperDuper/SuperDuperDescription.html

  • brent1582 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 28, 2013 3:22 AM (in response to wonder3)

    Wonder3,

     

    What if you dont have the OSX install disks?

  • shawnread1234 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 6, 2014 2:17 PM (in response to hipdeejay)

    I HAD THE SAME EXACT PROBLEM AND I DONT KNOW WHY, BUT HOW CAN I RECOVER MY 300 GB SPACE FOR MY IMAC!!!!!

     

    I AM STILL SEARCHING....

  • APLLE GEEK Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 10, 2014 12:23 AM (in response to shawnread1234)

    YOU CAN EASILY RECOVER YOUR LOST SPACE,

    1.GO TO DISK UYILITY

    2.SELECT THE LOST SPACE PARTITION-AND PRESS THE MINUS BUTTON

    3.CLICK ON REMOVE

    4.AND THEN RESIZE YOUR ORIHINAL PARTITION

    5.YOU ARE DONE !!!!!!

     

    IF PROBLEM NOT SOLVED CONTACT ME


Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.