Skip navigation

Keynote 09 5.1.1 massive problem exporting recorded slideshow

5167 Views 16 Replies Latest reply: Oct 27, 2013 9:29 PM by Quaas RSS
1 2 Previous Next
bwalton Level 1 Level 1 (0 points)
Currently Being Moderated
Feb 2, 2012 6:56 AM

Using Keynote 9 5.1.1 and am trying to export my recorded slideshow but the resulting .mov file has parts missing. I cannot figure it out. I have watched my recorded slideshow over and over and every part plays perfectly. If I simply play my keynote file it also plays perfectly. But exporting it has been a nightmare!!

 

My slideshow is reasonably complex;

it has animated text with build in and build outs

it has multiple .mp4 movie files embedded (they were recorded on my iphone and edited in imove with layover/transparency effects)

and it has .mov files created with the awesome app Brushes

and finally it has a .mov file created with Quicktimes screen recorder

 

But again my Keynote file itself plays no problem.

 

I have also tried exporting my Keynote to iWork, and had problems with being able to play the videos, I have exported to iTunes and had parts of my recorded slideshow simply disappear, I have sent to youtube and had an unidentified error midway through the upload (several times).

 

The only exporting that seems to work is exporting to flat files such as PDF or powerpoint - but that is completely not what I want. I am using Keynote for its beautiful animation abilities and am so frustrated with not being able to easily export and play it on other devices or publish to the web without problems.

 

Any guidance or advice from others would be hugely appreciated.

 

B

  • Steve_Leedom Calculating status...

    Just wanted to bring some new eyeball activity to this post, because I'm having the exact same issues on a project with similar content pieces.

     

    If anyone has some great advice on the issue and the solution, please chime in.

     

    On another note, at least for the time being, I was able to use Camtasia to convert my Keynote presentation off of the screen and convert to a movie file so I had something to give my client. Lost some quality, but it's better than NOTHING.

  • Buffsters Calculating status...

    Anybody out there have an answer to this? I have a recorded Keynote presentation that includes a 5-minute video. It all plays well within Keynote. When I begin exporting to Quicktime, it doesn't export the polished presentation. It exports without the correct timing of titles over the video and then cuts out before it's over at the end. Why won't the Keynote presentation presentation export as seen in playback within Keynote?

     

    Please help.

  • Johnxl Calculating status...

    I too am having the same problem....its madding!

  • Gresh07 Calculating status...

    How is this still an issue???

     

    I'm curently going thorough the same problem and can't seem to find a solution anywhere, All i can find is loads of people having massive problems dating back for months...

     

    If anyone knows a way around this or if an older version of keynote might work better please let us know.

  • Buffsters Level 1 Level 1 (0 points)

    I guess I can only reply to the original post.

     

    I found an annoying work around here that involves exporting to IMovie and using transparent overlays of the graphics created in Keynote. Here's a link to a video that describes how to do it:

    http://macmost.com/transparent-video-overlays-with-keynote.html

     

    Over a month ago, tech support requested the files in question from me, which I sent to them, and have never heard back.

     

    Good luck.

  • jojoebi Calculating status...

    I have been searching for the last couple of days to figure this out. I even simplified my presentation by taking out all the transisition so now it is a simple slide show with voice over but on export it either removes a chunk or screws up the audio.

    Initially I thought it was a problem with the youtube end but after watching the file once it is exported it is definately a keynote issue.

    Buffsters - I will check out your work around but it annoys me that I even have to!

  • JBalliet Calculating status...

    I am having the same issue. When the Keynote recorded slideshow is exported to Quicktime, all of the slides transfer as does the audio, except those slides with build-in/build-out actions which breakdown and become pixelized. As you all already know, this is super annoying.

     

    You can use a screen recorder such as the one built into Quicktime or Screenflow to record the presentation as you play it, then use iMovie to edit, finally exporting to Quicktime but the quality of an exported iMovie file based on a Keynote presentation is not good.

     

    I'd love to know if anyone has a better solution.

  • Gary Scotland Level 5 Level 5 (7,555 points)

    The quality of the QT file will depend on what CODEC is used to encode to QT. No one who posted earlier listed their workflow or  CODEC.

     

    An H264 file ( the three default settings:  large, medium or small )  will produce dreadful results but play back will be smooth and will be a small file.

     

    An Animation file will produce great quality but will be a very large file and will probably not playback at all on anything but the most powerful Mac, Animation CODEC is  extremely processor intensive.

     

    so  a custom setting must be chosen that balances between quality, file size and playback performance.

     

    custom1.png

     

     

     

    custom2.png

     

     

     

     

    custom3.png

     

     

     

     

    The file sizes of a  Keynote file running for just one minute,  encoded with   8bit Broadcast is 650 MB,  encoded with domestic DV is 65 MB

     

    Its  a matter of balacing file size, quality and preformance, producing some test files and deciding what works on the specific playback system.

  • stepheninmiamibeach Calculating status...

    We just experienced same thing.

    Problem was the animation at the beginning of the movie.

    We added a start and stop at beginning and end and it fixed the problem.

     

    Stephen

    Miami Beach

  • pietSRQ Calculating status...

    How do you mean start and stop? I have a recorded keynote file with bits of Quicktime in it. You mean avoid the "open automtically" (or is it "start automatically") option?

     

    PietS, Leuven

  • terence1957 Level 1 Level 1 (0 points)

    Hi-

     

    Well, reading though this thead I feel slightly vindicated, but somwhat ****** that these problems with Keynote have persisted for 2 years + with no apparent resolution from Apple. My problem seems trivial compared to many here; basically I have a slide show with prerecorded voiceover that I imported. Believe it or not it's simply ONE slide with bullets appearing which I have timed to the voiceover. Expoting to Quicktime...as soon as the first bullet appears, the audio cuts out. On one occasion I tried the export (I cannot reprodiuce this) it seemed to be working but was slightly out of sync (i.e,. not like my recording in Keynote) but the audio suddenly stopped in the middle. Yikes! The only reason I bought Keynote was for its advertised ability to produce movie files from a slideshow that I could integrate into a FCPX movie. I was hoping to avoid incompatibility problems using somthing like Powerpoint. Very dissapointed and still no resolution!

  • terence1957 Level 1 Level 1 (0 points)

    Update: It appears my discussion post was picked up by Apple with an offer to help. Now that's pretty amazing! I have pasted the email with my response, in fairness to all. I did manage to resolve my particular problem as you will see. Thanks, Apple's iWork Team!

     

    iWork Team <iwork@apple.com>Mon, Aug 26, 2013 at 4:19 PM

     

    Hello there,

     

     

    We have heard about your issue from the discussion thread below:

    https://discussions.apple.com/thread/3704717?tstart=0

     

    We would like to know if you would be able to provide the following:

     

    - A copy of your 1 slide slideshow?

    - If possible, send us both the Keynote file and the exported QT file.

     

    Thank you,

    The iWork Team

    14836573


    Terence Mon, Aug 26, 2013 at 6:07 PM
    To: iWork Team <iwork@apple.com>

     

    Wow! That's good service!
    I spent all day working on it and discovered the problem was the way I was adding audio. I was dragging and dropping an audio file from Finder right onto the slide, which produces a little sound icon. I guess I was playing it by ear because Mac is very drag and drop it seemed the logical thing to do - and it almost worked. Now I've discovered that I have to do this in Inspector, dropping it into the little box under Audio. All those weird problems go away. Anyway, I must read the Keynote manual sometime!

     

    I really appreciate your offer of help!

    Thanks,

    Terence

  • jmancino Calculating status...

    It's awesome that Apple actually got in touch with you! I'm having the issues you described, but I haven't added any audio files to the presentation. I have a voiceover that spans the entire presentation and videos that play in some of the slides. I suspect that that's what's causing the issue I'm having. My presentation plays fine in Keynote with the recorded timing and voice over, but the video that Keynote exports is mostly useless. The audion doesn't line up with the presentation, some embedded videos don't play (although the text that overlays them does), and other problems abound.

     

    I don't think this one will get solved any time soon, but it great to hear that someone on the iWork team is working hard on this.

     

    -Joe

  • terence1957 Level 1 Level 1 (0 points)

    Jmancino - I'm sorry to hear of your problems. I guess your voiceiver is recorded in Keynote itself. I record my VO in an audio editor (Cubase 5) first then import that to Keynote. Then I "record" the presentation itself and hit spacebar for each bullet to appear at the right moment in my VO. Everything seems to work fine for move exports now that I know how to do the audio import properly. The only reason for using Cubase was that I was already using it to make VOs for the Final Cut production - but this workflow seems to work. I hope you are able to get a fix soon.

1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (2)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.