Skip navigation

10.8.4 Mail has lost all signatures

639 Views 4 Replies Latest reply: Aug 27, 2013 4:45 PM by Ravenmoon RSS
Yarramalong Level 1 Level 1 (125 points)
Currently Being Moderated
Jun 5, 2013 4:22 PM

After updating the OSX, my mail has lost all signatures.


When I add an image, only a miniature is beng sent.

Mac Pro, OS X Mountain Lion (10.8.2), 10 GB
  • etresoft Level 7 Level 7 (23,905 points)
    Currently Being Moderated
    Jun 5, 2013 5:18 PM (in response to Yarramalong)

    Are they gone or are just just disassociated from the appropriate accounts? See if you can put them back in Preferences.

  • etresoft Level 7 Level 7 (23,905 points)
    Currently Being Moderated
    Jun 7, 2013 3:56 AM (in response to Yarramalong)

    Make sure your default email format is still rich text.

  • Ravenmoon Level 1 Level 1 (5 points)
    Currently Being Moderated
    Aug 27, 2013 4:45 PM (in response to Yarramalong)

    I have had all of mine vanish completely. Not just as to being with accounts, not listed in siguatures at all; just gone. They are all still in the Users/[name]/Library/Mail/V2/MailData/Signatures folder, but no matter what I do, Mail won't see them. They seemed to vanish around the same time as my rules, which I noticed right after a power outage. Maybe Mail didn't close properly, but heaven knows I've crashed before and not had this happen!


    I managed to tinker until I got the rules back; it seemed to be a case of files in the wrong places, though how they got moved is a mystery!, But I haven't been able to do the same with the sigs. I've tried removing all the plist files from the Signatures folder, all at once and individually, but no luck.


    The other things I tried (with regard to both rules & sigs) are here:




    OK, I was able to restore from a backup. It seems that somehow (no clue how/why) all the ".mailsignature" files went A.W.O.L., leaving only the ".webarchive" files for each sig. As I told the other thread, it's fixed in the sense that it works, even if not solved in that I know what went wrong, and I really wish I did.....


More Like This

  • Retrieving data ...

Bookmarked By (0)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.