Skip navigation

No Wake-on-LAN possible since updating to ML

92491 Views 281 Replies Latest reply: Apr 11, 2014 5:32 AM by Abraham Zabih RSS Branched to a new discussion.
  • StigBull Level 1 Level 1 (10 points)
    Currently Being Moderated
    Jun 5, 2013 5:18 AM (in response to SteffenKaiser)

    Is this fixed in 10.8.4?

     

    I updated my MacMini at home this morning, and I have been able to wake it every single time I tried SSH'ing into it from work.

     

    On two occasions it wouldn't wake, but by sending a magick packet I was able to wake it on both occasions.

     

    Keep your fingers crossed...

  • StigBull Level 1 Level 1 (10 points)
    Currently Being Moderated
    Jun 7, 2013 12:09 AM (in response to StigBull)

    Day 3 and it is still waking on LAN/WAN access every single time.

     

    I believe this is fixed in 10.8.4

  • ffcphone Calculating status...
    Currently Being Moderated
    Jun 7, 2013 12:12 AM (in response to StigBull)

    Not for us it isn't. Maybe I need to pin the blame at our router not sending on the magic packet if OSX is now behaving properly if it receives it.

  • Ricky679 Calculating status...
    Currently Being Moderated
    Jun 7, 2013 12:18 AM (in response to ffcphone)

    Magin packet don't work for me yet!! I check more things, but, the 10.8.4 hasn't fixed my problem!

  • StigBull Level 1 Level 1 (10 points)
    Currently Being Moderated
    Jun 7, 2013 12:30 AM (in response to ffcphone)

    I use a Time Capsule, have connected the Mini on ethernet as well as Wi-fi (secondary interface in network settings).

     

    Try SSH'ing into it.

    If it doesn't work download wolcmd (found via the magick packet link in my previous message) which sends an explicit wake on lan message.

     

    I use this syntax: wolcmd <The Mini's ethernet MAC address> <the router's public address> 255.255.255.255 7

     

    7 is the UDP port for the magick packet, but 9 can also be used, so try 9 if it doesn't work, and you may even have to experiment with the subnet mask (though it shouldn't be neccessary)

  • ffcphone Level 1 Level 1 (5 points)
    Currently Being Moderated
    Jun 7, 2013 1:06 AM (in response to StigBull)

    I've tried using the "WakeUp" app on iOS using the MAC address and router's public address.

     

    As previously, can wake the Mac Mini up when I'm on wifi at home and I'm feet away but when I'm at work and want to use logmein neither logmein nor WakeUp can encourage the Mac out of sleep.

     

    I had a call from Apple Support about this a couple of weeks ago. When I last requested an update matters were sti ongoing.

  • Ricky679 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jun 7, 2013 1:59 AM (in response to ffcphone)

    I use SleepOver app on IOS, Wake On LaN works, the problem in Wake On Wan.

     

    I have open 7 and 9 UDP ports on my routers ( i have a Comtrend Router and TP-Link Router as Switch) and I use "Wake for Ethernet network access" feature

     

     

     

    Wake on Wan  worked correctly three weeks ago, but now, it doesn't work.

  • StigBull Level 1 Level 1 (10 points)
    Currently Being Moderated
    Jun 7, 2013 3:50 AM (in response to Ricky679)

    Have you set up port forwarding on your router for UDP port 7/9 directly to the Mini?

  • artisticforge Level 1 Level 1 (5 points)
    Currently Being Moderated
    Jul 1, 2013 12:31 AM (in response to SteffenKaiser)

    Hello

     

    New Mac Mini purchased at local Apple Store 8 days ago. Wake-on-Lan is not working.

    I either have to physically go to the computer to wake it up or as I discovered on Sunday, aim an Apple Remote which is paired with the other older Mac Mini running Snow Leopard and click it a few times. The new Mac Mini wakes right up.

     

    All the computers in the house have a static ip address from the /24 I received when I was working on building DarpaNet/ArpaNet many years ago. All iMacs are running Snow Leopard and wake-on-lan with no problem. All other Mac Mini are running Snow Leopard and wake-on-lan with no problem. The 13 inch & 17 inch  MacBookPro are running Snow Leopard and wake-on-lan with no problem. Basically, any Apple Computer running Snow Leopard wake-on-lan works. Any Apple Computer running Mountain Lion wake-on-lan is not working.

     

    Unless someone has some insight I will try Apple Support once again later today, Monday.

  • SarahCat Level 1 Level 1 (5 points)
    Currently Being Moderated
    Jul 1, 2013 12:51 AM (in response to artisticforge)

    Artisticforge,

     

    Your experience mirrors mine and seems fairly definitive.

     

    I hope you will post your results if you call Apple Support.

  • SarahCat Level 1 Level 1 (5 points)
    Currently Being Moderated
    Jul 3, 2013 10:30 PM (in response to SarahCat)

    I came home this evening and found all my exterior lights off. They should have been turned on by my Indigo application (which has an iOS client), however, when I attempted to reach the Indigo Server running on my Mac Mini, the server was unreachable, even on my local Airport LAN. I went to the computer and found it asleep. I woke the computer and then everything operated normally.

     

    I then went into System Preferences -->Energy Saver -->Power Tab --> Computer Sleep - Never

     

    Wake on LAN appears not to work. I've tried, lord I've tried, but Mountain Lion on my i7 Mini has never seemed to support wake on LAN, however, my ancient Dual Core 2 Mini with Lion did.

     

    Not a great outcome, guys. I guess I'll be burning more power, having defeated the Energy Saver settings, which is sad. I'm going to the Apple Store on N. Michigan Ave in Chicago for an iPhone problem, but I'd take my Mini to the Genious Bar, but since I don't want to rip out and take my network, too, it seems unfeasible.

     

    So, here I am, defeating the Energy Saver feature because Wake on LAN does not appear to operate.

  • lexvo Level 1 Level 1 (60 points)
    Currently Being Moderated
    Jul 13, 2013 10:21 AM (in response to SarahCat)

    I have the same problem: wireless wake on lan is not working. I didn't read the whole thread, but is it safe to say that this is a bug in Mountain Lion?

  • lexvo Level 1 Level 1 (60 points)
    Currently Being Moderated
    Jul 21, 2013 3:54 AM (in response to lexvo)

    I may have found something that works.

    My main router is from my internet provider and I have an Airport Extreme to extend my network (bridge mode) and it also is my WiFi access point.

    Before, when I put my iMac to sleep via the menu, I couldn't get it to wake on wireless LAN. I also had trouble waking it up if it had slept for over a few hours.

    Today I did two things:

    1) give my Airport Extreme a fixed IP adress

    2) switch off ipv6 on my iMac (in Terminal, not via System preferences)

    Low and behold, I can wake up my iMac now from my iPhone and iPad and access the iTunes library.

    Of course, it is to early to say if this is a definite solution (hence the "I may have found) so I will try tomorrow if it still works (after my iMac slept for some hours).

  • lexvo Level 1 Level 1 (60 points)
    Currently Being Moderated
    Jul 21, 2013 4:29 AM (in response to lexvo)

    Sorry, forgot to mention that my iMac already has a fixed IP adress.

  • artisticforge Level 1 Level 1 (5 points)
    Currently Being Moderated
    Jul 21, 2013 6:20 AM (in response to lexvo)

    hello

     

    my entire network is made up of public static ip addresses.

    my iPhone has a static ip address, from the /24 assigned to me when I worked on the DarpaNet/ArpaNet many decades ago. static ip addresses do not help. the only way so far is to not allow the computer running Mountain Lion is ever go to sleep. Which is not the best.

     

    This one broken feature of Mountain Lion is a real turnoff. no pun intended.

     

    the solution has to come from apple and so far apple has been a mute.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (11)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.