Skip navigation

HT5557: iBooks: Frequently Asked Questions (FAQ) about iBooks features

Learn about iBooks: Frequently Asked Questions (FAQ) about iBooks features

HT5557 iBooks problem

222 Views 2 Replies Latest reply: Jun 30, 2013 10:06 PM by loisfromnl RSS
Betzabeth Romero Calculating status...
Currently Being Moderated
Jun 9, 2013 1:38 AM

How can I download iBooks, if my iPod has 4.2.1 version?

  • King_Penguin Level 10 Level 10 (92,520 points)
    Currently Being Moderated
    Jun 9, 2013 1:42 AM (in response to Betzabeth Romero)

    Unfortunately you can't, only the current version of each app is available in the store, and the current version of iBooks requires iOS 5+

     

    As all apps are tied to the account that downloaded it, you would need to have downloaded the app when it was compatible with iOS 4.2 and still have a copy of it somewhere that you could then sync to your iPod

  • loisfromnl Calculating status...
    Currently Being Moderated
    Jun 30, 2013 10:06 PM (in response to King_Penguin)

    I had the earlier version on my iPod but when I sinced/restored my iPod after a problem the new iBooks tried (and Failed) to install and wiped out what I had. Can't find a backup copy.  What do I do.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.