1 2 3 4 5 Previous Next 64 Replies Latest reply: Jun 9, 2013 9:53 AM by TRON Go to original post
  • 60. Re: rDesktop 1.7.0
    barlow36 Level 1 Level 1 (0 points)

    Hi Tron,

    thanks for your help. It does work but it doesn't create usr/local/bin.

    I'm not so familiar with development maybe there is a easier way to geth rdeskop with smartcard access?

    Thanks for your helpa again

  • 61. Re: rDesktop 1.7.0
    TRON Level 1 Level 1 (20 points)

    barlow36,

    I've posted an installer here:

    https://www.box.com/s/i4gdjvlbxhueo69lx45a

     

    It will place my pre-compiled rdesktop application in your /usr/local/bin/ folder and the pre-compiled keymaps folder in the /usr/local/share/rdesktop/ folder.

     

    You should then be able to run rdesktop from the Terminal application, as long as you have the X11 application installed on your Mac.  The most recent Macs do not have X11 installed, so you must install it separately:

    http://xquartz.macosforge.org/landing/

     

    Good luck!

  • 62. Re: rDesktop 1.7.0
    barlow36 Level 1 Level 1 (0 points)

    Hi Tron,

    thanks it works fine. For smartcard use do I need to do more?

    Thanks

  • 63. Re: rDesktop 1.7.0
    Ian Cheong Level 1 Level 1 (30 points)

    I use the macports version for smartcard support. I use it because I use lots of other macports packages, and it is an easy way to get packages that work, usually without any problems. The macports rdesktop may need manual tweaking until the port maintainer fixes bugs in it. Have logged a bug fix request with my tweaks listed in post here of 2nd May. Works fine with smartcard on 10.6.8 and 10.5.8. Current version is 1.7.1 as of last month.

     

    To use macports, read http://www.macports.org/install.php

     

    Then installation of most ports is simply

    $ sudo port install <portname>

     

    In this case if it is properly patched,

    $ sudo port install rdesktop +smartcard

     

    If it is not patched and generates errors, the fixes are listed in my post of 2nd May. To manually fix, I have used 2 ways.

    a. download appropriate source version, unpack and edit the source file, replace macports source file with edited version.

    b. use macports to download source, find and edit source file

     

    Either way, run the phases of macports build one at a time:

    http://guide.macports.org/#reference.phases

     

    eg (sudo is not needed for all but makes live easier to leave it in)

    $ sudo port fetch rdesktop +smartcard

    $ sudo port checksum rdesktop +smartcard

    $ sudo port extract rdesktop +smartcard

     

    If errors, then fix as per my listed tweaks. The major part is to locate the source file and delete the listed lines or replace it with an edited version.

     

    $ sudo port configure rdesktop +smartcard

    $ sudo port build rdesktop +smartcard

    $ sudo port destroot rdesktop +smartcard

     

    Commands I use to connect using ssh tunnel (always recommended for security - requires ssh to be set up on server, preferably with RSA key authentication):

    $ ssh <username>@<sshserverexternalIPaddress> -L 3389:<internalipofserver>:3389

    $ rdesktop -x m -r scard -r clipboard:"CLIPBOARD" -g 1280x1024 -u<username> localhost

  • 64. Re: rDesktop 1.7.0
    TRON Level 1 Level 1 (20 points)

    barlow36,

    After rdesktop (with smartcard support) has been installed, you need to invoke the smartcard support when you execute it, as indicated by Ian Cheong.  When you run rdesktop, just include the "-r scard" option, just like the last line of Ian Cheong's post:

     

    $ rdesktop -r scard REMOTE.SERVER.ADDRESS

     

    (where REMOTE.SERVER.ADDRESS is the address of the terminal you're trying to connect to)

     

    If you just type "rdesktop" in the Terminal application and press "enter", you should get a list of rdesktop options and how to invoke them.

1 2 3 4 5 Previous Next