Skip navigation

Aperture 3.4.5 Processing Everytime...

660 Views 3 Replies Latest reply: Jun 10, 2013 2:34 AM by léonie RSS
sataguler Calculating status...
Currently Being Moderated
Jun 10, 2013 12:24 AM

I am using Aperture for 2 years and I am updating it regularly. For nearly 1 week I have a serious problem. Whenever I try to open Aperture everytime it starts "Processing..." and last this action for a long time. Nearly my application stucks. Before 1 week ago there was no such problem or action at my Aperture. What may be the problem? How can I solve the problem? In activity window it always shows generating preview. And evertime it generates the same previews.

Also I have done "Repair Permissions", "Repair Databse" and "Rebuild Database", but nothing has chnaged... the same problem, everytime "Processing.." and nearly stucks...

Aperture 3, Mac OS X (10.7.5)
  • léonie Level 8 Level 8 (46,475 points)
    Currently Being Moderated
    Jun 10, 2013 12:44 AM (in response to sataguler)

    Does this stop, if you launch Aperture by double-clicking the Aperture icon while holding the Shift-key down (to defer the generation of previews)? And when you try to work with a new, empty test library?

     

    Then you probably have imported an image or video, that Aperture cannot process. Aperture will try over and over again on each new lauch to render previews for this file. So you need to find the file that makes Aperture get stuck and remove it from the library.

     

    Check the files you imported into Aperture, when the problem started. One way to do it, is to launch Aperture with the Shift-key and to create previews manually (Photos < Update/Generate Preview). If this causes the spin, you have found the culprit.

    For a systematic search, see my User Tip here:

                     How to Screen an Aperture Library for Corrupted Image Files or Videos

     

    Regards

    Léonie

  • léonie Level 8 Level 8 (46,475 points)
    Currently Being Moderated
    Jun 10, 2013 2:34 AM (in response to sataguler)

    I looked for the corrupted files, but found none. Whatelse can I do?

    Very often it are older videos, that suddenly are causing problems.

     

    Try again to launch Aperture without Shift-key, and open the "Activity Window".

     

    When you see that Aperture is hanging, select the current task and press the "Pause Task" button. You should now be able to see the filename in the panel.

    Check this file.

    Screen Shot 2013-06-10 at 11.32.17.PNG

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.