Skip navigation

I updated iTunes (10.7) and now iPhone Configuration Utility will not run.

42652 Views 70 Replies Latest reply: Jun 10, 2013 5:11 AM by DaftyDoo RSS
  • sunkissedsyd Calculating status...

    HI Todd, no error message, it just dosn't launch, However it is allowing to launch in local profile mode. weird!

  • JimMalnati Calculating status...

    I have the same problem (IPCU crashes immediately and the UI does not start).  There is nothing in any Event Log to indicate an error and I have rebooted after the IPCU 3.6 install.  Here is my configuration:

     

    iTunes 10.7.0.21

    IPCU 3.6.0.295

    iPhone 5 (Verizon) 64GB and iOS 6

    Windows 7 32-bit

     

    Apple Application Support 2.2.2

    Apple Mobile Device Support 6.0.0.59

    Apple Software Update 2.1.3.127

    Bonjour 3.0.0.10

    iCloud 2.0.2.187

    QuickTime 7.72.80.56

    Safari 5.34.57.2

     

    Also, in "C:\Program Files\iPhone Configuration Utility\nlog.config" I found the following (note the Logger Name comment in bold below; I don't know that "put it back before we ship" is relevant to this issue but may be something for the QA people to address in terms of cleanup):

     

    <?xml version="1.0" ?>
    <nlog xmlns="http://www.nlog-project.org/schemas/NLog.xsd"
          xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
          throwExceptions="true"
        >
       <targets  async="true">
            <target name="file" xsi:type="File"
                layout="[${longdate} ${logger}] ${level}: ${message} ${exception}"
                fileName="${specialfolder:folder=LocalApplicationData}/Apple Computer/iPhone Configuration Utility/ipcu.log"/>
                archiveFileName="${specialfolder:folder=LocalApplicationData}/Apple Computer/iPhone Configuration Utility/archives/ipcu.{#####}.txt"
                archiveAboveSize="10240"
                archiveNumbering="Sequence"
                concurrentWrites="true"
                keepFileOpen="false"
                encoding="UTF-8" />
        </targets>

        <rules>
            <logger name="*" writeTo="file" /> <!-- For QA sanity, removed: minlevel="Info" put it back before we ship-->
        </rules>
    </nlog>

     

    Are there any other debug logs that may shed light on this issue?

     

    Thanks in advance for helping solve this problem!

  • Todd Fernandez Level 2 Level 2 (215 points)

    I have the same configuration you do except that I had an older version of the iCloud control panel installed and I am running Windows 7 64-bit, but even after I updated iCloud to the version you have installed, iPCU 3.6 runs just fine and sees a connected iPhone 5.

     

    I know this isn't very satisfying advice, but you may want to consider uninstalling and reinstalling all of the Apple software.

  • JimMalnati Level 1 Level 1 (0 points)

    Thanks Todd: that was good advice, and I considered it myself, but due to the impact decided to ask for other ideas first. 

     

    In the end I removed all Apple products, rebooted, and currently have installed just iTunes 10.7.0.21 and

    IPCU 3.6.0.295, but these installed Apple Application Support 2.2.2, Apple Software Update 2.1.3.127, Bonjour 3.0.0.10, and Apple Mobile Device Support 6.0.0.59 automatically.  QuickTime, iCloud, etc are not installed yet. 

     

    Sadly, IPCU still crashes (same as before).  I have tried IPCU without my iPhone 5 connected (iTunes running) and with iTunes closed.  No luck in any case, and nothing in the event logs as a clue where to debug next.

     

    Any other suggestions?

  • Todd Fernandez Level 2 Level 2 (215 points)

    I suspect that you may have installed a conflicting version of a dll that iPCU depends on. I have seen this happen before with OpenSSL.

     

    The iPCU log at "${LocalApplicationData}/Apple Computer/iPhone Configuration Utility/ipcu.log" may give you a clue to which dll.

     

    Alternatively, if you have access to Dependency Walker (dependencywalker.com), you could run that tool on MobileDevice.dll and/or CoreFoundation.dll (it won't work on the iPCU app itself because it's a .NET app) and check where it's loading each dll it's linked against. If you see one that is loaded from a place that is not the iPCU directory, that's the one.

     

    The solution would be to remove that dll and then reinstall iPCU, which includes all of the dlls it depends on. Note, it's possible that this would then break whichever app installed the incompatible version of that dll if the version included with iPCU is not compatible with it.

  • sunkissedsyd Level 1 Level 1 (0 points)

    HI Everyone,

    Thanks for you feedback...

    OK I worked out a solution for me....it worked for me not sure if it will work for others also so ill share it with you.

     

    1, Created a local profile on your laptop

    2. Install ipcu and iTunes on that profile

    3. Restart the computer - not logging in to the network (so off line to ALU)

    4. Turned off wifi on laptop

    5. Exported my certificate to my network/xxx desktop

    6. go to file path C:\Program Files\iPhone Configuration Utility

    7. go to iPCU.exe and right click , run as the local profile you created - iPCU should lunch

    8. update your configuration profile as per the instructions

    9. you will need to install your certificate from your network/xxx desktop - (make sure you add it to personal certificates)

    10. then you should be able to install on your iPhone.

     

    If you are not familiar with the certificate part of these instructions let me know an ill post instructions for that also.

     

    Hope this helps someone

  • B_Reid Calculating status...

    I too had run into this problem, but as of today it would appear that a solution is provided.  My Apple Software Update ran today informing me of an updated version (to 3.6) of the iPhone Configuration Utility.  I ran it and my IPCU is now fixed! 

  • Ghayth Calculating status...

    same problem
    wish to fix it ASAP

  • Todd Fernandez Level 2 Level 2 (215 points)

    Which "same problem" do you have? If you have iTunes 10.7 installed, you need to update to iPCU 3.6.

  • clarissa_dawnnn Calculating status...

    Same issue!! i uninstalled itunes.and redownloaded it and it worked!!!!!

  • DaftyDoo Calculating status...

    Team,  after doing some search on these forums, I came to understand that the CRYPTO folder also needs to be deleted.

     

    c:\users\USERNAME\roaming\microsoft\crypto

1 2 3 4 5 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (5)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.