6 Replies Latest reply: Jun 10, 2013 4:51 PM by Pondini
1macprincess! Level 1 Level 1 (40 points)

I realize it needs cushion for workspace as well as not backing up more frequently will cause TM to do a brand new full backup. How often do i need to do this? I am on a laptop, and don't carry it with me, nor have it conveniently out to protect it from damage.

TIA!


MacBook Pro (15-inch, Mid 2012), OS X Mountain Lion (10.8.4)
  • 1. Re: External HD not deleting old backups to make space...why?
    1macprincess! Level 1 Level 1 (40 points)

    Well, i mean i don't carry the ehd with me....!

  • 2. Re: External HD not deleting old backups to make space...why?
    Pondini Level 8 Level 8 (38,720 points)

    TM will delete old backups to make room for new ones, if it can.

     

    It won't ever delete your last remaining backup, though, for obvious reasons.  So if your backup drive isn't a whole lot larger than the data it's backing up( we usually recommed at least 3 times as large), there may not be room for both the last backup and a large new backup.

     

    TM usually won't do a new, full backup unless there have been a very large amount of backups -- it's actually fairly rare, but occasionally happens after 30 days or so.

     

    How much data is on your Mac, and how large is your backup disk (less any other data on it)?

     

    Also see #C4 in Time Machine - Troubleshooting to see more info on the exact message you got.

  • 3. Re: External HD not deleting old backups to make space...why?
    1macprincess! Level 1 Level 1 (40 points)

    Thanks so much for your reply! It was the only backup on the drive. The drive is small....a 500g G-drive mobile. I love the drive, and it worked fine for my older computer with a smaller HD. I guess i need to stop ignoring the backup reminders from TM and then it will do incremental backups. I think that's the biggest issue. The computers HD is 750, so it's less than one time it's size!

    The g-drive works fine, and I have used about 1/3 of it so far, but as i said, i think it's cuz i'm not keeping up on the incremental ones. just need to move the ehd to a more convenient, but safe spot. (laptop lives on my dining room table, which is in my kitchen, so i am extra careful)

    Thanks again for your help!

  • 4. Re: External HD not deleting old backups to make space...why?
    Pondini Level 8 Level 8 (38,720 points)

    1macprincess! wrote:

    . . .

    The computers HD is 750, so it's less than one time it's size!

    It doesn't really matter how large the HD is -- TM doesn't back up empty space.

     

    The g-drive works fine, and I have used about 1/3 of it so far,

    Something doesn't add up.  That would be about 160 GB used; if one full backup is 160 GB, there should be more than enough room for another.

     

    Let's confirm the sizes.  If they're shown on your Desktop or Finder sidebar, select and control-click each in turn and select Get Info.  Either screen print the displays and post them here, or tell us the Capacity and Used of each.

     

    If they're not shown, go to Finder > Preferences then either General or Sidebar and make sure the Hard Disks and External Disks are checked (not with minus signs).

  • 5. Re: External HD not deleting old backups to make space...why?
    1macprincess! Level 1 Level 1 (40 points)

    sorry...math has never been my thing. i have used about 300 g of the 750g internal hd. the ehd is 500g, so it wouldn't back it up as there was only 91g available on the ehd.

    i've deleted what's on the ehd. (it's backed up on another ehd, so i'm safe) now i'll run a new full backup and be sure to do incremental ones weekly. will that be frequent enough?

    thanks!

  • 6. Re: External HD not deleting old backups to make space...why?
    Pondini Level 8 Level 8 (38,720 points)

    1macprincess! wrote:

     

    sorry...math has never been my thing. i have used about 300 g of the 750g internal hd. the ehd is 500g, so it wouldn't back it up as there was only 91g available on the ehd.

    Ah, ok.  It's still a bit unusual for TM to do a full backup, but that's probably what's going on.

     

    i've deleted what's on the ehd. (it's backed up on another ehd, so i'm safe) now i'll run a new full backup and be sure to do incremental ones weekly. will that be frequent enough?

    Should be.  If not, post back and we'll dig a bit deeper.

     

    If it does fail again, make a screenshot of the message, and see #C4 in Time Machine - Troubleshooting, or post it here and we'll dig deeper.

     

    Cheers!