Previous 1 2 3 4 5 Next 56 Replies Latest reply: Oct 1, 2013 9:14 AM by tobiamoo Go to original post
  • thawn1 Level 1 (20 points)

    For me, creating/editing /etc/fstab did not work as described above. I had to replace LABEL=... with UUID=

    and use the Volume uuid that I got by typing:

     

    diskutil info /Volumes/<LabelOfYourDrive>

     

    into a terminal.

     

    source:http://www.livingit.de/?p=1280

  • XDvenom Level 1 (0 points)

    Hey Thawn1 does your method

    For me, creating/editing /etc/fstab did not work as described above. I had to replace LABEL=... with UUID=

    and use the Volume uuid that I got by typing:

     

    diskutil info /Volumes/<LabelOfYourDrive>

     

    into a terminal.

     

    still work with the newest version of mountain lion 10.8.4 can u able to reply to me please well if you get it please

  • XDvenom Level 1 (0 points)

    Hey Thawn1 does your method

    For me, creating/editing /etc/fstab did not work as described above. I had to replace LABEL=... with UUID=

    and use the Volume uuid that I got by typing:

     

    diskutil info /Volumes/<LabelOfYourDrive>

     

    into a terminal.

     

    still work with the newest version of mountain lion 10.8.4 can u able to reply to me please well if you get it please

  • XDvenom Level 1 (0 points)

    i started another discussion about if that solution work now for the new version of mountain lion 10.8.4

  • thawn1 Level 1 (20 points)

    I just updated to 10.8.4 and I can still write to my external NTFS formatted USB disk, so yes, this method still works.

  • XDvenom Level 1 (0 points)

    do u have skype at all to talk about it private?? i need ask u more info

  • thawn1 Level 1 (20 points)

    I just put up some step-by-step instructions that should help:

    1. plug your drive in (I'll assume it is labeled "Data", you can find out the label by opening disk utility)
    2. open a terminal window
    3. type (replace Data with the name of your drive):
      diskutil info /Volumes/Data | grep UUID
    4. copy the volume uuid (in this example :EF6B132A-A6AD-43F1-B571-3C4B3CD79619)
    5. type (all on one line and the quotation marks must be exactly where they are):
      sudo echo "UUID=EF6B132A-A6AD-43F1-B571-3C4B3CD79619 none ntfs rw,auto,nobrowse" >> /etc/fstab
    6. reboot
    7. the disk will not show up in your finder or on the desktop. The reason for that is the nobrowse option which is necessary for this to work in OSX 10.8.x. Personally, I think this is just harassment by Apple. To access the disk, you need to open a terminal and type:
      open /Volumes/Data
    8. voila, a finder window showing your disk will open and will allow you to write to the disk.

     

    Message was edited by: thawn1

  • XDvenom Level 1 (0 points)

    all 1 line with no spaces

  • thawn1 Level 1 (20 points)

    Please stick to one chat.

    I'll only reply here:

     

    https://discussions.apple.com/message/22217451#22217451

  • Yaddi Level 1 (0 points)

    Thank you. It works well on the newest version of mountain lion 10.8.4. Anybody who found it did not work should be aware of no quotes or spaces appeared on LABEL value. Moreover, you may add Macintosh HD\Volumes to Favorites of the Finder, then it will turn out so convenient. As the Volumes folder is hidden, you need to search it with File visbility in invisible items, just via "Find".

     

    Have fun.

  • kauaimu Level 1 (0 points)

    Brillian, Soha! This is by far the best solution. I followed it to a T, it worked like a charm. Thank you so much.

  • tobiamoo Level 1 (0 points)

    Hello,

     

    I have repeated all the steps you suggested several times over but still no luck.

     

    When i unmount and remount my hard drive, it still shows up on my desktop and in the Finder window. And of course, i still can't write on it.

     

     

    Any more suggestions?

     

    PS. My Mac runs OSX 10.8.5

  • thawn1 Level 1 (20 points)

    Without telling us which steps you did exactly, it will be hard to help you.

     

    Note that the LABEL= method only works for labels without spaces.

  • edoardoc Level 1 (10 points)

    I have been using Mountain Lion and NTFS disks without issues for long.

     

    Install Fuse for OS X first - well maintained project : http://osxfuse.github.io/

     

    Then I installed NTFS-3G

    I'm running 2010.10.2 from http://sourceforge.net/projects/catacombae/)

    seems a bit out of date but works well for me.

     

    I have not tried yet NTFS for Mac OS X   http://ntfsosx.sourceforge.net/

     

    HTH Edoardo

     

    ETA: I forgot, a patch called fuse_wait may help

    details here : https://github.com/osxfuse/osxfuse/wiki/NTFS-3G


  • tobiamoo Level 1 (0 points)

    Well i have tried to use both the LABEL= method and the UUID= method to no avail.

     

    My hard drive does have a space between its label, could that be the problem?