8 Replies Latest reply: Jun 11, 2013 5:33 PM by ChrisJ4203
Majestic2 Level 1 Level 1 (0 points)

I'm trying to install iOS 6.1.2 on my iphone 4s (currently 5.1.1) running OSX 10.7.5 and iTunes 10.7.  I get a message " the iPhone could not be updated. This device isn't eligible for the requested build"  Is it my system or iTunes that's stopping me?


iPhone 4S, iOS 5.1.1, OSX 10.7.5 iTunes 10.7