Skip navigation

My Aperture won't open

1500 Views 6 Replies Latest reply: Jun 11, 2013 7:09 PM by mary janehomeandaway RSS
mary janehomeandaway Calculating status...
Currently Being Moderated
Jun 7, 2013 1:23 AM

The Warning I am getting says;


"/Users/maryjanebarry/pictures/Aperture.aplibrary" cannot be loaded because it is from a newer version of Aperture.


I have updated latest version of Aperture since the warning. I have tried clicking on Aperture in Finder, same warning.

Help please

MacBook Pro, Mac OS X (10.7.5)
  • firstlaunch Level 3 Level 3 (610 points)
    Currently Being Moderated
    Jun 7, 2013 9:57 AM (in response to mary janehomeandaway)

    Have you tried to open a new library by holding down the option key on launch?


    I suggest opening 2 finder windows. One finder window displaying your Aperture application and the other displaying your Aperture library. Then, select each one to confirm they both show the same version in the info area (or command+i to get info). Once you know for sure they are the same, drag that library onto the Aperture application in that folder.


    I suggest making sure your Aperture and systems are updated to the latest.

  • léonie Level 8 Level 8 (46,330 points)
    Currently Being Moderated
    Jun 7, 2013 11:18 PM (in response to mary janehomeandaway)

    Trash Aperture's "preferences" file: it may be locked to a wrong library.


    Then try to double click your Aperture library to open it directly.


    Remove the Aperture's user preferences from the User Library as described here:

    Aperture 3: Troubleshooting Basics




    Your User Library is hidden by default in 10.7.5 - to open it in a Finder window use the "Go" menu from the Finder's main menu bar.

    • Quit Aperture, if it is running. Log off and on again.
    • Open the user library by using the Finder's "Go > Go to Folder" menu and hold down the options-key, until "Library" appears in the drop down menu. Select it.
    • In the widow that will open, scroll down to "Preferences"
    • From the "Preferences" folder  remove "".

    Then try to launch Aperture again.


    But deleting the "Preferences" file will cause Aperture to forget the preferences settings. Be prepared to have to reset all options you set using the Aperture Preferences panel.




  • firstlaunch Level 3 Level 3 (610 points)
    Currently Being Moderated
    Jun 9, 2013 10:13 PM (in response to mary janehomeandaway)

    Hi Mary,


    Did you get your libray to open? You might try upgrading Aperture to 3.4.5 and then try opening it.


More Like This

  • Retrieving data ...

Bookmarked By (0)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.