Skip navigation

Disable account but keep e-mail visible

6181 Views 9 Replies Latest reply: Jun 12, 2013 10:27 AM by Eddie000 RSS
diggy123 Level 1 Level 1 (0 points)
Currently Being Moderated
Jan 25, 2012 9:30 AM

Hey guys & girls

 

I'm using the latest Mail app for my emails and until now I've been using POP3 account. I have loads of e-mails and also sent items, which i need to keep.

 

Just today however I did an IMAP account. From now on, i will use this one instead. However I need to jump back and worth to see e-mails i have recieved yesterday and so on. If I disable the account in prefs, it will remove it from the view. If I enable it, for some reasons, all the emails sent will be using this old account. I can not change this so it would use the new IMAP account.

 

Just to make sure, I have the same e-mail address, just changed POP3 to IMAP.

 

Is there a way ti disable the account (no more checkin mails and using it to send mails) but keep my inbox and sent items still visible?

 

thanks!

macbook, Mac OS X (10.6.4)
  • kurt188 Level 4 Level 4 (1,325 points)
    Currently Being Moderated
    Jan 25, 2012 11:45 AM (in response to diggy123)

    ´╗┐Is there a way ti disable the account (no more checkin mails and using it to send mails) but keep my inbox and sent items still visible?

    Yes, but it does involve some work.

     

    First, you need to move (not copy) the folder for that POP account to your Desktop. Then, in Mail's preferences, delete that POP account entirely. Now you can setup the account as IMAP (although I think you'll regret that in the long run) and let it retrieve whatever email is currently there.

     

    Next, you need to go to File->Import Mailboxes… and navigate to and select the folder that contains the POP mailbox for the messages you want to import; for example: /Desktop/POP-xxxx@xxxxx.com/INBOX.mbox/Messages and click Choose to proceed with the process.

     

    When that's done, you'll have an 'Imported' mailbox in Mail, after which you need to create your own new mailbox for those old messages from your Inbox and label it Old Inbox, or something to that effect. Then go to the Imported mailbox and Select All messages in there and drag them onto the icon for the new mailbox you just created for them; they should now all be moved into that mailbox.

     

    Now you can go back and import the other mailboxes (Sent, Drafts, Deleted, etc if you like) one-at-a-time, stopping after each one to create a new mailbox for them and moving the messages into them before proceeding with the next one.

     

    When you're done with that, you can delete the 'Imported' folder(s), then quit Mail and restart it to see if everything is still the way you want it to be. If so, then you can delete the POP account folder you moved to your Desktop previously.

  • Camelot Level 8 Level 8 (45,670 points)
    Currently Being Moderated
    Jan 25, 2012 12:13 PM (in response to diggy123)

    Your question doesn't make much sense.

     

    If I enable it, for some reasons, all the emails sent will be using this old account. I can not change this so it would use the new IMAP account.

     

    Outgoing mail doesn't use POP or IMAP, it uses SMTP. Therefore it should not matter what accounts you have set (POP or SMTP) all mail will go out using the SMTP settings.

     

    Your problem might be related to the fact that you have the same email address set in both accounts. That's a no-no. You should change the email address in your POP account to some dummy account and turn off automatic checking of mail in that account. Then only the IMAP account will actively download mail and your outgoing mail should be fine.

  • X423424X Level 6 Level 6 (14,190 points)
    Currently Being Moderated
    Jan 25, 2012 12:27 PM (in response to diggy123)

    Is there a way ti disable the account (no more checkin mails and using it to send mails) but keep my inbox and sent items still visible?

     

    The simplest way to disable an account while still keeping it in the list of accounts (and having access to its maileboxes, etc.) is to go into the Accounts preferences, select the desired account, click the Advanced tab, and then uncheck the checkbox for 'Enable this account".

  • Jonathan Rose Calculating status...
    Currently Being Moderated
    May 30, 2012 12:39 PM (in response to X423424X)

    Actually, X42342X, that's the source of the problem.  If you uncheck the account, the account disappears in Mail along with all the mail folders. 

  • Camelot Level 8 Level 8 (45,670 points)
    Currently Being Moderated
    May 30, 2012 12:53 PM (in response to X423424X)

    You can prevent any account from sending mail via:

     

    Mail -> Preferences -> Accounts -> (this account -> Outgoing Mail Server -> (none)

     

    also check the 'use only this server) checkbox and you're done - this account now cannot send any mail since it doesn't have a SMTP server configured.

     

    As for getting mail, just disable automatic checking for mail under the Advanced tab. Clearing (or setting an invalid) password will ensure that you don't accidently retrieve mail for this account, either.

  • X423424X Level 6 Level 6 (14,190 points)
    Currently Being Moderated
    May 30, 2012 1:04 PM (in response to Jonathan Rose)

    Jonathan Rose wrote:

     

    Actually, X42342X, that's the source of the problem.  If you uncheck the account, the account disappears in Mail along with all the mail folders. 

     

    That's wrong.  It only disables the account.  It doesn't delete it.  Just tried it on my own account.  Unchecked the "Enable this account" and that is all it does.

     

    The only way I know of to to delete an account is in the Mail Accounts preferences where you select an account and click the minus in the bottom left of the Accounts window.

  • Jonathan Rose Level 1 Level 1 (60 points)
    Currently Being Moderated
    May 30, 2012 3:53 PM (in response to X423424X)

    Interesting.  I am using Mail 5.2, OS 10.7.2. When I unclick "enable this account" under Inbox the Mail inbox that had all my previous emails disappears.  You are right that it's not deleted as when I click enable this account, the inbox that has all my mail re-appears.

     

    I wonder why mine is different? 

     

    Incidentally, to the original poster, I highlighted all 12,000 of my inbox messages, and temporarily moved them to a new mailbox I called Temp Inbox.  Then I unclicked "enable this account", and the previous inbox disappeared. I did Apple A to highlight all the messages in the Temp Inbox and moved them to the new IMAP inbox.

  • X423424X Level 6 Level 6 (14,190 points)
    Currently Being Moderated
    May 30, 2012 5:16 PM (in response to Jonathan Rose)

    I wonder why mine is different? 

     

    Probably because I still use Snow Leopard, not Lion.

  • Eddie000 Calculating status...
    Currently Being Moderated
    Jun 12, 2013 10:27 AM (in response to kurt188)

    Hi, I realise this is an old thread but, I have followed your instruction and all seems fine until I move the emails to their final 'old emails' destination. When I try to move them my mail activity box I have displaying informs me that they have  all become 'outgoing messages' and look like they are sending!!!  I cancelled quickly but are they really all being sent???

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.