Skip navigation

Has anyone got slow browsers after updating to 10.8.4

716 Views 5 Replies Latest reply: Aug 9, 2013 5:02 AM by jaredfromlebanon RSS
bratman91 Level 1 Level 1 (125 points)
Currently Being Moderated
Jun 7, 2013 6:43 AM

In the last couple of days, both Safari and Firefox have shown very "jerky" performance - sometimes pages load very quickly, at other times loading stalls for a while and then restarts. With Safari, I get a spinning ball until the blockage clears itself. Running my ISP's (BTInternet) own speedtest when this stalling occurs, shows a speed near to dial-up whereas it should be near 30+Mb as I am on fibre. As soon as the stall clears, the speed reverts to normal.

 

CPU useage, memory, disc space etc are all normal, I have tried rebooting the modem and router, and changing from wifi to ethernet (via Powerline adapters) has no effect. This seems to have happened after updating to 10.8.4 but, given that everthing else seems to be working properly, I am reluctant to blame this, and suspect my ISP and/or its modem or router. Has anyone else noticed problems with their browsers since 10.8.4 and, if so, found a cure?

iMac (21.5-inch, Late 2012), OS X Mountain Lion (10.8.3)

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.