Skip navigation

Why does iTunes delete my itunesprefs.xml?

23040 Views 228 Replies Latest reply: Mar 2, 2014 7:35 PM by laurenfaffler RSS Branched to a new discussion.
1 2 3 ... 16 Previous Next
iJimB Calculating status...
Currently Being Moderated
Jun 11, 2013 11:20 AM

Every time I open iTunes I have to agree to the License Agreement.


This started happening around the time I upgraded to iTunes


I have Windows 7, so I moved and let iTunes recreate the C:\Users\<UserName>\AppData\Local\Apple Computer\iTunes directory, but this has not helped.


Then, I notice that whenever I quit iTunes the file itunesprefs.xml is deleted. Is this normal?




Windows 7
  • _racerx_ Level 1 Level 1 (20 points)
    Currently Being Moderated
    Jun 11, 2013 6:38 PM (in response to iJimB)

    I don’t think this is isolated to v11.0.4, I’m seeing the same behavior on two different Win7 64bit system running iTunes 11.0.3


    For me, it started yesterday morning (6-10-2013) when I went into iTunes still using v11.0.3.  After opening iTunes, I was prompted to agree to the license agreement; once iTunes opens the GUI is reverted to the default state, and opened up the tutorial window.  Also, all settings are wiped out, like the GUI settings (like Sidebar, status bar, etc.); the device sync settings; and the preferences.


    I decided to see if the latest iTunes version would corrected this, and after updating  to I still have the same behavior. 

  • jethronj Calculating status...
    Currently Being Moderated
    Jun 15, 2013 10:16 AM (in response to iJimB)

    I'm having the exact same problem ever since I upgraded to 11.0.4.  Sometimes it asks for me to agree to the license agreement and other times it takes me directly to the tutorial.  Each time it resets my preferences (side bar and some syncing preferences).  I tried reinstalling but that did not work.


    Using Windows 7 as well.


    I'm looking for a solution to fix this!!!

  • _racerx_ Level 1 Level 1 (20 points)
    Currently Being Moderated
    Jun 15, 2013 12:02 PM (in response to jethronj)

    I haven't found a fix yet, but I suspect it's a McAfee Total Protection issue (are you both using McAfee?).

    I found that if I disable real time scanning (temporarily, just long enough the test/verify it's the problem).


    With real time scanning off, the file isn’t deleted after iTunes is closed, and the settings are saved between iTunes sessions.


    I believe it’s a setting in McAfee, because I have three system (All Win7 64bit), two of them have the problem and one doesn’t.  The one that works, when I updated iTunes to v11.0.4, after the restart and when iTunes was opened, McAfee properly prompted for permission to allow iTunes access.


    The two systems that don’t work, I never received the McAfee prompt.

  • danw2013 Calculating status...
    Currently Being Moderated
    Jun 15, 2013 2:58 PM (in response to _racerx_)

    I seem to have this same problem (files deleted while McAfee is on resulting in repeated request to agree to software license agreement).  I've been on the phone with McAfee (issue was elevated).  They say that McAfee should not delete a file without prompting the user to remove the file.  They sent me back to iTunes.  It seems like this should be a McAfee setting.  I've tried installing and reinstalling iTunes with no change.  Any idea how to cause McAfee to prompt?

  • _racerx_ Level 1 Level 1 (20 points)
    Currently Being Moderated
    Jun 15, 2013 9:44 PM (in response to danw2013)

    I would get back on the phone with McAfee and point them to this post.


    Demonstrate to the L2 how the file isn't deleted when real time scanning is turned off.  You can prove this by starting and closing iTunes several times for them with real time off.


    Then turn on real time scanning and typically on the 2nd or 3rd re-start of iTunes, the file is removed (you may need to hit refresh to see this).


    Also, technically, the file isn't deleted, at least not in the sense like you manually deleted a file, because the file isn't placed in the recycle bin.


    I would also have them demonstrate exactly how McAfee would prompt you if it were going to delete a file.  Sounds like a line of BS to me, because McAfee would place the file in quarantine first (problem with McAfee however is that you are not prompted when it has quarantined a file, bad design IMO).


    I also uninstalled McAfee, and run the McAfee Removal Tool (to make sure McAfee was completely removed, per this link:


    Once McAfee was removed, I had no problems with iTunes, (settings saved as expected).


    I reinstalled McAfee, and the problem with the iTunesPrefs.xml returned


    McAfee should be able to determine that it's an issue in real time scan pretty easily.

  • _racerx_ Level 1 Level 1 (20 points)
    Currently Being Moderated
    Jun 16, 2013 6:29 PM (in response to danw2013)

    Still no fix, problem appears to be with an incompatibility with McAfee's latest version and both iTunes 11.0.3 and 11.0.4.  I’m not sure if it’s the engine files or something else at this point.


    I have done some further testing, and on the system that was working properly, I uninstalled McAfee, than reinstalled it to the latest version directly from my McAfee Account.  Once the reinstall was complete, the problem of the disappearing iTunesPrefs.xml file was now on this system.


    Just to keep the record straight, I installed the latest McAfee Total Protection (Build 12.1.338, .engine is 1558.  The install is everything except for the features I don’t need or want (File Locker, Online Backup, Parental Controls or the Vulnerability Scanner).

  • danw2013 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jun 16, 2013 6:45 PM (in response to _racerx_)

    I talked with level 2 McAfee support today for about 30 minutes.  I demonstrated the problem (and pointed them to this discussion).  They recorded some of the information from my computer and are sending it to their R&D group.  It seems like they recognize that it's a problem with McAfee.  They say I should hear back tomorrow.  It doesn't seem like it should be too hard a fix, so I'm hopeful that they will resove it.

  • _racerx_ Level 1 Level 1 (20 points)
    Currently Being Moderated
    Jun 17, 2013 5:49 AM (in response to danw2013)



    Please keep us posted on what they suggest and/or what us to do.


    I haven't been able to contact McAfee directly, since I have been working really strange hours as of late.


    I'm thinking that McAfee will push out a new build via the auto-update and this will fix the problem.

  • turingtest2 Level 8 Level 8 (43,955 points)
    Currently Being Moderated
    Jun 17, 2013 5:57 AM (in response to _racerx_)

    This sounds similar to a problem that AVG appeared to be causing with the main library files recently. iTunes would create a new temporary copy of the library, delete the original and then attempt to rename the temporary file. AVG would hold up the rename and iTunes wouldn't check to make sure the operation was completed. Restart iTunes, and boom! empty library. In that case excluding the iTunes folder from real-time scanning didn't help which is odd.


    Have you tried excluding the  C:\Users\<UserName>\AppData\Local\Apple Computer\iTunes folder from McAfee's scanner?



  • turingtest2 Level 8 Level 8 (43,955 points)
    Currently Being Moderated
    Jun 17, 2013 6:17 AM (in response to turingtest2)

    BTW I've noticed a few other posts regarding having to repeatedly reset preferences recently. In the past this has sometimes been triggered by a problem where the prefs file isn't updated properly, so deleting it is what you would want to do. However now that I've seen this thread I can ask others if they too are running McAfee. Thanks.



  • danw2013 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jun 17, 2013 4:58 PM (in response to iJimB)

    Just got off the phone with McAfee.  The representative said that they're investigating the issue and will provide an update tomorrow.  He did mention the possibility of an issue with my system, but he said that they're still looking for a solution.  I hope we didn't stump them.

  • _racerx_ Level 1 Level 1 (20 points)
    Currently Being Moderated
    Jun 17, 2013 7:17 PM (in response to danw2013)



    Thanks for the update.  A new dat update went out today (build 1559) but this DID NOT resolve the issue yet.


    Hopefully, McAfee can resolve this soon.


    One question to you, when they said they will provide an update tomorrow, is that a status update of your open case or an update that is being pushed out by McAfee?



1 2 3 ... 16 Previous Next


More Like This

  • Retrieving data ...

Bookmarked By (10)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.