Skip navigation

New Macbook Air - wifi connectivity problems

447945 Views 2,058 Replies Latest reply: Apr 20, 2014 8:24 AM by hunberry RSS Branched to a new discussion.
  • Tmess85 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jun 18, 2013 7:40 AM (in response to Hijej)

    I'm also experiencing the same problem on a brand new haswell macbook air. Kind of a bummer to wait almost five years to get a new computer, then open the box last night, and not be able to connect to the internet for longer than 2-3 minutes. Also have plenty of other apple devices (macbook pro, ipad, iphone, apple tv connected to my router). At any rate, I'm going to the apple store today at 2pm eastern, so i will be sure to post the results of that genius appointment to this board. i'm guessing this is a hardware issue and they will likely have to replace the computer.

  • jimlip23 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jun 18, 2013 8:03 AM (in response to Tmess85)

    I'm pretty sure I can tell you how it will go.. when you get to the store, they will join their network and it will work great.. that'll prove it isn't a hardware issue which leaves softwear conflict or your home network.. they'll tell you to try doing new install and they'll check out your settings and give you some things to try at home. They'll likely suggest you get home and call apple support to figure out what is causing it on your network because as you can see, it works fine on their network. Like you though, I have purchased recently enough that I can simply return and buy another and hope it was hardware/fluke related and take my chances with the next.... I tried a few more things last eve (changing channels yet again and restarting the network etc) with no luck.. however, I then turned on my iphone hotspot and connected to that and was able to surf with no hangups. So I know it's something on the network, but I don't know what and Apple support wasn't able to solve in my first go around with them.

     

    Good luck later today... let us know how it goes.

  • gmc74 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jun 18, 2013 8:20 AM (in response to Hijej)

    I cancelled my appt.  I moved it until today, and then ended up cancelling it.

     

    After contacting Apple Support, I received an email from an Apple Engineer that wanted to look at log files, so I sent him a bunch of data.

     

    I have narrowed my issue down to 802.11g networks.  My router runs at 11g, and a back up router runs 11g.  I have issues with both of them.  When I share my connection from my MacBook Pro (11n), I don't seem to have the same issue.

     

    It appears that when it disconnects from 802.11g, it doesn't reconnect.  When it disconnects from 802.11n, it reconnects before I even notice.  If wifi diagnostics isn't monitoring it, I wouldn't know that it dropped from 802.11n.

     

    I am going to pick up a new airport extreme and see if that resolves it at home.  Hopefully they will resolve it soon, seems like a firmware issue to me.

  • jimlip23 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jun 18, 2013 8:32 AM (in response to gmc74)

    Will you replace one of your routers with that or just have the xtreme join the network as an access point? If you do that, do you give the extreme a different network name and join that with your mba?

     

    I thought of that option and am willing to shell out yet another $200, but I'm not sure how the setup goes and I can't easily replace/reprogram my netgear router.

  • Chatran Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jun 18, 2013 8:39 AM (in response to vhkim)

    Could you guys check to see if wifi works when it is not placed on a flat surface?

     

    I saw a review here:

     

    http://www.gizmodo.co.uk/2013/06/13-inch-macbook-air-2013-review-well-hello-batt ery-life/

     

    This Is Weird

    The Wi-Fi signal seems to struggle a little when the Air’s put down on a desk. It’s not massive, but it can make the difference between having one bar of internet and staring at your failed-to-upload-GIFs in frustration. It’s almost certainly a result of the antenna being in that plastic strip along the bottom of the screen, which is then shielded a little when the Air’s down flat on a desk. Not sure what to do about it other than switch to using my Ethern–oh, wait.

     

  • jimlip23 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jun 18, 2013 8:43 AM (in response to Chatran)

    I read that and tried it.. I didn't find any difference. Regardless of position (on desk, in lap) when it hangs, it is still connected to the router and it doesn't go to the blank screen announcing not connected to the internet.. it just hangs there....forever. And again, on my iphone hotspot or on the wifi in the apple store it works flawlessly..

  • gmc74 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jun 18, 2013 8:44 AM (in response to jimlip23)

    I will replace my router with the Airport Extreme, and hopefully that resolves the issue for me.

  • gmc74 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jun 18, 2013 8:45 AM (in response to Chatran)

    yeah, I have the same results as jimlip23, this doesn't seem to be related

  • wifiguru Level 2 Level 2 (230 points)
    Currently Being Moderated
    Jun 18, 2013 11:23 AM (in response to Tmess85)

    What router are you using ? Please list the firmware version too and check if you have the latest updates.

     

    It would help if all of you guys always posted your router make/model so anyone else who came to this thread can check if there is an issue with any one brand of routers. Just a suggestion

  • wifiguru Level 2 Level 2 (230 points)
    Currently Being Moderated
    Jun 18, 2013 11:26 AM (in response to Fred Braches)

    That doesn't sound right. Can you post a screenshot ? When i use it, as long as WiFi is turned on, the Continue button is always enabled and I can gather logs.

  • Hijej Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jun 18, 2013 11:39 AM (in response to wifiguru)

    Mine are:

     

    Cisco WAP4410N with 2.0.6.1

    Linksys WRT54GL with 4.30.16

    Linksys WAG160Nv2 with 2.00.20

     

    So all of them have the newest firmware, all of them are 2.4GHz, and I have problems not only with G but also with N.

  • gmc74 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jun 18, 2013 12:14 PM (in response to Hijej)

    So far, the only thing I have not had an issue with is using my MacBook Pro with Internet Sharing on, that shares an 802.11n 2.4ghz network.

     

    My n router defaults back to g because it is old and some g devices connect to it.  Out of curiosity, Hijej, do you see PHY Mode 802.11n or 802.11g when you option click the wifi icon?

     

    My other network is aso 802.11n, but it reverts to g when I connect.

    Screen Shot 2013-06-18 at 12.13.00 PM.png

  • theliuman Calculating status...
    Currently Being Moderated
    Jun 18, 2013 12:16 PM (in response to vhkim)

    Just got my new Haswell Macbook Air 13" yesterday, having the same problems as everyone else.  This is my 3rd Air and I've never had any wifi issues in the past.

     

    At different hotspots (2.4GHz most likely), wifi signal drops constantly (between 10 seconds and 20 min). 

    At home (5GHz, Airport Express, latest firmware 7.6.3), wifi signal drops rarely.

     

    Extremely annoying since I am constantly out-and-about and rarely home during work hours.  I used Migration Assistant from my previous 2012 Macbook Air.

     

    I would go to the Genius Bar and perhaps get a new system, but I got the CPU upgrade so I don't think they have those models readily available.

     

    I really hope Apple releases a firmware update for the new wireless chipset soon, because this is a dealbreaker.

  • Hijej Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jun 18, 2013 12:31 PM (in response to gmc74)

    gmc74: PHY mode is 802.11n and router is set to "N Only"

  • gmc74 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jun 18, 2013 12:36 PM (in response to Hijej)

    That is a bummer, I am giving this until the end of the week, then I am returning it.  It seems to work fine with other Apple hardware, but the world doesn't use other apple hardware, like the hotel I will be at next week...

1 ... 4 5 6 7 8 ... 138 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (72)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.