Skip navigation

Aperture crashed twice today.  Comments?

1328 Views 16 Replies Latest reply: Jul 6, 2013 8:43 PM by Kirby Krieger RSS
1 2 Previous Next
Kirby Krieger Level 6 Level 6 (11,595 points)
Currently Being Moderated
Jun 4, 2013 4:17 PM

Aperture crashed twice on me today.  Have since repaired the Library.  Once was while using BorderFX.  The other time I was building a complex filter in Places View.  It's been a while since Aperture has outright crashed on me.  Snips from crash logs below.  Thanks.

 

Process:         Aperture [7250]

Path:            /Applications/Aperture.app/Contents/MacOS/Aperture

Identifier:      com.apple.Aperture

Version:         3.4.4 (3.4.4)

Build Info:      Aperture-320085000000000~3

Code Type:       X86-64 (Native)

Parent Process:  launchd [193]

User ID:         501

 

 

PlugIn Path:       /Library/Application Support/Aperture/*/BorderFXEditPlugin

PlugIn Identifier: com.iborderfx.BorderFXEdit

PlugIn Version:    1.8.0 (401)

 

 

Date/Time:       2013-06-04 18:36:40.794 -0400

OS Version:      Mac OS X 10.8.3 (12D78)

Report Version:  10

 

 

Crashed Thread:  0  Dispatch queue: com.apple.main-thread

 

 

Exception Type:  EXC_BREAKPOINT (SIGTRAP)

Exception Codes: 0x0000000000000002, 0x0000000000000000

 

 

Application Specific Information:

*** CFRelease() called with NULL ***

Performing @selector(setFontFamilyAction:) from sender IFFontPopUpButton 0x7fd2ba9de8a0

 

 

Thread 0 Crashed:: Dispatch queue: com.apple.main-thread

Process:         Aperture [6883]

Path:            /Applications/Aperture.app/Contents/MacOS/Aperture

Identifier:      com.apple.Aperture

Version:         3.4.4 (3.4.4)

Build Info:      Aperture-320085000000000~3

Code Type:       X86-64 (Native)

Parent Process:  launchd [193]

User ID:         501

 

 

Date/Time:       2013-06-04 17:27:26.687 -0400

OS Version:      Mac OS X 10.8.3 (12D78)

Report Version:  10

 

 

Crashed Thread:  0  Dispatch queue: com.apple.main-thread

 

 

Exception Type:  EXC_BAD_ACCESS (SIGSEGV)

Exception Codes: EXC_I386_GPFLT

 

 

Application Specific Information:

objc_msgSend() selector name: retain

 

 

 

 

Thread 0 Crashed:: Dispatch queue: com.apple.main-thread

MacBook Pro (Retina, Mid 2012), OS X Mountain Lion, 16 GB RAM; 500 GB SSD; NEC; Munki
  • léonie Level 8 Level 8 (46,760 points)
    Currently Being Moderated
    Jun 4, 2013 11:09 PM (in response to Kirby Krieger)

    Comments?

    Kirby,

    I tried to reproduce the BorderFX crash, and sure enough, it crashed on me too!

    Application Specific Information:

    *** CFRelease() called with NULL ***

    Performing @selector(setFontFamilyAction:) from sender IFFontPopUpButton 0x7fd2ba9de8a0

    BorderFX works well for me, as long as do not try to change the Font used in the captions. Is that what you have been doing too? Changing the font? I have no time right now, to experiment with different fonts, but it may be a question of missing or duplicate fonts.

    Can you save images back to Aperture at all, as long as you are sticking with the default fonts (not as beautiful as your usual signature - I know!)

     

    Regards

    Léonie

     

    PlugIn Path:       /Library/Application Support/Aperture/*/BorderFXEditPlugin

    PlugIn Identifier: com.iborderfx.BorderFXEdit

    PlugIn Version:    1.7.1 (380)

     

    Date/Time:       2013-06-05 08:06:15.933 +0200

    OS Version:      Mac OS X 10.8.3 (12D78)

    Report Version:  10

     

    It crashed, after selecting Font Apple Cnancery, then adding a caption.

  • léonie Level 8 Level 8 (46,760 points)
    Currently Being Moderated
    Jun 5, 2013 7:48 AM (in response to léonie)

    In the meantime I installed the MacOS X 10.8.4 update and now BorderFX stopped crashing. Maybe it is just a coincidence.

  • léonie Level 8 Level 8 (46,760 points)
    Currently Being Moderated
    Jun 5, 2013 11:38 AM (in response to Kirby Krieger)

    Gern geschehen, Kirby!

     

    The other time I was building a complex filter in Places View.

    What kind of rules did you use in Places view, when it crashed? Related to Pleces, or completely different rules?

  • Frank Caggiano Level 7 Level 7 (22,905 points)
    Currently Being Moderated
    Jun 20, 2013 6:24 PM (in response to Kirby Krieger)

    So had the crashes stopped (first post was from the begining of June) and started again ot have there been crashes all along?

     

    Standard stuff: Before the crashes started was anything added to or changed on the system? Any other problems with the system?

     

    Is this the new MBP that is crashing?

     

    While the whole crash report probably won;t help post it anyway who knows. Also download and run EtreCheck and post the results. Might help.

     

    regards

  • léonie Level 8 Level 8 (46,760 points)
    Currently Being Moderated
    Jun 21, 2013 12:22 AM (in response to Kirby Krieger)

    kirby,

    it looks like we are still in the same boat:

    Application Specific Information:

    *** CFRetain() called with NULL ***

    Performing @selector(closeDateFormatterSheet:) from sender NSButton 0x7fbce19cbc90

    Now BorderFX is working for me fine, when I am changing the font to Apple Chancery, but changing the date using the Date Formatter will cause it to crash, as soon as I close the formatter panel.

     

    For the time being, I am using the date format as set in the system Preferences.

     

    Aperture 3.4.5, ApertureBorderFX-1.7.1_380.dmg

    MacBook Pro (17-inch Late 2011), OS X Mountain Lion (10.8.4), 2.4 GHz i7, 16GB, 500GB SSD,1TB HD
  • léonie Level 8 Level 8 (46,760 points)
    Currently Being Moderated
    Jun 21, 2013 5:27 AM (in response to Kirby Krieger)

    Thanks for the link to the update, Kirby. I missed that one.

     

    I can change the font size - for me the default shown is 24. When I change the size, Aperture crashes.

     

    I will install the version you are using and test again.

     

    Where are you changing the font size? I am using the brick created by "add metadata". There is no slider, but only stepping arrows.

  • léonie Level 8 Level 8 (46,760 points)
    Currently Being Moderated
    Jun 21, 2013 6:36 AM (in response to Kirby Krieger)

    Nice, I never noticed that the value slider slides. The arrow tips ar so close to the numbers. I always set it by clicking the arrow tips.

    I am now on version 1.8.0_401.  The matadata field do not work any longer: The exported image shows different text than set in the plug-in.

    And I can slide font size the value slider and set it to any value, but the value will be ignored.

     

    With these setting,

    Screen Shot 2013-06-21 at 15.28.09.PNG

    This image will be exported to Aperture.

    Screen Shot 2013-06-21 at 15.18.37.PNG

    The font is much to small and completely different tags are displayed.

     

     

    Just to be sure that we are testing the same thing - are you testing the export plug-in or the edit-plug-in?  My results are for the edit-plug-in.

  • Reinhard Uebel Calculating status...
    Currently Being Moderated
    Jun 22, 2013 4:32 AM (in response to Kirby Krieger)

    I have been looking into the crashes discussed above, from what I can tell, they seem to be related to missing or disabled fonts. I have not been able to reproduce the crash on my machine, but I have reproduced the same crash if I simulate a missing font in the code.

    I have tested the meta-data text, and it is not working in the latest version, I will fix this in the next release.

    I hope to have a new version released in the next few days.

1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.