1 2 3 4 5 Previous Next 74 Replies Latest reply: Mar 23, 2014 4:05 AM by Marco Franco Go to original post
  • 60. Re: Setting date and time
    VRod007 Level 1 Level 1 (0 points)

    Had similar issues with my ATV2 not being able to set the date and time. I tried resetting, restoring, restarting and all would seem to get stuck at the setting date and time. I finally uplugged it and plugged it straight into my MacBook Pro with the micro usb cable (didn't even need the power cord). Through iTunes I clicked on Restore. iTunes took over and did a complete restore including a firmware update. Then when it finished it said to plug it back into the TV. When I did it asked me to set the language, set the wifi network and password (the usual startup stuff) and voilà! It works again.

     

    Hope this helps.

  • 61. Re: Setting date and time
    Holiq Hudairi Level 1 Level 1 (0 points)

    I was able to get my Apple TV working again by downgrading the firmware following the instructions in this message:

     

    https://discussions.apple.com/message/20008613#20008613

     

    In case that message disappears, here's my translation:

     

    1. Connect your Apple TV to your computer via USB. Don't plug in the power cable.

    2. Download the older 5.0.2 firmware from Apple here:

     

    5.0.2 (Apple TV 2): AppleTV2,1_5.0.2_9B830_Restore.ipsw

    5.0.2 (Apple TV 3): AppleTV3,1_5.0.2_9B830_Restore.ipsw

     

    3. Open iTunes and select the Apple TV. Hold down the option key and press the restore button at the same time.

    4. In the dialog that opens select the firmware that you downloaded.

    5. The restore process will take a few minutes. Once it's done plug your Apple TV back into your TV. If the date and time message persists just press the menu button to skip it. This got mine working again.

    Good luck !!!!

  • 62. Re: Setting date and time
    JamesHDenver Level 1 Level 1 (0 points)

    Thanks - this is the only way I've been able to get mine to come up, on the new firmware it will stay on setting time and date for days straight. Now if there was a way to stop it from asking to be upgraded right back!

  • 63. Re: Setting date and time
    Querie Level 1 Level 1 (0 points)

    Hi

    I tried this downgrading with no success.

    First, if I don't plug in the power cable, my ATV won't show up in iTunes at all. Then I did plug in the cable it showed up and I tried to reset using the older file, but I was told it was not compatible

  • 64. Re: Setting date and time
    shabshekan Level 1 Level 1 (0 points)

    Okay I finally found an easy and kinda great solution

     

    The problem is indeed about connectivity. It seems that during the Activating and Time setting process, the ATV has to connect to Apple or iTunes servers through a special port or connection.

    My device was definetely connected to the internet, because I could check and download new updates and all my other devices on the home network were connected to the internet but still it wouldn't get activated.

     

    So, today my Apple TV 3rd generation arrived and after setting everything up I also faced the "Setting Time and Date"-problem.

     

    First, the ATV was connected to my router via WiFi.

     

    Like everyone else's case the ATV would stuck on the "Activating - Setting Time and Location"-Screen.

    When I would skip the Activating screen there were only 2 buttons on the ATV Home Screen, "Computer" and "Settings".

    I did everything everyone suggested here, but it didn't work for me.

     

    Then I connected it via Ethernet, but still, same thing.

    I also let it go for a couple of hours, but still no luck.

     

    Then I did a really simple thing:

    I used the Personal Hotspot on my iPhone so the ATV would connect to the internet via my phone carrier.

    And bamm, after only seconds it worked!!

     

    After everything was loaded and I logged in with my Apple ID and turned Home Sharing on, I connected the ATV back to the router.

    Now everything works fine!

     

    As I described, there might be conflicts between the ATV, trying to use special ports, and your home internet connection.
    Since there are nearly no restrictions when you use your phone's data I thought that maybe that might be a solution which indeed was right!

     

    Hope this works for everybody and enjoy your ATV! ;

  • 65. Re: Setting date and time
    Querie Level 1 Level 1 (0 points)

    My problem seems to be that I don't use a router. I connect with Ethernet directly to the fiber-LAN media box in my apartment. I guess you can call it some kind of router, but it has only one connection for internet, LAN1.

    I don't want to use a router or WIFI because I think it slows speed down.

    My computer has 2 Ethernet inputs, so I thought I could connect the ATV to port 2 with no success.

    I found an option in the ATV to connect without internet, still no success.

  • 66. Re: Setting date and time
    markdavies Level 1 Level 1 (10 points)

    This issue vexed me for a long time.

     

    Credit for this solution goes to Ed Gainer, our network manager here at The Hun School of Princeton.

     

    HTH.

     

    :::

     

    Version update 5.2.1 (6025) seems to have changed the way its searches for time. According to the Apple website’s list of ports used by Apple, the time protocol NTP would normally communicate via TCP or UDP. This was the case in previous versions, but when the update for 5.2.1 was introduced, the Apple TV displayed a “Searching for Time and Date” indicator upon restart. The only remedy was to select “Menu” on the Apple Remote. At that point, the main menu now only displayed “Computers” and “Settings” options. All the icons for other online content options such as YouTube, HuluPlus, Vimeo, etc. were missing.

     

    After running a packet trace the ports, NTP (123), DNS (53) and ports 49152 – 65535 were used in booting the Apple TV. After some trial and error it appears that the Apple TV is searching for the time via the NTP protocol through UDP. When port 123 was opened in the firewall over TCP/UDP it still did not communicate. The solution was to specifically indicate the NTP protocol over UDP. Keeping the NTP protocol specified via TCP is also recommended.

     

    The resolution to this problem was to create a service group for Apple including the following services.

    Name

    Protocol

    Source Ports

    Destination Ports

    NTP

    UDP

    Default (0-65535)

    123

    http

    TCP

    49152-65535

    80

    https

    TCP

    49152-65535

    443

     

    Additionally, it is recommended to include these services in the group to encompass all of the Apple products in your environment.

    Name

    Protocol

    Source Ports

    Destination Ports

    NTP

    TCP

    Default (0-65535)

    123

    3689 (iTunes Library)

    TCP

    Default (0-65535)

    3689

    5353 (Apple TV iTunes)

    UDP

    Default (0-65535)

    5353

    Domain (DNS)

    TCP

    Default (0-65535)

    53

  • 67. Re: Setting date and time
    Querie Level 1 Level 1 (0 points)

    I bought me a switch, and it solved my problem.

    Make sure you set all the options in the ATV to automatic, using the MENU. Especially set timezone to be set automatic.

    Good Luck

  • 68. Re: Setting date and time
    mhaddadm Level 1 Level 1 (0 points)

    Thanks! Worked for me!

  • 69. Re: Setting date and time
    Leprechaun65 Level 1 Level 1 (0 points)

    Had several of the same symptoms reported in posts in this string -

         1) Stuck in 'setting date and time' on power on

         2) Press of menu key brought up only computers and settings icons

         3) In Settings, Location was blank (not United States for me as usual)

     

    Attempted ATV restart etc with no success.  All other devices in my case had no issues with connectivity, BUT simple reset of my router restored correct communication for ATV and resolved the issue. 

     

    All of this followed first an unsuccessful attempt at updating to 5.2.1, then a successful update to 5.2.1.  Would seem that somewhere in this process, my router to ATV communication got confused in some manner.

  • 70. Re: Setting date and time
    jacya Level 1 Level 1 (0 points)

    markdavies solution looks great. with Verizon FIOS in Virginia you get the Actiontec router and it only supports NTP over TCP and not UDP - so still stuck . From what I've read it looks like the only solution left is to downgrade.

  • 71. Re: Setting date and time
    Vossing Level 1 Level 1 (0 points)

    I have the same problem. It's on and off and I see no pattern. If you ask me - Apple TV us a pice of s....

    It's giving me headaches and no entertainment.

  • 72. Re: Setting date and time
    Haytread Level 1 Level 1 (0 points)

    We were having the same issue. After exhausting all of the above suggestions. I changed to my android tethering hot spot and bingo! Evidentially my Verizon router needs to be replaced.

  • 73. Re: Setting date and time
    JimRussell Level 1 Level 1 (0 points)

    I'm a Verizon Fios customer who had the same problem after I let it do the software update last night-- unable to set the time and stuck with only the computers and settings options. The good news is that now (less than 24 hours later) all seems back to normal. Patience or dumb luck?

  • 74. Re: Setting date and time
    Marco Franco Level 1 Level 1 (0 points)

    Perfect shabshekan !

     

    After 2 days trying evertything I've read over all the internet... it works !!!!!   

     

    The trick is: don't use your router !

     

    Use your Personal Hotspot on the iPhone (3G, 4G, whatever) !!!

     

    After that, you can use Ethernet or Wi Fi over your router.

     

    Thank you very much !

     


1 2 3 4 5 Previous Next