Skip navigation

Network Settings

286 Views 4 Replies Latest reply: Jun 25, 2013 2:58 PM by Rod Fryer RSS
Rod Fryer Level 4 Level 4 (1,865 points)
Currently Being Moderated
Jun 24, 2013 10:34 AM

Put a new Airport Card in a G4 iMac (running OS 10.4.11) given by a friend - he'd never had an Airport Card installed.

 

Works fine in that surfing wirelessly works OK, but when I click on Network in Sys Prefs, I get a drop down dialog box that states "Your Network Settings have been changed by another application". Clicking on "OK" makes the drop down dialog box wrap up out of the way, but it just descends again. This can be reapeated ad nauseam.

 

What is happening here? What do I need to do?

  • Klaus1 Level 8 Level 8 (43,415 points)
    Currently Being Moderated
    Jun 24, 2013 2:55 PM (in response to Rod Fryer)

    Go to System Preferences: Security. Check the box next to "Require password to unlock each secure system preference." Then lock Security.

     

    I haven't had the problem myself, but this post by ejp1684 seems to have offer a solution:

     

    Once in the network prefs and the popup appears, place your mouse over the place where the "Show All" button is (behind the popup). Then, hit Return - which gets rid of the window and immediately the window is gone, click on the 'Show All" button. I then get a window asking me to save etc, the changes. You can click on any of them and you should be back in the prefs window. Then, when you select the Network prefs, you should be able to change things. If this doesn't work, I found that I had to use the mouse button to click on both the "OK" button on the popup, and then quickly switch to the "Show All" button - took me a few times to do it!

     

    Even if you can't change the settings, at least you won't have to do a hard shutdown.

     

    http://discussions.apple.com/thread.jspa?messageID=8112368&#8112368

     

    This post by MacStrong also provided a solution that worked for some:

     

    If you recently updated or run a disk utility on your Mac this may have altered your sharing preferences. Go to System Prefs>Sharing Prefs and go to Network Time. If you have it checked, uncheck it and then recheck it. I just fixed a Mac by doing this. If it is not checked try checking and unchecking it.

     

    http://discussions.apple.com/thread.jspa?messageID=8204758#8204758

     

    This solution from Thomas Sattelman has been known to work on Intel macs:

     

    I read somewhere that this message is due to the new way of saving the PPP connection password after the security update is applied. It will occur, only if you have one or more, saved network configurations that includes PPP connection setup.

     

    This is how I got rid of the problem without deleting any of my network locations or any preference files:

     

    1. Log in using an admin account.

    2. Open the Security Preference Window

    3. Check "Require Password to unlock each secure system preference" to get temporarily rid of the annoying message (at the expense of typing in the admin password whenever settings are changed).

    4. Open the PPP network connection (Network Window)

    5. Uncheck "Save Password" in the PPP-Pane

    6. Type your password into the approriate field

    7. Recheck "Save Password" in the PPP-Pane

    8. Repeat this for all your PPP network connections

    9. Open the Security Preference Pane and uncheck "Require Password to unlock each secure system preference"

     

    http://discussions.apple.com/thread.jspa?messageID=8235114#8235114

  • rccharles Level 5 Level 5 (5,150 points)
    Currently Being Moderated
    Jun 25, 2013 10:02 AM (in response to Rod Fryer)

    This happens after applying Security Update 2008-06 to 10.4.10 or 10.4.11.

     

    Another thing that you could try it is deleting or copying to desktop the preference files for networking.  Mac OS will regenerate these files.  You would then need to reconfigure your network settings.

     

    http://discussions.apple.com/message.jspa?messageID=8185915#8185915

     

    http://discussions.apple.com/message.jspa?messageID=10718694#10718694

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.