Skip navigation

iCal Server External Invitees not working

7350 Views 26 Replies Latest reply: Oct 21, 2013 6:30 PM by Trismegister RSS
  • RoseValley Level 1 Level 1 (10 points)
    Currently Being Moderated
    Jun 20, 2012 8:32 AM (in response to MattMacPro)

    If you get anything from them let me know. I will let you know how the comand line works out. :-) But it will have to wait a bit as I have got to fix a PC with a virus AGAIN!! Stupid Windows!!

     

    Kevin

  • techgal Level 1 Level 1 (5 points)
    Currently Being Moderated
    Aug 23, 2012 3:34 PM (in response to RoseValley)

    Hello;

    Anyone found a solution to this? Still looking to configure the server to successfully pickup response emails and get them to the ical users...

  • MattMacPro Calculating status...
    Currently Being Moderated
    Aug 23, 2012 4:09 PM (in response to techgal)

    Hi techgal

     

    I have it working for most of the time. Every now and then an email will get 'stuck' in the email account being used to send invites. But everyone is sending invite to each other and appear to be sending externally as well. Seems to get stuck when I add a new user to the OD. Restarting the iCal service makes it all work again. I had an email stuck in the email account and that was the first one in over a month.

     

    Couple of things -

     

    Turn OFF the Address Book service on the server.

    Make sure the email account your using to send invites understands + email addressing

    Make sure everyone has the correct email adddress in their person address book under their 'me' contact.

  • techgal Level 1 Level 1 (5 points)
    Currently Being Moderated
    Aug 23, 2012 6:41 PM (in response to MattMacPro)

    Ok.. thanks MattMacPro

    We use a third party email server and it does not seem to understand plus addressing. I was told that google/gmail does and so wanted to set up an account for the sending/receiving of ical invites to external domains through that however I am not sure whether to set up as a pop or imap account as gmail accounts will do both. I am excited to try this!

    Thanks again.

  • techgal Level 1 Level 1 (5 points)
    Currently Being Moderated
    Aug 23, 2012 6:53 PM (in response to techgal)

    nevermind.. I see your imap settings in an earlier post.

  • techgal Level 1 Level 1 (5 points)
    Currently Being Moderated
    Aug 23, 2012 7:16 PM (in response to techgal)


    Does this look familiar???

     

     

    • 2012-08-23 19:09:58-0700 [-] [caldav-7]  [-] set uid/gid 93/93
    • 2012-08-23 19:09:58-0700 [calendarserver.accesslog.AMPLoggingFactory] AMPLoggingProtocol connection established (HOST:UNIXAddress('/var/run/caldavd/caldavd.sock') PEER:UNIXAddress(''))
    • 2012-08-23 19:09:58-0700 [-] [caldav-7]  [-] AMP connection established (HOST:UNIXAddress(None) PEER:UNIXAddress('/var/run/caldavd/caldavd.sock'))
    • 2012-08-23 19:11:03-0700 [-] [caldav-0]  [PooledMemCacheProtocol,client] [twistedcaldav.scheduling.imip#error] Could not do server-to-imip request : <twistedcaldav.scheduling.imip.ScheduleViaIMip object at 0x10a001310> iMIP VFREEBUSY REQUESTs not supported.
    • 2012-08-23 19:11:03-0700 [-] [caldav-0]  [PooledMemCacheProtocol,client] [twistedcaldav.scheduling.scheduler.ScheduleResponseQueue#error] Error during POST for mailto:kkingston57@gmail.com: iMIP request failed
    • 2012-08-23 19:11:41-0700 [-] [mailgateway] 2012-08-23 19:11:41-0700 [-] SMTP Client retrying server. Retry: 5
  • techgal Level 1 Level 1 (5 points)
    Currently Being Moderated
    Aug 23, 2012 7:28 PM (in response to techgal)

    Ok Mr. Rosevalley. Now to you as you had this error. Any luck overcoming it?

  • MattMacPro Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 24, 2012 5:10 AM (in response to techgal)

    Hi techgal

     

    Try setting up Apple Mail on the server itself to use the gmail account you have created - set it up using IMAP. Test it by just sending and receiveing email first. Once that works - setup iCal to use it for sending invites.

     


  • techgal Level 1 Level 1 (5 points)
    Currently Being Moderated
    Aug 25, 2012 4:50 PM (in response to MattMacPro)

    Have you guys seen this?

     

    http://trac.calendarserver.org/wiki/FAQ

  • TerribleToll Calculating status...
    Currently Being Moderated
    Jun 25, 2013 5:00 AM (in response to Edm Dude)

    I'm suffering from this issue on two Lion server installations.

     

    Everything works fine except iCal just will not send any invitiations:

     

    Server iCal Error log shows numerous "[twistedcaldev.mail.IMAP4DownloadFactory#error] IMAP factory connection failed", "SMTP Client retrying server" and "iMIP request failed".

     

    I have setup the email to work with a dedicated gmail account which works just fine from Apple Mail and invitiations will also send from iCal client if I force them. However, iCal server just won't play.

     

    I do have the Address Book server running - but the client is using that so I'd rather not switch it off.

     

    I'm just checking the plist files (if I can find them)

  • MattMacPro Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jun 25, 2013 5:29 AM (in response to TerribleToll)

    Hi TerribleToll

     

    Only suggestion would be to test with address book service turned off.

  • Trismegister Level 1 Level 1 (10 points)
    Currently Being Moderated
    Oct 21, 2013 6:30 PM (in response to TerribleToll)

    Ensure Sending Port is correct.

     

    In my case I discovered that the default "Enable invitations by email" settings were incorrect in that the outgoing SMTP Server Port is automatically set to 465 when the SSL checkbox was ticked. When set to port 25 external invitees were notified fine with no more "SMTP Client retrying server" errors logged.

     

    Background: The SMTP Server used is the Mail servive of OS X Server itself and so I had assumed that serveradmin settings calendar:Scheduling:iMIP:Sending:Port = 465 meant that Server would open up port 465 but no; a port scan showed that only port 25 was opened on the server's adaptive firewall even though the router port 465 was open.

     

    serveradmin settings calendar:Scheduling:iMIP:Sending:Port = 25 was my solution

1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (1)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.