2 Replies Latest reply: Jun 25, 2013 6:41 AM by mende1
cosgrave5 Level 1 Level 1 (0 points)

I have 2008 Mac OS X 10.8.4. My airport express software cd wont load ,it says it is not compatible with this version of OS X., I have 2008 Mac OS X 10.8.4. My airport express software cd wont load ,it says it is not compatible with this version of OS X.


air port express, OS X Mountain Lion (10.8.4)
  • 1. Re: airport express compatibility
    Brandon2184 Level 4 Level 4 (1,605 points)

    Download the software from the Apple website instead of using the CD. http://support.apple.com/kb/DL1664

     

    Although, as mende1 mentions below, you shouldn't have to install anything, it should set itself up automatically.

  • 2. Re: airport express compatibility
    mende1 Level 10 Level 10 (89,570 points)

    Welcome to Apple Support Communities

     

    You don't have to use your AirPort DVD, because your Mac already has got the apps that you need to set up your AirPort Express.

     

    Just plug your AirPort Express and it will turn on. Then, open AirPort Utility (in /Applications/Utilities) and follow the steps. It will be detected by AirPort Utility and your computer will connect automatically to it. You don't need to download anything unless you haven't updated AirPort Utility, but as you are using OS X 10.8.4, you should have to latest AirPort Utility version