Skip navigation

Managed Files Become Referenced With No Masters!

425 Views 7 Replies Latest reply: Jun 25, 2013 6:42 PM by KiwiMac RSS
KiwiMac Level 1 Level 1 (10 points)
Currently Being Moderated
Jun 20, 2013 9:07 PM

I have encountered an odd and frustrating problem.

 

I'm on the road on a 2 month shoot in SE Asia. I shot some work a few days ago whilst in Manila. Imported into a managed library on a WD My Passport drive, backed up to a Vault on a second drive and backed up wirelessly via Backblaze.

 

All was well until last night when I had a chance to do some editing. The entire import from that session now show as referenced files with missing masters! They have little triangles with arrows in the bottom right. You can see them in the viewer etc in Aperture but you cannot work on them, export them, email them or anything - you just get an error message saying "One or more of the selected version has a original file which is still being imported. Please wait for the file copy to complete and try again." or "The selected original image is either offline or not found. Please reconnect it and try again."

 

The drives are connected correctly (and indeed all other images apart from that shoot are fine). I ran Disk Utility and repaired permissions and drives. I switched it off and on again. I rebuilt the library, the data base and permissions. I restored the library from the Vault. None of which made any difference.

 

I searched the wireless backups on Backblaze and the files are missing from there too.

 

Yet a few days ago I emailed some of those files to a friend and edited some of them too, so they were all there and were fine.

 

Can anyone offer any kind of explanation and/or suggestion for recovery?!

 

Thanks

  • léonie Level 8 Level 8 (46,475 points)
    Currently Being Moderated
    Jun 20, 2013 11:13 PM (in response to KiwiMac)

    Have you rebooted your Mac since the import? If not, don't do it, until you checked the temporary directories that Aperture writes to, if it cannot write to the disk.

     

    I suspect, Aperture may not have been able to write to your drive and wrote instead to a temporary directory.

     

    • Launch the Terminal and enter the command:

    open $TMPDIR

     

    This will open a hidden folder in the system with cryptic names, used as a cache by many apps. Look for a folder

    com.apple.Aperture > Temporary items

     

    Are there any image files?

     

    • Also try

    open /tmp

     

    and have a look.

     

    Also look inside the Aperture Library package, if the photos actually have been imported:

    • Select the Aperture library on the external dive, ctrl click it, select "Show package contents"
    • Open the folder "Masters" in the window that will open.
    • Look for the folder 2013 > 06 > the date you imported your Manila photos.

     

    Are they actually in the "Masters" folder?

    • If yes, try to repair the permissions in your library.
    • If not, can you reimport from your card?

     

     

    How are you editing, btw?

    I have seen this error message only in connection with plug-ins and Mt.Lion. It can happen, if the plug-ins are not properly sandboxed and incompatible with the latest system version.

     

    What is your set-up? Aperture version, MacOS X version?

     

    Can you edit the images with Aperture's own adjustments?

  • léonie Level 8 Level 8 (46,475 points)
    Currently Being Moderated
    Jun 21, 2013 3:19 AM (in response to KiwiMac)

    That command is showing you the exact folder you should be looking at.

    /var/folders/z1/sc01v4mn6_x2md3m_f318sl00000gn/T/

     

     

    Your Terminal is behaving differently from mine: for me this command opens a Finder window at that location.

    Does

         open -a Finder $TMPDIR

    work?

     

    If not, try to open that folder from the Finder's "Go" menu.

     

    Finder > Go > Go to Folder ⇧⌘G

     

    Then paste the path above into the textfield.

    /var/folders/z1/sc01v4mn6_x2md3m_f318sl00000gn/T/


     

    All of which means nothing at all to me!

    Your mac a temporary storage area called TMPDIR, where programs can write data to. This area is outside the users home directory, so applications can share it. To prevent malware from guessing the name (security by obscurity) the folders are named in a random way. For each user the symbolic name - the shell variable $TMPDIR  will map to a different folder.

     

    I have to say that if it cannot do what it should do, it would be much more sensible if (a) it told you and (b) it wrote things somewhere permament for you to move later!

    Right - the question is, if Aperture could write anywhere or did not notice that the write failed.

    Did you erase the card, after importing,or could you restore from your card?

  • Frank Caggiano Level 7 Level 7 (22,785 points)
    Currently Being Moderated
    Jun 21, 2013 3:39 AM (in response to KiwiMac)

    Have you tried running the Aperture libray functions ? Open Aperture while holding down the command and option keys. Select repair library.

     

    When you restored from the vault did you keep the original library?

  • léonie Level 8 Level 8 (46,475 points)
    Currently Being Moderated
    Jun 21, 2013 3:57 AM (in response to KiwiMac)

    What about the second part of my question? Could you have a look at the "Masters" folder in the library, before you stowed your drive away in the luggage for your flight?

     

    I would never do that btw. I would not trust the drive with my image files to be save in the checked in luggage. I lost a camera this way and an iPod. And even, if it is not stolen, the luggage may be late to arrive. On some travels I had to wait three days for the luggage to finally arrive. So any thing I really need for taking photos goes into the jand luggage.

  • léonie Level 8 Level 8 (46,475 points)
    Currently Being Moderated
    Jun 21, 2013 4:30 AM (in response to léonie)

    Frank,

    I am glad you are looking into this discussion.

     

    Has the behaviour of the "open" command from the Terminal changed?  

     

    I never got an error message like KiwiMac posted above when using "open path to some folder" from the Terminal in bash

     

    -bash: /var/folders/z1/sc01v4mn6_x2md3m_f318sl00000gn/T/: is a directory

    Marcuss-MacBook-Air:~ marcopolo10$

    Léonie

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.