Skip navigation

Unable to Print on HP 2570 Connected to Asus RT-N66U

5436 Views 15 Replies Latest reply: Jan 5, 2014 6:51 AM by Rosco P. Coltrane RSS
1 2 Previous Next
Argonese Level 1 Level 1 (0 points)
Currently Being Moderated
May 1, 2013 7:24 PM

I am in the process of setting up my Imac (new to mac) to print.  I have the Imac connected via ethernet cable to an ASUS RT-N66U.  I have an HP 2570 connected to the ASUS via USB.  When I follow the instrux on the ASUS site, I get all the way to clicking add the printer, I get an error message  "Unable to verify the printer on your network." "Unable to connect to ‘192.168.1.1’ due to an error. Would you still like to create the printer?"   Not sure what I am doing wrong, I am hoping someone here has had a similar experience.

iMac (27-inch, Late 2012), OS X Mountain Lion (10.8.3)
  • rkaufmann87 Level 8 Level 8 (40,530 points)

    You have a peer to peer network setup , this is the worst type of network you can have. Connect both computers to your router either via wi-fi or either net and then turn on printer sharing on OS X (Google it) and do the same with the version of MS Windows you have installed on your PC.

  • rkaufmann87 Level 8 Level 8 (40,530 points)

    Then follow the simple instructions in Apples newsletter about Printing Overview OS X Lion.

  • rkaufmann87 Level 8 Level 8 (40,530 points)

    Then it appears your router does not support that functionality of OS X, I'd recommend another router. The only routers I know that are are supported for USB printing through the router are Apple's Airport Extreme, Airport Express and Time Capsule.

  • ShlomiL Level 3 Level 3 (675 points)

    Hi,

    The ASUS RT-N66U as a print server support specific models only, as you may find listed for the specific router / print server, only 3 HP models are listed by Asus as supported, as well it does not seems to support Mac OS X:

    http://event.asus.com/2009/networks/printersupport/rt_n66u.htm

     

    As your printer support Ethernet connection, try connecting it to your router via Ethernet and check if that work (I could not find much Mac information within its user guide so that depands if the router support a Mac OS envoirnment)

     

    Shlomi

  • ShlomiL Level 3 Level 3 (675 points)

    Well. I did not stated that Asus does not support Mac envoirnment, only that the manufecturer's information does not list a such.

     

    Regarding the 2570 compatibility, It's Asus which does not list the printer compatible with the print server and not me.. the list above is taken from Asus web site, as listed on the user guide of the RT-N66U.

     

    I would suggest contacting Asus support for any assistant, it is a 3rd party hardware which offer this capability and they should know better what they products capable of doing..

     

    Shlomi

  • branth Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jun 26, 2013 11:25 AM (in response to Argonese)

    Well "nice" to see I'm not alone.  I am having the same problem with my Mac Pro and my ASUS RT N66U router and Brother Laser printer (HL 2070N).  Router sees the printer in USB slot.  Identifies it as Brother printer and I can see the printer in my printer to choose from box.  If I select the Brother, the print jobs goes off to print but when I go to Print Q the print job is there but error message says printer not on line.

     

    If I put USB directly into USB slot on Mac Pro works like butter.

     

    Any help from ASUS?  I tried playing around with Ethernet connection but haven't had any luck so far.

  • AdeleMc Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 29, 2013 10:56 AM (in response to branth)

    I had similar issue with HP Laserjet 2015d.  Went back over the Asus instructions for setting up a printer and saw that I neglected to add a setting.  System Preferences>Print & Fax>+ to add printer>Protocol: Line Printer Daemon - LPD, Address: enter your router's IP AND THIS IS WHAT I NMEGLECTED TO CHEK THE FIRST TIME Queue:LPRServer.

     

    Make sure LPRSERVER is selected.  Once I reinstalled using these instructions per the Asus website, my printer works fine with my router.

     

    I am running MacBook Pro

  • branth Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 29, 2013 12:35 PM (in response to AdeleMc)

    Still doesn't work for me.  Now I get printer busy.  Busy doing what I have no idea!! 

     

    But direct USB connection works so I'll live with it.  I'm using a Mac Pro Desktop and have extra USB slots added so no problem.  Plus I'm using handyPrint app so I can print from my iPad.  So as everytihng is working well I'll just leave it as is.  But thanks for the suggestion. Looked hopeful until I kept getting printer busy response.

  • SMVMD Level 1 Level 1 (0 points)

    Argonese, I have this same issue with my new imac.  Did ASUS support ever help you get it resolved? 

1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.