Skip navigation

Apple Configurator 1.3 crashes when opened.

1096 Views 8 Replies Latest reply: Jul 11, 2013 1:57 PM by nzsouthernman RSS
Roy Carter Calculating status...
Currently Being Moderated
Jun 21, 2013 9:05 AM

Apple software update notifies me that Apple Configurator 1.3 is available for download.

I load Configurator 1.3, start it up and it crashes, repeatedly.

I go to Time Machine Backup and restore version 1.2.1, and it runs.

Tried reloading 1.3, same issues.


Does anyone have any ideas?

  • feosuna Calculating status...
    Currently Being Moderated
    Jun 21, 2013 2:44 PM (in response to Roy Carter)

    Do you have any devices connected when you start Configurator?  Do you ever see a Migration Window or Configurator's main window before it crashes?

  • eliotb Calculating status...
    Currently Being Moderated
    Jun 23, 2013 10:38 PM (in response to Roy Carter)

    I'm experiencing similar issues. Crashes repeatedly after update. No devices connected when starting. No time machine backup either.

  • nsdjoey Level 3 Level 3 (645 points)
    Currently Being Moderated
    Jun 25, 2013 10:45 AM (in response to Roy Carter)

    I've talked to others who  updated to v1.3 and are experiencing frequent crashes. Sounds like a lot of people are having the same problem.


    I think I'm going to stick with 1.2.1 for a while...


  • nzsouthernman Calculating status...
    Currently Being Moderated
    Jun 25, 2013 6:55 PM (in response to Roy Carter)

    We have the same here.  Tried letting it create a clean fresh database in case it was the upgraded one from 1.2.x -> 1.3 and it worked for a while, and is now crashing regularly again.


    Does anyone have 1.2.x somewhere that we can download & reinstall from? I can't seem to find it online anywhere.

  • cycle252 Calculating status...
    Currently Being Moderated
    Jun 27, 2013 12:30 PM (in response to Roy Carter)

    Same thing here. Seems to crash while trying to migrating the database. With the AppleConfigurator.storedata out of the Library\containers folder it will load. But as we all all know taking this config file out causes it to basically act like a new install and none of the apps show up or groups under my supervised section.


    I have looked forever for 1.2.x and cant find a copy. They really need to fix this as I have a lot of money tide up in apps for my university for multiply classroom projects.

  • fpcs2 Calculating status...
    Currently Being Moderated
    Jul 4, 2013 12:31 PM (in response to Roy Carter)

    I use AC 1.2.1 for iPads at one location, and I just started using AC 1.3 on a different MacBook Pro to deploy 1,000 more iPads at a different location.  I am only using three iPads at that location for testing for now, and I have noticed that AC 1.3 does crash often.  I think it has something to do with applying multiple updates to All Devices without plugging each device in to let it finish the first updated applied - that is just a theory.  Regardless of what is causing the crash, once AC crashes, it crashes every time I restart it, even after rebooting the MacBook, until I disconnect all iPads, restart AC and "stop" the pending updates.  Then, I reconnect one of the iPads, and it does not crash again until some combination of applied updates.


    That said, is it possible that you have updates "pending" from the original AC 1.2.1 installation - I think those were shown as "Waiting to Connect" in 1.2.1?  Can you stop those by clicking the Stop button in 1.3?  I thought of that because my first AC 1.2.1 shows the status of "Waiting to Connect" for several iPads, and I thought AC 1.3 was suppose to fix that with the Stop feature.  (This is slightly different, but I had random iPads crashing when I plugged them in to AC 1.2.1, and I am almost certain it had something to do with the "Waiting to Connect" status.  Have you noticed that problem too?)


    I hope this helps, and I hope someone has additional thoughts on this.

  • nsdjoey Level 3 Level 3 (645 points)
    Currently Being Moderated
    Jul 11, 2013 1:14 PM (in response to cycle252)

    Hi nzsouthernman and cycle252,


    I found someone who posted Apple Configurator 1.2.1  on another forum...



    You'll have to delete ~/Library/Containers/ (probably back it up first) or else the downgraded app won't open, but unfortunately you'll probably lose your supervised devices.



    Hope this helps!


  • nzsouthernman Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 11, 2013 1:57 PM (in response to nsdjoey)

    Brilliant, thankyou nsdjoey! That'll resolve the issue for us until Apple fix 1.3.x.


More Like This

  • Retrieving data ...

Bookmarked By (0)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.