4 Replies Latest reply: Jun 28, 2013 10:56 AM by mende1
randydavey Level 1 Level 1 (0 points)

i need a version 10.6 or newer to run new software programs

i currently have version 10.5.8

how can i update????

when i try to update, apple tells me there re no new updte and my computer is fine

 

also, when i check "about this mac" on my comptuer, the logo is a cracked apple????


iMac, operating system