Skip navigation

Ownership Enabled Question

32240 Views 54 Replies Latest reply: Mar 5, 2014 2:51 PM by TheCoodu RSS
  • kstc Calculating status...
    Currently Being Moderated
    Mar 30, 2013 9:39 PM (in response to Peter Reznikoff)

    But what if you try the above things and you still do not see the option to ignore show up?

     

    It seems as though the partition map scheme of my drive is Apple Partition Map. Is there any hope then?

    I would assume GUID has a bit more control over permissions than the lowly Apple Partition Map.

    The drive is a client of mine that bought it last year. Way to go LaCie.

    Who the heck still uses OS9?

    LaCie fail.

    Just like there enclosures. The bridge always fail. The drives are usually ok, thanks Hitachi...Wait, the drive inside the LaCie is a Toshiba, the LaCie box says they use Hitachi. fck sakes.

     

    lmao and going into the latest alias folder for the backups and copying it by hand.

    Client will have to punt. They will not be able to browse for their files but at this point they have

    their data.

  • cbucbu Calculating status...
    Currently Being Moderated
    Apr 4, 2013 5:06 AM (in response to kstc)

    I have tried all of the suggestions listed above which include

    - clicking on my external hard drive, going to finder and then selecting get info - nothing.

    - right clicking on it directly and go to get info - nothing

    - unlocking the padlock and tried to scroll down - nothing

    - changing all of the sharing permission people listed as suggested - nothing

    - going to terminal and typing sudo /usr/sbin/vsdbutil -a /Volumes/NAME OF YOUR DISK - can't type in terminal, it won't let me when I'm promted for a password

    - switching off and leaving for a day, trying again - nothing.

     

    I'm feeling very frustraited as I have already used this external drive to make a copy of my time machine. 

     

    Any other ideas???

    Please help me!!!

  • Vampyrvet Calculating status...
    Currently Being Moderated
    Apr 9, 2013 7:38 PM (in response to Peter Reznikoff)

    I had to reformat my computer and reinstall the OS.  I want to save my last few months' of Time Machine backups.  I had the same problem with ownership as other users in this thread.  I was not allowed to move any of the backups out of the "Backups.backupdb" folder. 

     

    I found that if you move the folders containing the individual TM backups to the Trash (it warns you that this can't be undone, do it anyway), then move the folders from the Trash to your alternate destination, this is how you can circumvent the ownership restriction.  Apparently the act of moving the backups to the Trash releases the safeguards, and then you are free to move them anywhere you want.

     

    Just be aware that this is an extremely lengthy and time-consuming process.  But if it's the only way to reclaim your data, it might be worthwhile.

     

    Hope this helps

    Natalie

  • rudsteruk Calculating status...
    Currently Being Moderated
    Apr 11, 2013 1:53 AM (in response to Peter Reznikoff)

    For those people that don't have ownership option.  Just paste this into Terminal replacing APEX with your destination drive name...

     

    sudo diskutil enableOwnership APEX

     

    simples

  • WillowTVP Calculating status...
    Currently Being Moderated
    Apr 14, 2013 4:03 PM (in response to AlexF)

    After all the explanations...this one worked.  Thanks for your expertise Alex.  I found it on the drive I wanted to transfer to, as you explained.    Brilliant. 

  • kstc Level 1 Level 1 (10 points)
    Currently Being Moderated
    Apr 14, 2013 4:43 PM (in response to WillowTVP)

    Glad this option came up and it worked for most people who didn't realize they were restoring to a previous Time Machine hard drive. I think the problem that exists is what if the drive was a new drive or recently formatted drive and you do not have the ability to change ownership?!?!?

     

    In my case the format of the drive revealed that Apple Partition Map was the issue and formatting to GUID was able to change ownership on the drive after reformatting.

  • Jpierce Calculating status...
    Currently Being Moderated
    May 27, 2013 8:47 AM (in response to joelfromcolorado springs)

    ^problem solved

  • supraru Level 1 Level 1 (0 points)
    Currently Being Moderated
    May 28, 2013 8:45 AM (in response to Niel)

    Thank you for this. Solved.

  • miller_tv Calculating status...
    Currently Being Moderated
    Jun 11, 2013 8:07 AM (in response to Peter Reznikoff)

    PERFECT, thanks!

  • betababe Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jun 28, 2013 6:22 PM (in response to AlexF)

    Thanks so much! Solved my problem.

  • ADH69 Calculating status...
    Currently Being Moderated
    Sep 22, 2013 1:05 PM (in response to AllStarMe)

    Thanks! This helped me with a similar problem.

  • Klaus Blume Level 2 Level 2 (305 points)
    Currently Being Moderated
    Oct 29, 2013 6:28 PM (in response to rudsteruk)

    You are my man,

     

    Thank you

  • laisony Level 1 Level 1 (10 points)
    Currently Being Moderated
    Dec 8, 2013 1:46 PM (in response to Peter Reznikoff)

    Because of the postings on this discussion I was able to do this.

    At the risk of being repetitive this is what happened to me.

     

    I wanted to use a new external drive for my Time Machine backups.

    When I unlocked the "Get Info" Window on the newly formated drive

    then the option to [Ignore ownership on this volume] was displayed at bottom of Get Info Window

    The box could be checked and unchecked.

     

    While the box was unchecked I copied all my previous Time Machine Backup Files from the old drive to the new drive. Still the "Ignore ownership..." box could be checked and unchecked. I left it unchecked.

    Then in Time Machine Preferences I selected the new drive as a backup disk.

    After that I wanted to see if the box could be selected and unselected as before. But when I checked the box for [Ignore ownership on this volume], the box and text disappeared.

     

    The old external drive that was previously used for backups was not displaying "Ignore ownership..."

    After I erased the old drive [Ignore ownership on this volume] was displayed on the "Get Info" window after I clicked the lock and unlocked it. Then on the old drive "Ignore ownership..." could be selected and unselected.

  • mysticfaucet Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 23, 2013 4:03 AM (in response to rudsteruk)

    A luddite question: Where can I find Terminal in order to do the following:

     

    "For those people that don't have ownership option.  Just paste this into Terminal replacing APEX with your destination drive name...

    sudo diskutil enableOwnership APEX"

     

    Thanks.

  • gregarious47 Calculating status...
    Currently Being Moderated
    Dec 23, 2013 9:08 AM (in response to AlexF)

    Alex, thanks so much for straightening this out. I just enabled the destination drive and, whoopee!, files being copied.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (2)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.