Skip navigation

New Macbook Air - wifi connectivity problems

444062 Views 2,047 Replies Latest reply: Apr 14, 2014 1:09 PM by Garryatco RSS Branched to a new discussion.
  • fifrelin Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jun 28, 2013 10:30 AM (in response to vhkim)

    As I said before, mine works fine. But it's a custom model (i7/8 GB), I suspect it was assembled later than most standard configurations that were sold recently. It would be interesting to know if ye folks all have base i5/4 GB configuration, or if the WiFi bug manifests itself also on enhanced configuration.

     

    I’d be surprised if the problem is not at least partly linked to HW (otherwise, every MBA should be plagued), maybe a batch of suboptimal RF chips. RF is not as simple as logic circuits: it's not about toggling from 0 to 1 and back; it's about amplifying linearly weak signals, and that's a totally different trick.

  • patricketurner Level 1 Level 1 (30 points)
    Currently Being Moderated
    Jun 28, 2013 10:49 AM (in response to lilikiller)

    Right, if portability is what you are after than the AirPort can only help where your computer calls home. For me it has been a good solution cause I take my iPhone and iPad with me when I go places and leave the laptop at home, with the AirPort. Given the fact that these wifi issues seem to only happen in the MBA's than I assume that it can be fixed with a simple software update. Apple has already ackowledged the problem, though the "Geniuses" will deny it, and even go as far as to say that the wifi bug is just a rumor.

  • gmc74 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jun 28, 2013 10:51 AM (in response to fifrelin)

    I also have an i7/8gb and it has happened to mine.  As best as I can tell, it is limited to specific environments.  I had two routers that I had the issue with, apple has those routers now.

  • fifrelin Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jun 28, 2013 11:25 AM (in response to gmc74)

    Thanks, so it’s not related to the actual configuration.

     

    As far as I understand, it happens also when the MBA is close to an AP, so I guess the RF section is innoncent, at least the RX part. Now, for the TX channel, something may be wrong. If the chip broadcasts at too low a RF level, and the gain of the first RF stages of the AP is too low, it may choose to disconnect and renegociate the link, which would lead to a disconnect/reconnect cycle.

     

    It would be interesting if somebody could setup a point-to-point link between one defective MBA and another Mac, and monitor the S/N ratio.

  • P. Phillips Level 1 Level 1 (50 points)
    Currently Being Moderated
    Jun 28, 2013 12:15 PM (in response to fifrelin)

    I have i5, 1.3 13 inch, 8 GB and 256 SSD. Had it since June 18. Running it at home off a Sagemcom router ( supplied by ISP), WPA2- PSK (AES), 2.4 Ghz,b/g/n on channel 11. No dropping wifi connections.

     

    Pierre

  • gmc74 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jun 28, 2013 1:25 PM (in response to P. Phillips)

    Looks like it works in the air, connected to Gogo wifi

     

  • Gatorbull Calculating status...
    Currently Being Moderated
    Jun 28, 2013 6:21 PM (in response to gmc74)

    i7, 8gb, 128SSD with wifi issues checking in.

     

    From day one my MBA was dropping the connection to the DLink 615 router at my house.  The connection was dropping probably every 1-2 minutes repeatedly.  I admit was downloading a large file via the distributor so this may have had an effect on the wifi connectivity (reletive to the less frequent drops I am experiencing now).  Those who are more tech savvy can address that point.  I decided to contact apple support where they ran me through a litany of tests which concluded in reinstalling the iOS.  This installation failed as I received an error message stating that there was a disk error (concerning).

     

    After contacting apple support I made an appointment to see a genius.  While in the apple store, my wifi did not drop once.  I purchased an airport express which I had no problems on.  The genius also stated that I need not worry about the disk error that occurred the day prior and that I should be able to update to the new iOS with no problem in the future.

     

    I also went to starbucks and paneras in order to test my connection.  While it felt at times the connection had dropped, it would re-establish it's self after refreshing the page several times or simply waiting for 15-20 seconds (I did not have to turn the wifi on and off or restart the MBA).

     

    I updated the firmware for the DLink router I own at my other establishment which has somewhat alleviated the problem.  ATM I only have the connection drop once per 30 minutes - 2 hours.  Still it can be very annoying, but I am not sure what can be done.  It seems as though it may just be a compatibility problem with the DLink router I own. 

     

    Anyway's I have been in contact with Apple support throughout this entire process (the customer service has been phenomenal).  I plan on contacting the senior manager who has been assisting me tomorrow morning to update him.

  • PlotinusVeritas Level 6 Level 6 (13,575 points)
    Currently Being Moderated
    Jun 28, 2013 6:27 PM (in response to Gatorbull)

    Why has nobody mentioned this?

     

    Those having wifi issues, are you running I7 processors….. or  I5 ?

     

    Ive seen too many with issues running I7. 

     

    Conclusion being (maybe) that the I7 might be causing RFI or EMI (radio frequency or electromagnetic interefence) since its so close to the wifi antenna.

     

    Of those with errors, dropping wifi, are most those with 1.7GHz dual-core Intel Core i7 chipsets?

     

    There could be a bleedover 2.4Ghz harmonic causing SNR (signal to noise problems) sourced wifi drops.

     

    Ive notice Apple Inc. seems overtly interested in scoping out problem Airs SNR reports.

  • NoorAbulibdeh Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jun 29, 2013 1:25 AM (in response to vhkim)

    Hey everybody I think I found a fix for my particular problem maybe this can help you guys too.

     

    I just purchased the 13inch model for my girlfriend a few days ago and I have been experiencing many of the same issues as everybody else on here.

     

    I have a Westell 7500 wireless router and after being connected for less than 30 seconds the connection will time out and only reconnected after restarting and then it will do the same thing all over again.

     

    I called my ISP (century link) and after troubleshooting for about an hour the technician suggested that I change the wireless channel from 6 to 11.

     

    It WORKED, I have been online for an hour with no dropouts I have even shut down and restarted her MacBook a few times and it has had no issues connecting and staying connected.

  • Cloudi Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jun 29, 2013 1:37 AM (in response to NoorAbulibdeh)

    Hi!

     

    Still no problems with my new MBA 13".

     

    I keep reporting here becuase I think it's helpful for Apple and you guys to know what completely accidentally worked out of the box.

     

    I realise that it could be seen as irritating, insensitive and carping.  Thanks to you all for not saying so.

     

    Anyway, I noticed that NoorAbulibdeh has found using channel 11 works.  Quite by accident, that's the channel my MBA used from the get-go.

     

    The rest of my setup can be found by searching for Cloudi in this thread.

  • iHuzefa Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jun 29, 2013 3:57 AM (in response to vhkim)

    @mechanic are you sure that the people who've replaced the MBAs are having the same issue?

  • darkpuh Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jun 29, 2013 5:29 AM (in response to lilikiller)

    That's true. It's good to see that Apple is working on a fix for this problem. I've now installed AirPort Extreme and all the hickups are gone. But like you said, that isn't a solution for those who want mobility.

     

    Here's one hoping to see the fix released soon

  • M. R. Level 2 Level 2 (335 points)
    Currently Being Moderated
    Jun 29, 2013 5:33 AM (in response to iHuzefa)

    I have the same issue on my 2nd one

  • keithfromcambridge Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jun 29, 2013 8:38 AM (in response to wsm0603)

    Hi wsm0603,

     

    I can verify that I had wifi issues on my MacBook Air 13" while running Windows 7 through Bootcamp. The issue is the same as Mac OS; wifi drops after a minute of connectivity and the only way to get it back is to disconnect wifi and reconnect.

     

    However, after no success with altering router configuration and other suggestions posted here, I seem to have found a fix (for Windows at least). Here's what I did:

     

    1. Connect to your wifi network.

    2. Right click you network name in the taskbar and go to Properties.

    3. In the Window that appears, go to the Security tab and click the Advanced Settings button.

    4. In 802.11 settings, enable Federal Information Processing Standards (FIPS) compliance for this network.

     

    After that, disconnect and reconnect to your wifi network, and it should work. I have verified this to continue working after a reboot, as well.

     

    The thing is I'm unsure of why this works, as it is just something I randomly tried. Could anyone shed some light on what FIPS is or why enabling it would stop wifi from dropping (on Windows)?

     

    Note: I have also tried this on 2.4GHz and 5GHz wifi channels and it is now working (i.e. not dropping) for both of them.

     

    Thanks

  • nat_gillet Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jun 29, 2013 9:27 AM (in response to vhkim)

    I just returned my new Macbook Air because of the same problem.

     

    But for those who are keeping their new computer, I  found an efficient way to solve it temporarily!

     

    I got a wireless usb adapter (in my case the Long Range Wireless N150 USB Adapter from EnGenius).

    The result was stunning. My connection  worked perfectly  again !!! It was stable and  even faster than with my old Macbook.

    I even began having second thoughts about returning the new Air under such circumstance. But I finally decided that I wanted a flawless machine. So I will buy it again later when I am sure it is not a hardware problem. In the mean time I will keep my new wireless USB adapter.

     

    Hope this helps!!

1 ... 27 28 29 30 31 ... 137 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (72)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.