Skip navigation

Glyph View in Character Viewer?

15496 Views 83 Replies Latest reply: Apr 16, 2014 4:49 AM by nkalvi RSS
  • maharaj Level 1 Level 1 (105 points)
    Currently Being Moderated
    Jun 29, 2013 1:32 PM (in response to Tom Gewecke)

    many thanks, yes of course that is true. but the frustrating part to all Sanskritis is that a host of important conjuncts in Sanskrit, which are glossed (as bindu) and not used in Hindi, although all present as glyphs in the font, are not available,  e.g. to write 'Ganga'  (not dental 'n'). It is accessing these characters that I am baffled with. Cheers.

  • maharaj Level 1 Level 1 (105 points)
    Currently Being Moderated
    Jun 29, 2013 1:37 PM (in response to Tom Gewecke)

    ङ्ग  for example can only be achieved to write Ganga. although not incorrect, it is not the proper way to write it in Sanskrit. The appropriate conjunct (for this and others) - all these chars are in the font but inaccessible. Thanks again.

  • Tom Gewecke Level 9 Level 9 (70,920 points)
    Currently Being Moderated
    Jun 29, 2013 1:59 PM (in response to maharaj)

    maharaj wrote:

     

    ङ्ग  for example can only be achieved to write Ganga. although not incorrect, it is not the proper way to write it in Sanskrit. The appropriate conjunct (for this and others) - all these chars are in the font but inaccessible.

     

    To get special versions of such things on a Unicode system you do the following:  Go to Format > Fonts > Show Fonts and select Devanagari MT.  Then click on the gear wheel at the bottom left and select Typography.  Then select Additional Conjuncts or whatever is appropriate:

     

    Screen Shot 2013-06-29 at 4.48.37 PM.png

     

    Using this I can get

     

    Screen Shot 2013-06-29 at 4.57.48 PM.png

  • maharaj Level 1 Level 1 (105 points)
    Currently Being Moderated
    Jun 29, 2013 2:50 PM (in response to Tom Gewecke)

    gosh! what am i missing? tried that, i can still ony get

     

    sample.png

     

    am i keying it in wrong? z+f+g  ?

    macbook pro 17" early 2009, OS X Mountain Lion (10.8.2), 4 GB RAM
  • maharaj Level 1 Level 1 (105 points)
    Currently Being Moderated
    Jun 29, 2013 2:52 PM (in response to maharaj)

    whoops! ok got it now. many thanks.  hopefully others will also work now

  • maharaj Level 1 Level 1 (105 points)
    Currently Being Moderated
    Jun 29, 2013 3:14 PM (in response to maharaj)

    my next puzzle is to get this working in Quark Xpress. It now works in Textedit but the conjuncts are lost when importing into Quark...

  • maharaj Level 1 Level 1 (105 points)
    Currently Being Moderated
    Jun 29, 2013 3:18 PM (in response to maharaj)

    Quark xpress can't see Devanagari MT

  • Tom Gewecke Level 9 Level 9 (70,920 points)
    Currently Being Moderated
    Jun 29, 2013 3:25 PM (in response to maharaj)

    maharaj wrote:

     

    Quark xpress can't see Devanagari MT

     

    You will have to go to the Quark forums.  Things like Adobe and Quark are unable to use Apple's Indic support and they have their own special add-ons and fonts to work right (or not).

     

    Can you use Pages instead?

  • maharaj Level 1 Level 1 (105 points)
    Currently Being Moderated
    Jun 29, 2013 3:30 PM (in response to Tom Gewecke)

    thanks Tom - shall investigate your suggestions

  • montagular Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 7, 2013 1:10 PM (in response to lemon-kun)

    I just found a workaround for this problem that doesn't involve buying any software and allows you to insert any character from the repertoire shown in Font Book. Here's what you do: in the "repertoire" preview of Font Book, locate the symbol in the font you want to use. Hover over it and remember the unicode point it has been placed at in that font. (If it has been mapped to a typable character, then just type it from the keyboard.) If it has been mapped to an untypable character, go to the character viewer and select the Unicode section of the list (it might not be visible by default, so make it visible). Scroll through the unicode grid until you get to the location indexed by the code you got from Font Book for the glyph you're interested in. Select that grid location, without caring what the character displayed looks like. Then click "add to favourites". The character--i.e., the unicode position--will be added to the favourites in character viewer. Now click on favourites to see your list of favourite symbols. The one you've just added will be last on the list. Again, without caring what it looks like, double-click it (having set the insertion point and correct font in the document you're working on), and the character will appear properly in your document.

     

    I can't believe someone thought it was a good idea to remove the "input from character palette" functionality and this is how you have to work around it, but at least I can get my symbols into a document now. The worst part is that the characters I'm using were mapped to the "private use" portion of unicode, and so on my favourite list in character viewer they appear as identical grey squares, and I just have to remember which is which (or insert them all then remove the ones I don't want).

     

    Tom Gewecke, I've seen your excellent advice on very many topics here before, and I'm exhilarated to have found a solution that you didn't (seem to) know about--even as kludgy a solution as this!

  • Tom Gewecke Level 9 Level 9 (70,920 points)
    Currently Being Moderated
    Oct 7, 2013 2:29 PM (in response to montagular)

    montagular wrote:

     

    Tom Gewecke, I've seen your excellent advice on very many topics here before, and I'm exhilarated to have found a solution that you didn't (seem to) know about--

     

    Congrats!

     

    Though it doesn't help someone who wants to input a character for which there is no unicode point but just a glyph id.

  • rm555 Calculating status...
    Currently Being Moderated
    Dec 31, 2013 9:45 PM (in response to Tom Gewecke)

    Tom,

     

    I need some help again in Pages.

     

    1.

    Now I have noticed that after checking the box for "Additional Conjuncts", when I start typing a few characters, then the text next to that checkbox immediately changes from "Additional Conjuncts" to "Common Ligatures". Then I am not able to type 'ṅg' or such conjuncts. I'm not sure what has happened.

     

    I get the same problem when I restart Pages also. 

     

    When I type in Evernote, I am still not able to type ṅg, but the text next to the checkbox remains as "Additional Conjuncts" and remains checked as well.

     

    2.

    I am having trouble in typing avagraha.

    On the last page of the document in the following link, it says that avagraha is gotten by typing: >, shift + f; but it is not working.

    http://deimos3.apple.com/WebObjects/Core.woa/DownloadTrackPreview/emory-public.2 595939314.02595939325.2618536082.pdf

     

    All of the rest of the characters on that list are working for me; only avagraha is not working. (for ँ़ it is written incorrectly in the document; it is actually option + m, option + f)

     

    Please help me with avagraha.

     

     

    Thank you Tom,
    Rahul

  • Tom Gewecke Level 9 Level 9 (70,920 points)
    Currently Being Moderated
    Jan 1, 2014 5:46 AM (in response to rm555)

    1.  Sometimes Pages is not stable with those typography functions.  Are you using Pages 4 or the new Pages 5?  All you can do is keep trying or use something else like TextEdit.  As for 3rd party apps like Evernote, there is never any guarantee that they will support Apple typographical features, you would have to contact the people who make them.

     

    2. Will reply a bit later.

  • Tom Gewecke Level 9 Level 9 (70,920 points)
    Currently Being Moderated
    Jan 1, 2014 5:44 AM (in response to rm555)

    rm555 wrote:

     

     

    2.

    I am having trouble in typing avagraha.

     

     

    In Devanagari Qwerty, it seems to be Option + ':  ऽ

  • Tom Gewecke Level 9 Level 9 (70,920 points)
    Currently Being Moderated
    Jan 1, 2014 5:49 AM (in response to rm555)

    rm555 wrote:

     

    (for ँ़ it is written incorrectly in the document; it is actually option + m, option + f)

     

    For me it is actually Option + m, Shift + f:  ँ़

Actions

More Like This

  • Retrieving data ...

Bookmarked By (2)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.