Skip navigation

How to use PC numeric keypad in MacOS 10.4

566 Views 4 Replies Latest reply: Jun 30, 2013 12:22 PM by ZZANADUU RSS
spapakons Calculating status...
Currently Being Moderated
Apr 24, 2013 7:57 AM



Sorry if this is not the right place to ask. I work in a computer shop and recently I sold a cheap noname USB keyboard to an Apple user. I don't know which model his Mac is, but he told me it originally had MacOS 9 installed and he upgraded to MacOS X 10.4 Tiger which is the maximum supported by the hardware. The new keyboard works fine, except for the numeric keypad. It is always off and I wonder if there is any way to enable it so he can type numbers from there. I went to his place, had a look in Settings/Keyboard but could not find anything relevant. I also tried Google, but I didn't manage to find anything useful. I hope you know which setting or key combination or third-party utility can enable the numpad in a non-apple keyboard at a real Mac. If the keyboard where Microsoft or Logitech, I could try the respective driver, but as I already said this is noname.


Any help appreciated.


Thank you in advance




<Email Edited by Host>

PowerMac, Mac OS X (10.4)
  • rccharles Level 5 Level 5 (5,150 points)
    Currently Being Moderated
    Apr 24, 2013 11:24 AM (in response to spapakons)

    I remember way back in the PC days there was some key you pressed on the keyboard to switch between numberic mode and cursor mode on the keyboard.


    I'm surprised the keyboard didn't work.


    Proably cheapest solution is to buy an apple keyboard.


    There are keyboard remapping programs around, but Tiger is old so there would be extra searching.

    Here is one example... I do not know how much work this would be.

    Simply use DoubleCommand software.  It is a free program


  • rccharles Level 5 Level 5 (5,150 points)
    Currently Being Moderated
    Apr 24, 2013 1:31 PM (in response to spapakons)

    Here is an app to tell you the keycodes.


    I also read somewhere that I should disable mouse keys,

    That's under universal access.  [ handn't thought of that. ]


    blue apple > system preferences > universal access


    Picture 2.png

  • ZZANADUU Calculating status...
    Currently Being Moderated
    Jun 30, 2013 12:22 PM (in response to spapakons)

    Hey folks I figured it out for Mountain Lion. Go to system preferences > select Accessibility under System group > select Mouses and Trackpad from the left hand side of the window > Uncheck Enable Mouse Keys ----------- Eureka! It worked for me - I have a Mac Mini. See screenshot below-

    Screen Shot 2013-06-30 at 16.14.20 PM.png


More Like This

  • Retrieving data ...

Bookmarked By (0)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.