Skip navigation

Keep losing internet connection

166017 Views 171 Replies Latest reply: Apr 6, 2014 8:10 PM by Nickpicnic RSS
  • vriensr Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 27, 2012 2:18 PM (in response to Skyler12345)

    My problem:

    My wired LAN has following clients: a number of NAS's (several brands), a few Windows PC's, a few iPhones (wireless), an iPad (wireless), a router, a printer, a multimedia player, and a brandnew iMac 27".

    Guess what? I haven't had a single problem on my network for years, ... until ... right, after connecting my new iMac running Lion/Mountain Lion.

    Still none of the devices have problems, except for the  iMac which keeps losing Shares all the time.

    It is even funny, when looking at Shares  in Finder that disappear automatically  and sometimes re-appear after a while.

    The most problematic was the constant disappearing TimeMachine on my QNAP NAS.

    During a Backup I had to perform a few iMac restarts to get it finished...

     

    My solution:

    I tried many 'solutions' which I found on different forums; none of them fixed the problem.

    One simple action finally made my TimeMachine available 100% of time:

     

    Start Finder

    Select Go

    Select Connect to Server

    Enter TimeMachine address as follows:   afp://<IP address>/TMBackup

    Select + and Connect

     

    This way I managed to have my QNAP NAS TimeMachine available for 100%, even surviving network access and sleeps of my iMac...

     

    Maybe some of you can benefit from this approach.

    If there is a reason why not to choose this solution, feel free to comment.

  • vinylrichy Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 5, 2013 5:35 AM (in response to dolsen)

    I have the same issue still.

     

    I turn wifi on it conects to my router (and other routers with same issue) will show as having a correct IP addres and default gateway. I can ping the IP address, but no default gateway so not actually receing any info from router. My Iphone can connect to the net via wi-fi as well so im 100% its not router.

     

    When i diagnose it shows no conection to ISP. A few sesconds after this the page refreshes then gives the all clear green connected.

     

    I leave this page and a few seconds later it goes off again. It simply does not work.

     

    Ive even got hold of a USB wireless card and it connects with no issues, which is fine but ive then lost a valuable USB port!

     

    Whats the fix for this Apple?! I paid a lot of money for my Macbook and it doesnt work. Is it a software issue? or is the wilress card bust? I would imagine it has to be a software issue as wirless does detect and connect but only for a few seconds.

     

    Not happy.

     

      Software Versions:

      CoreWLAN:          2.1.3 (213.1)

      CoreWLANKit:          1.0.3 (103.2)

      Menu Extra:          7.2 (720.1)

      configd plug-in:          7.4.1 (741.1)

      System Profiler:          7.0 (700.3)

      IO80211 Family:          4.2 (420.3)

      WiFi Diagnostics:          1.0.2 (102)

      AirPort Utility:          6.1 (610.31)

      Interfaces:

    en1:

      Card Type:          AirPort Extreme  (0x14E4, 0x88)

      Firmware Version:          Broadcom BCM43xx 1.0 (5.10.131.36.15)

      MAC Address:          00:1e:c2:ae:83:40

      Locale:          ETSI

      Country Code:          X3

      Supported PHY Modes:          802.11 a/b/g/n

      Supported Channels:          1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13, 36, 40, 44, 48, 52, 56, 60, 64, 100, 104, 108, 112, 116, 120, 124, 128, 132, 136, 140

      Wake On Wireless:          Supported

      Status:          Off

  • Gamble82 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 5, 2013 8:33 AM (in response to dolsen)

    I told you, it's basically an IP conflict, but it doesn't look like one.

     

    Try giving it a static IP and see if that works. It not do what I did.

     

    Turn off ALL internet/wifi devices. EVERYTHING that has an IP. Tivo, router, phone, laptops, desktops, gateways, etc etc.

    Turn on your mac that has the issue first. Once it grabs and ip address, turn the rest of the devices on.

  • vinylrichy Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 5, 2013 8:42 AM (in response to Gamble82)

    Hi,

     

    I had already tried assigning static Ip to MacBook to no avail. Since then I have done a pram reset using ctrl alt p &amp; r and startup and now when I click on wi-fi it says "hardware not installed" and my USB Wireless has also failed.

     

    Tried to pram again and waiting for the 3 chimes. This doesn't work.

    Tried to do a hardware test holding D at boot, but this doesn't work and I have no startup disks (bought MacBook from eBay)

     

    Pretty much screwed for wi-fi.

     

    Looks like a trip to Apple store for me. Time to dust off the credit card :(

  • smb12321 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Feb 2, 2013 1:33 PM (in response to pshooter)

    I found a permanent fix!!  This sounds lame but I am aPC guy so I called the Help desk (I have a warranty),  First time they simply sent some URLs.  Second time the guy asked me more questions thanI asked him.  Third time I got a no-nonsense gal (showing my age) who said, "Yes, I know what to do."

     

    She led me through a series of menus (don't ask) but essentially I had to remove my network from some "sleep" menus and change a few values and prestor - have kept wi fi and network for 2 weeks without a hitch.  I've made other calls and when I get the "I'll sent you some links"  I call back until I find someone who knows what they are talking about.   Good luck!

  • vinylrichy Level 1 Level 1 (0 points)
    Currently Being Moderated
    Feb 3, 2013 12:40 AM (in response to smb12321)

    Glad you're working. Would have been nice to know the details of your fix though ;)

    I'm still not working. MacBook is close to going in the bin as I've wasted too many hours on trying to fix this. Why do Apple charge to fix this. I like apple but their post sales support is dire.

    This is an Apple problem. Fair enough, if I had broken the laptop the inwould have no issues paying to have it repaired, but when I have not actually caused this issue then I'm left a sad panda.

  • mej50 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Feb 6, 2013 9:36 AM (in response to Gamble82)

    THANK YOU!!!  I've been at my wits end trying to get this figured out.  Between having Hughesnet internet which is s--l--o--w, and the constant dropping of the wi-fi, I was starting to hate working with my iMac.  Last night, after reading your post, I turned EVERYTHING that is wireless off (printers, iPad, iPhones, all computers, and my Apple Time Capsule router)  Turned the iMac back on first, then the time capsule.  Everything seemed to be working fine last night.  This morning added the other wi-fi products and it is still working just like it did when I first got it.  What a relief and what a simple solution!!

     

    LISTEN TO THIS PERSON PEOPLE - He knows what he's talking about!!!

  • areitan Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 7, 2013 11:44 AM (in response to dolsen)

    Hello out there

    I think I found the problem.

    I just got a new IMAC and it's losing my internet connection from my timecapsule.

     

    I just changed "Konfigurer ipv6" to automatic (se pic)

    save and restart

     

    Skærmbillede 2013-03-07 kl. 20.31.24.png

    Problem solved.

     

    I hope it works to all of you

     

    thanks from

    Reitan

  • kzinvogon Level 1 Level 1 (5 points)
    Currently Being Moderated
    Mar 31, 2013 4:41 AM (in response to areitan)

    Sorry but i dont think this is the problem as all my machines have IPV6 enabled automatically.

     

    Just to be clear the wifi connection stays up and it happens on any wifi ,or even on a cable connection to the USB ethernet port. On my MACPro it happens on all ports .

     

    What happens is web sites don't respond and Outlook 2011 connected to exchange declares itself as being unable to find a DNS server.

     

    So i go to terminall and ping 8.8.8.8 (being the ip address of a google name server)  to see if the network is up and i get a reply so the network is UP

     

    Then i ping www.google.com and get no response..

     

    Of course one of the tricks is to flush the dns cache but this no longer works or even tried to use OpenDNS and still no good.

     

    Only thing to do is switch the various interfaces off andf back on again. I am infuriated with Apple over this issue which is clearly an OS bug that came when i upgraded to Mountain Lion. All my PC's, Iphones, Ipads, TV's experience no problems at all with connectivity. So you tell me Apple?

  • jzyap Level 1 Level 1 (0 points)
    Currently Being Moderated
    May 6, 2013 4:06 PM (in response to dolsen)

    until now,apple hasnt resolve this issues.crappppppppppppppp youuuuuuuu

  • Dottore de Funk Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jun 27, 2013 11:52 PM (in response to jzyap)

    I think this must be hardware related as I onlt have one machine that this happens on - an Imac 24 Core 2 Duo 2.8gig running Lion. All my other devices, old macs running 10.5 or 10.6 and phones and ipads are fine. And now I have a new MacBook pro on Mountain Lion and it seems fine too.

     

    Nothing I have done so far sorts the iMac.

  • Dottore de Funk Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jun 27, 2013 11:56 PM (in response to Dottore de Funk)

    Oh and the iMac was fine before "upgrading" to Lion so I think it is some kind of issue with Lion and the iMac hardware.

  • maddik Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jun 30, 2013 3:51 PM (in response to xtech)

    I too am in the same boat. Brand new mac 27" osx 10.8.4., comcast, cable modem via comcast, netgear wgr614v10, (1) cpu hardwired and now this one....***?  All other wirless devices in my house work flawlessly (kindle, Toshiba laptop etc).  Any suggestions?

  • smb12321 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jun 30, 2013 11:06 PM (in response to maddik)

    I had the exact problem.  Upgraded to ML, everything else worked fine.  I hate to say this but I was lucky.  I called support and got someone who knew the answer immediately.  It was a matter of changing a few settings that he had me mark, change, etc.  So sorry I can't remember but it was a quick 30 second fix and no problem since months ago.  It was NOT hardware, modem, OS, etc but a few settings.  Call support and hopefully you can get someone helpful.

  • shaedlyn Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 7, 2013 10:04 AM (in response to smb12321)

    that's absolutely incredible to me! I hope everyone on this forum calls Apple to say *** share the information. i've been experiencing this off and on for a year and i think it's the keychain, but every fix gets corrupted eventually. i'll call Apple, but i no longer have Apple Care so we shall see where it goes.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (6)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.