3 Replies Latest reply: Jul 3, 2013 10:35 PM by AceNeerav
AceNeerav Level 1 Level 1 (95 points)

This is the first time I am using a 3G data Modem. My dad got this from his work and today is its first day of use. It worked find on the office computers my dad has which run windows.

 

I connected it to my macbook pro mid 2010 running ML 10.8.4. The blue light never went steady. I know there is enough 3G network from Vodafone on my desk as my iPhone 5 and iPad Mini also receive signals from the same operator.

 

Also, the app that is loaded in the model would launch, but, quit on its own. I searched this and other forums and came to know that this is some common problem but I didn't find a soultion anywhere. Also, one thread mentioned that it fails to run because it is a 32bit app, which i came to know from get info that it is indeed 32 bit.

 

Can someone tell me how to get this running?


MacBook Pro, OS X Mountain Lion (10.8.2), 13 inch, 2.4 Ghz, Mid 2010
  • 1. Re: Huawei e3131 with os x 10.8.4.... how?
    nbar Level 5 Level 5 (6,945 points)

    I can tell you that ML is definitely compatible with 32 bit apps even though it is a 64 bit kernel.

  • 2. Re: Huawei e3131 with os x 10.8.4.... how?
    BobTheFisherman Level 6 Level 6 (10,970 points)

    Did you download and install the device OSx driver from the manufacturer's site, if there is an OSx driver? USB devices such as the one you describe typically need installation of their driver in order for them to work.

  • 3. Re: Huawei e3131 with os x 10.8.4.... how?
    AceNeerav Level 1 Level 1 (95 points)

    GOT IT WORKING!

     

    Read a lot and came to this blog. realized that this blog is incomplete as well. then after installing another version of mobile partner which didn't load the configuration files, i just unplugged and replugged the modem and it launched the installer on its own!

     

    Basically the installer package within the app bundle should launch automatically but it doesn't! just go inside the app bundle "right click on the app and select 'show package contents' ". and try and locate the installer package in resources folder. double click and let it install. unplug and re plug the modem. done!

     

    somehow the option to start the wifi hotspot of my modem still doesn't appear like it does on the window machine i have at home.

     

    Neerav