4 Replies Latest reply: Jul 15, 2013 10:56 AM by jelstro1
jelstro1 Level 1 Level 1 (0 points)

I have a pretty unique setup and situation with our Time Capsule causing us some major problems:

 

We are an after school music program for teens with 7 iMacs that members use to create and edit music in GarageBand. Their files are stored on a partition of a Time Capsule that they're all given a folder on to store GarageBand projects in. Believe it or not, for the past 4 years this has worked perfectly. They've been able to open GarageBand projects from the Time Capsule's drive partition and edit, record and mix Garage Band projects in real time all while streaming over wifi.

 

About 3 or 4 months ago in March 2013 (I'm thinking there was a Time Capsule firmware and/or Airport Utility update around the time it started) about 5 minutes after anyone opens their GarageBand projects from the Time Capsule partition, their iMac disconnects from the Time Capsule's partition and Garage Band basically goes haywire. It sort of moves their project to "no man's land", it's not on the computer's local hard drive and it can't see it on Time Capsule, so when you try to record it says "drive partition full" and even worse, if you try to save Garage Band usually crashes and loses their work. Even if you try to do "Save As" and move it to a local location it'll still crash and lose their work.

 

Dragging their file from the Time Capsule partition to the computers desktop and working on the project locally for the day works, but isn't really a good solution as kids have trouble grasping file management and lose their files between computers when they work this way.

 

Our Time Capsule is about a year and a half old, Firmware version 7.6.3 and Airport Utility on the Mac I use to admin things is 6.3.

 

A weird problem I know, but we are desparate for help!


Time Capsule, Mac OS X (10.7.5)
  • 1. Re: Time Capsule Frequently disconnecting users from drive partitions
    LaPastenague Level 8 Level 8 (35,380 points)

    7.6.3 firmware definitely has more bugs than previously.

     

    IMHO the first step is to downgrade the TC.. use 7.6.1 or even 7.5.2 on an 18month old TC might work better than any 7.6 version.

     

    Secondly 6.3 is problematic as a utility.. apple seem to have made ipv6 local-link a necessity..

     

    See the rather belated advice..

    http://support.apple.com/kb/TS4597

     

    Downgrade firmware is easy in v6 utility.

     

    Simply select version with option key held down. Select the version you want to use and it will downgrade.. (or maybe that is an upgrade!!)

     

    firmwareupgradeau6.png

    You can also use 5.6 utility to manage the TC.. since it is not the latest greatest which needs the latest not so greatest utility.

     

    How to load 5.6 into ML.

     

    1. Download 5.6 for Lion.

    http://support.apple.com/kb/DL1482

    Click to open the dmg but do not attempt to install the pkg.. it won't work anyway.

     

     

    2. Download and install unpkg.

    http://www.timdoug.com/unpkg/

     

     

    Run unpkg on the desktop.. it is very simple.. drag the AirPortUtility56.pkg file over to unpkg.. and it will create a new directory of the same name on the desktop.. drill down.. applications utilities .. there lo and behold is Airport utility 5.6 .. drag it to your main utilities directory or just run it from current location.

     

     

    You cannot uninstall version 6 (now 6.3 if you updated) so don't try.. and you cannot or should not run them both at the same time.. so just ignore the toyland version.. the plastic hammer.. and start using 5.6.. a real tool.

     

    For screen shots see this post.

    https://discussions.apple.com/thread/4668746?tstart=0

     

    You only need to do this on the computer that is going to manage the files.. but it is easy once you have the actual 5.6 utility to just copy it to every computer in the network.

     

    Sounds like interesting stuff.

    The TC is not designed as a NAS.. so if this really doesn't work out, I would be looking at a 2 disk synology so you can run mirrored raid.

     

    And of course backup is so much easier in a real NAS.. TC has no inbuilt backup ability, and TM cannot backup network drives.. so Apple kind of didn't intend TC to do this job.

  • 2. Re: Time Capsule Frequently disconnecting users from drive partitions
    jelstro1 Level 1 Level 1 (0 points)

    Ahhhhhh. Thank's so much for the advice. Downgrading was the first thing I wanted to try, but I couldn't figure out just how simple it was. Just did the firmware downgrade and need to wait until I have kids in here doing some projects in a few hours to see if it's really working.

     

    As for our use of TC as a NAS, it's convoluted, yes, but a cost effective solution that worked surprisingly well until this problem started. The TC backs up all of it's partitions to a HD that's wired to an iMac left on overnight, doing a different partition each night, via Chrono Sync.

  • 3. Re: Time Capsule Frequently disconnecting users from drive partitions
    LaPastenague Level 8 Level 8 (35,380 points)

    The TC backs up all of it's partitions to a HD that's wired to an iMac left on overnight, doing a different partition each night, via Chrono Sync.

    Excellent.. that I guess was my main concern.. for this kind of setup.

     

    And I agree with your pragmatic approach.. it works.. it doesn't need more.

    Nevertheless, next time around, budget permitting.. I would still look at a more.. elegant... solution.

  • 4. Re: Time Capsule Frequently disconnecting users from drive partitions
    jelstro1 Level 1 Level 1 (0 points)

    I succesfully downgraded and it felt like things were going okay for a few days, but we're right back to square one as of today.

     

    Anyone have other possible ideas?