2 Replies Latest reply: Jul 4, 2013 2:41 PM by Chris CA
everydaydano Level 1 Level 1 (0 points)

In the new iTunes, (11.0.2), there is a glitch where renaming the song won't change it's order.  For example, a Violin Concerto downloaded from iTunes appears under "V" even though I renamed the file to include the composer's name "Britten: Violin Concerto".  I want to have all of my music sorted by composer, not album, title, or artist.  In older versions of iTunes, this was simple, just be double-clicking the name of the song, and adding the composer's name to the track if it wasn't there already.  Now that this isn't working, is there any way to get around it?  It's a very annoying thing to look for a piece by a particular composer, and have to scroll through hundreds, if not thousands of tracks, having no idea where it might appear.


iMac
  • 1. Re: renamed files don't appear in alphabetical order
    Imp68 Level 4 Level 4 (2,155 points)

    Right click the song >> get info >> see "name" field.

     

    I've tested this and it works fine.  Also, make sure you're in Song view and it's sorted by name.

  • 2. Re: renamed files don't appear in alphabetical order
    Chris CA Level 9 Level 9 (74,885 points)

    In the new iTunes, (11.0.2)

    New iTunes is 11.0.4.

    everydaydano wrote:

     

    I want to have all of my music sorted by composer, not album, title, or artist.  In older versions of iTunes, this was simple, just be double-clicking the name of the song, and adding the composer's name to the track if it wasn't there already.

    This is sorting by title field (actually Name) (which had the compser name in it), not Composer field, which is a separate field.

     

    Select Songs view.

    iTunes menu View > View options.

    Tick Composer.

    Then click on the Composer field to sort by composer.