Skip navigation

imac the USB stick serial killer!

2188 Views 6 Replies Latest reply: Jul 5, 2013 10:22 AM by BDAqua RSS
JohnnyCordner Calculating status...
Currently Being Moderated
Jun 20, 2013 5:04 AM

Need help with USb drives. I'm using a imac osx10.4. I was copying 6.65GB of data onto my 8GB USB stick. It got to copying 6.64GB of the data then was shown an error message saying it could not complete copying. The flash drive then disappeared from my desktop. When I took it out and put it back again it was not showing up at all. I restarted imac and its still not showing. The USB stick is not showing in 'Disk Utility' either. I would not mind so much but this has happened several times before on a various macs with other other USB sticks/drives and when copying even less data.There was already about about 1 MB of docs on the USB which I do need to recover.

 

I've been using an imac for 3yrs but never got into the tech side so much. I found this: "Tutorial: Common fixes for USB device issues (unrecognized, etc.)" here: http://reviews.cnet.com/8301-13727_7-10328879-263.html?tag=mfiredir I've tried most of this and I am current downloading 'xcode to run 'USB Prober' I'm not reinstalling OSX and mucking around with the imac settings as the problem is with the usb stick not the imac.

 

Previously when this happened I put the flash drive in my 10yr old windows xp machine which recognised the USB stick and so I could then use recovery software to restored the drive and its contents. This time the USB stick did not at first show up on my PC, on either 'my computer', 'disk management utility' or my various recovery software. However after restarting my pc a few times the USB stick did show up as "inaccessible" and in the 'properties' it showed as 'capacity full'. I still cannot access the stick, run scan disk or even reformat it.


This is the 4th USB stick victim a imac has killed on me. Anyone know a free solution to fixing a USB stick on a mac?

  • Klaus1 Level 8 Level 8 (43,355 points)
    Currently Being Moderated
    Jun 20, 2013 9:48 AM (in response to JohnnyCordner)

    Did you format the USB stick in Disk Utility before copying anything to it?

  • BDAqua Level 10 Level 10 (114,705 points)
    Currently Being Moderated
    Jun 20, 2013 10:10 AM (in response to JohnnyCordner)

    What brand/model sticks are they?

     

    Any possibility of a Gound Loop in your Mini or some peripheral?

  • rccharles Level 5 Level 5 (5,150 points)
    Currently Being Moderated
    Jun 20, 2013 10:45 AM (in response to BDAqua)

    You should format the flash drives with disk utility. Use:

             Picture 2.png

     

    I can only suggest a recovery tool, which you tried.

     

    I buy the cheapest flash drives and I haven't had a problem.  The default format is fat32 which is the old dos format & isn't so good.

     

    Robert

  • rccharles Level 5 Level 5 (5,150 points)
    Currently Being Moderated
    Jul 5, 2013 10:12 AM (in response to JohnnyCordner)

    Need help with USb drives. I'm using a imac osx10.4. I was copying 6.65GB of data onto my 8GB USB stick.

     

    fat32 supports a max of 2 or 4 gig files. Tiger is read only for NTFS.  You would have had to install some other driver to write.

     

    The number on the drive is where k=1000. Tiger uses k=1024.

     

    Anyway, you get less space on a formated drive.  Looks like you get about 7.5gig useable space from a 8GB drive.

     

    The copy should not have trashed the drive. Should have gotten an error message. 

     

    Tiger defaults to building a spotlight database on the drive.  This will take up more space.

     

    Use the spotless application to turn off indexing.

    http://www.fixamac.net/software/spot/

     

    Robert

  • BDAqua Level 10 Level 10 (114,705 points)
    Currently Being Moderated
    Jul 5, 2013 10:22 AM (in response to JohnnyCordner)

    Hi Johnny,

     

    What all shows as checked in Finder>Preferences>General & Sidebar?

     

    Safe Boot , (holding Shift key down at bootup), use Disk Utility from there to Repair Permissions, test if things work OK in Safe Mode.

     

    Then move these files to the Desktop...

     

    /Users/YourUserName/Library/Preferences/com.apple.finder.plist

     

    /Users/YourUserName/Library/Preferences/com.apple.systempreferences.plist

     

    /Users/YourUserName/Library/Preferences/com.apple.sidebarlists.plist

     

    /Users/YourUserName/Library/Preferences/com.apple.desktop.plist

     

    /Users/YourUserName/Library/Preferences/com.apple.recentitems.plist

     

    Reboot & test.

     

    PS. Safe boot may stay on the gray radian for a long time, let it go, it's trying to repair the Hard Drive.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.