3 Replies Latest reply: Jul 6, 2013 3:35 PM by léonie
Buzzkeeper Level 1 Level 1 (0 points)

I am trying to update Apterture 3.1.1 to latest version. I am using Mountain Lion 10.8.4 When I download the update and open, it tells me I need at least version 3.0 Please help!


Aperture 3, OS X Mountain Lion (10.8.4)