Skip navigation

portable hard drive no longer recognised

301 Views 8 Replies Latest reply: Jul 8, 2013 1:51 AM by Steve Burke RSS
Steve Burke Calculating status...
Currently Being Moderated
Jul 6, 2013 8:05 AM

Hi. does anyone know why my portable exterior hard drive in now not being recognised and showing up on my desktop? I'm also having itermittent issues with my USB sticks too.

 

I've tried various USB ports and restarted the iMac but still nothing ...

 

Thanks in advance

iMac (27-inch Late 2009), Mac OS X (10.6.8)
  • steve359 Level 6 Level 6 (12,035 points)
    Currently Being Moderated
    Jul 6, 2013 8:09 AM (in response to Steve Burke)

    USB draws power from the main power supply.  There are limit to what that can provide.

     

    My first suggestion is a "powered USB hub", that uses a wall plug to supplement USB power with AC from the wall.  Available for as little as $20 from BestBuy or Target.

     

    May fix all of your external-USB issues.

  • Allan Jones Level 7 Level 7 (29,585 points)
    Currently Being Moderated
    Jul 6, 2013 10:04 AM (in response to Steve Burke)

    I vote for Steve's solution---historically it is a winner.

     

    However, if you can't get the powered hub for a while, offload the files from  the external to the computer, then use Disk Utility on the iMac to erase and reformat the drive as Macintosh Extended (Journaled). Most of these external are shipped formatted for Windows but one that both Macs and peecees can use.

     

    There are many reports across the forums that having a native Mac format on a portable external drive helps with the power drain issue. However, if you must share the drive with a Win computer, don't reformat.

    iMac 27-in; Mid 2010 2.93G i7 Quad, Mac OS X (10.6.8), 12GB RAM; ATI5750 1G VRAM
  • steve359 Level 6 Level 6 (12,035 points)
    Currently Being Moderated
    Jul 6, 2013 2:50 PM (in response to Steve Burke)

    Go with the powered hub ... common enough item at computer parts stores and Best Buy.

     

    As to "why now"?  Maybe the power supply has lost just a little of its original capacity and now cannot run them while still running the main system.

  • WZZZ Level 6 Level 6 (11,880 points)
    Currently Being Moderated
    Jul 7, 2013 3:51 AM (in response to Steve Burke)

    Have you got another cable to try? What kind of drive is this? Is it by chance a WD?

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.