Skip navigation

Does anyone else this error after iPhoto crashes when importing?

221 Views 4 Replies Latest reply: Jul 7, 2013 2:11 PM by DJWebDUck RSS
DJWebDUck Level 1 Level 1 (5 points)
Currently Being Moderated
Jul 7, 2013 1:46 PM

I tried searching for answers on Google, Bing, Webcrawler, and even Wolfram but there is no answer for this anywhere on the web.  Just got done installing my new hard drive.  I made sure to backup EVERYTHING and I even made a zip copy of my iphoto library.


On my initial first launch of iPhoto, I try to import my library and iPhoto crashes after about 3 seconds.  In the error report window that comes up, it lists this as the reason why it was terminated:


'[<NSCFDictionary 0x1f0ad190> valueForUndefinedKey:]: this class is not key value coding-compliant for the key 1140.'


Does anyone know if this is a simple code fix or how to solve errors like these?  Remember, this is fresh install of OS X on a new SSD hard drive.  All of my Adobe apps are running great with no hassles.  The only apps that are giving me trouble are iPhoto and Aperture.


Even worse is that now Aperture is stalling every time I try to export a version of a photo that I retouched.  I'm thinking it probably has something to do with why iPhoto constantly crashed when importing.


Any ideas or suggestions would be greatly appreciated. Thank you!

MacBook Pro, Mac OS X (10.6.8), Core 2 Duo 2.4GHz 6GB RAM w/ SSD


More Like This

  • Retrieving data ...

Bookmarked By (0)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.