Skip navigation

DNS with multiple connections -or- how to set "primary" IP?

552 Views 3 Replies Latest reply: Jul 9, 2013 2:04 PM by MrHoffman RSS
Brian Dieckman Calculating status...
Currently Being Moderated
Jul 9, 2013 9:32 AM

A server that previously had only one purpose (file server) is now serving a second purpose (receiving files over sftp). Because the software that sends the files over sftp can't be changed, I set the second ethernet port on this server to the same settings as the server that was decomissioned. (Same network, different IP)

 

The hostname of this machine SHOULD be: myservername.something.something.com

The hostname of this machine is being reported as: myservername.local.

 

That means DNS is broken on this machine, which ***** because it's my OD Master and I can't get clients to bind.

 

When I run "sudo changeip -checkhostname" I get the followng response:

Primary address = xx.xxx.xx.1

Current HostName = the.correct.host.name

The DNS hostname is not available, please repair DNS and re-run this tool.

 

The problem is that the IP address listed under "Primary address" isn't the address to which the host name is registered. (Let's say the hostname is registered to xx.xxx.xx.2)

 

So I either need to set the server's "primary" IP to the correct address, or figure out how to use changeip -checkhostname to check a specific adapter.

 

dig and dig -x return the correct data for the IP and hostname... the DNS servers are set up correctly.

 

Any advice on properly setting up DNS on a server with two IP addresses?

 

Thanks in advance!

  • MrHoffman Level 6 Level 6 (11,745 points)

    If the host name is myservername.local, then DNS services are configured incorrectly.  The .local top-level domain is reserved to mDNS (Bonjour) and should not be mixed with DNS (unicast DNS); that mixing usually works, but it's not reliable and not recommended per public statements by some of Apple's networking engineers.

     

    As for selecting the primary address, drag the primary address to the first position in Network Preferences.

     

    DNS itself doesn't care if there are multiple addresses associated with a host.  That'll all work fine, so long as the subnet routing is set up correctly.

  • MrHoffman Level 6 Level 6 (11,745 points)

    It might appear that your local DNS configuration is wrong.  Here's how to set up OS X Server DNS services.  (That was written for Snow Leopard, but the Lion and Mountain Lion setup is basically the same, once you select Show All Records in the DNS configuration section of the Server.app tool.)

     

    If you have plant-wide DNS servers available (such as those that are part of the typical Microsoft Windows Server Active Directory setup), you don't need to run DNS services on your OS X Server box.  Simply reference the plant-wide DNS servers. 

     

    (Any DNS that's considered "plant-wide" should probably also be "servers"; multiple DNS servers with some primary and secondary servers.  FWIW.)

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.