9 Replies Latest reply: Jul 10, 2013 12:54 PM by Ralph Johns (UK)
chattphotos Level 4 Level 4 (1,440 points)

Hi, just got back from Austria, I was using Messages there without problem for the past 4 months.

 

I am now at home in the USA, messages is freaking out, and it's not letting me sign in.

The only other thing that changed in iMessage was my phone number, that's it.

 

I've already trashed the preferences, is there anything else to try?


MacBook Pro, OS X Mountain Lion (10.8.3)
  • 1. Re: Messages not working (after crossing the ocean)
    Linc Davis Level 10 Level 10 (118,305 points)

    This could be a complicated problem to solve, as there are many possible causes for it. Test after taking each of the following steps that you haven't already tried. Back up all data before making any changes.

    Before proceeding, test on another network, if possible. That could be a public Wi-Fi hotspot, if your computer is portable, or a cellular network if you have a mobile device that can share its Internet connection. If you find that iMessage works on the other network, the problem is in your network or at your ISP, not in your computer.

    Step 1

    Check the status of the service. If the service is down, wait tor it to come back up. There may be a localized outage, even if the status indicator is green.

    Step 2

    Restart your broadband device and your router, if different. You may have to skip this step if you don't control those devices.

    Step 3

    From the menu bar, select

     ▹ About This Mac

    Below the "OS X" legend in the window that opens, the OS version appears. Click the version line twice to display the serial number. If the number is missing or obviously invalid, take the machine to an Apple Store or other authorized service center to have the problem corrected.

    Step 4

    Back up all data, then take the steps suggested in this support article.

    There are five steps in that article. Please take all of them. If you don't understand some of the steps or can't carry them out, ask for guidance.

    Step 5

     

    From the menu bar, select

      

    System Preferences Network

      

    If the preference pane is locked, click the lock icon in the lower left corner and enter your password to unlock it. Then click the Advanced button and select the Proxies tab. If any proxy options are selected, make a note of them and then deselect them. You don’t need to change the bypass or FTP settings. Click OK and then Apply. Test. The result may be that you can't connect to any web server. Restore the previous settings if that happens.

     

    Step 6

    Reset the NVRAM.

    Step 7

     

    Enable guest logins* and log in as Guest. Don't use the Safari-only “Guest User” login created by “Find My Mac.”

     

    While logged in as Guest, you won’t have access to any of your personal files or settings. Applications will behave as if you were running them for the first time. Don’t be alarmed by this; it’s normal. If you need any passwords or other personal data in order to complete the test, memorize, print, or write them down before you begin.

     

    Test while logged in as Guest. After testing, log out of the guest account and, in your own account, disable it if you wish. Any files you created in the guest account will be deleted automatically when you log out of it.

     

    *Note: If you’ve activated “Find My Mac” or FileVault, then you can’t enable the Guest account. The “Guest User” login created by “Find My Mac” is not the same. Create a new account in which to test, and delete it, including its home folder, after testing.

    If iMessage worked in the guest account, stop here and post your results.

     

     

    Step 8

     

    Boot in safe mode and log in. Note: If FileVault is enabled, or if a firmware password is set, or if the boot volume is a software RAID, you can’t do this. Ask for further instructions.

     

    Safe mode is much slower to boot and run than normal, and some things won’t work at all, including Wi-Fi on certain iMacs.  The next normal boot may also be somewhat slow.

     

    The login screen appears even if you usually log in automatically. You must know your login password in order to log in. If you’ve forgotten the password, you will need to reset it before you begin.

     

    Test while in safe mode. After testing, reboot as usual (i.e., not in safe mode) and test again.

     

    If iMessage worked in safe mode, but didn't work when you booted out of safe mode, stop here and post your results.

     

    Step 9

    According to one anecdotal report, Flash Player may interfere with iMessage, though I don't know how and can't confirm. To test this theory, select from the menu bar

     

     ▹ System Preferences… ▹ Flash Player Storage

    and click

    Block all sites from storing information on this computer

    Close the preference pane. If this action solves the problem, please post your results.

    Step 10

    Reinstall OS X.

    Step 11

    If none of the above steps resolves the issue, make a "Genius" appointment at an Apple Store, or contact Apple Support.

  • 2. Re: Messages not working (after crossing the ocean)
    Ralph Johns (UK) Level 9 Level 9 (67,505 points)

    Hi,

     

    So you deleted com.apple.imservice.imessages.plist and com.apple.imessages.bag.plist  ?

     

    Did you remove the Apple ID from the old Phone (number) ?

     

    Technically it will allow two iPhone Numbers (add the Apple ID to the Settings in Messages on both).

     

    However what you then have is an Austrian +code then Number and presumably an U.S. +1 Country code then Number which might cause it problems as basically you are then telling the iMessages server you are in two places (country code-wise) when the system is obviously set up for you to be in one place (plus roaming).

     

    This may take a Genius Appointment or possibly an iTunes Account contact to sort this.

     

    3Sigcopy2.png
    8:55 PM      Tuesday; July 9, 2013

     

      iMac 2.5Ghz 5i 2011 (Mountain Lion 10.8.4)
     G4/1GhzDual MDD (Leopard 10.5.8)
     MacBookPro 2Gb (Snow Leopard 10.6.8)
     Mac OS X (10.6.8),
     Couple of iPhones and an iPad

    "Limit the Logs to the Bits above Binary Images."  No, Seriously

  • 3. Re: Messages not working (after crossing the ocean)
    chattphotos Level 4 Level 4 (1,440 points)

    Ya, I don't have imessages.bag, but I did trash the imservice one many times.

     

    Remove AppleID from the old phone number? what? I assumed iMessage managed that automatically.

     

    (iMessage on the iPhone is fully working with the US number)

     

    My Mac sees the right +1 number in iMessage and Facetime but I can't sign in.

    Screen Shot 2013-07-09 at 4.26.26 PM.png

  • 4. Re: Messages not working (after crossing the ocean)
    Eric Root Level 6 Level 6 (16,210 points)
  • 5. Re: Messages not working (after crossing the ocean)
    Ralph Johns (UK) Level 9 Level 9 (67,505 points)

    Hi,

     

    Although it looks like a long winded job following Linc's suggestions it is likely to bear fruit on this.

     

    Presumably this is the same physical phone with a new SIM card to give it a new U.S. number ?

    How is the iMessages server to know you don't want to link the Apple ID and the Old number if you have not removed it ?

     

    I have two iPhones and have trouble trying to keep one of them from Linking to the iMessages account on the Mac version of Messages.

    Each uses a different Apple ID (although both are linked to my iCloud account) and it tried to add the iPhone Number and the second Apple ID to Messages .

    You can "Deny" the pop up the app (or the iOS device) gets about this.

    However if you accept on one of them you have to remove the Apple ID from the iPhone and then break with the iMessages server (Turn Off Messages or put in Airplane Mode) to remove the link to the Apple ID.

    restarting the other iOS devices Messages app and the Mac version tends to then remove the iPhone Number and Apple ID

     

    The com.apple.imessages.bag.plist holds the info about the Server name and defaults about how iMessages are sent.

    This one may not be created until the account has logged in to give it the server name.

     

    iMessages on the Mac can have issues after the the update to OS X 10.8.2 as this then uses the Mac's Serial Number to create the Auth-token for the iMessages login.

    You seem to indicate you have updated  to at least this level.

     

    Linc's Step 4 and the Hosts file if you were blocking sites in Austria may be an issue.

    Have you changed DNS servers since arriving back in the States ?

    Have you changed Date and Time and Location ?

     

     

     

     

     

    3Sigcopy2.png
    9:54 PM      Tuesday; July 9, 2013

     

      iMac 2.5Ghz 5i 2011 (Mountain Lion 10.8.4)
     G4/1GhzDual MDD (Leopard 10.5.8)
     MacBookPro 2Gb (Snow Leopard 10.6.8)
     Mac OS X (10.6.8),
     Couple of iPhones and an iPad

    "Limit the Logs to the Bits above Binary Images."  No, Seriously

  • 6. Re: Messages not working (after crossing the ocean)
    chattphotos Level 4 Level 4 (1,440 points)

    I haven't messed with hosts, and yes the DNS servers did change, but that didn't help any.

     

    Also, I'm on Sprint, so I had to take the Austrian SIM out to enable the CDMA radio again.

     

    However, the keep it simple method was the trick, your date and time location tip hit the nail on the head!

     

    I forgot to take it off CET, I reset my location to EST and everything is working now.

     

    To note, I never thought the time zone would be such an issue for iMessage, or to take Apple to make an error message relavent to that.

  • 7. Re: Messages not working (after crossing the ocean)
    Ralph Johns (UK) Level 9 Level 9 (67,505 points)

    HI,

     

    It is because both iMessages type messages and the AIM/Jabber/Yahoo types are Time Stamped.

     

     

    3Sigcopy2.png
    7:00 PM      Wednesday; July 10, 2013

     

      iMac 2.5Ghz 5i 2011 (Mountain Lion 10.8.4)
     G4/1GhzDual MDD (Leopard 10.5.8)
     MacBookPro 2Gb (Snow Leopard 10.6.8)
     Mac OS X (10.6.8),
     Couple of iPhones and an iPad

    "Limit the Logs to the Bits above Binary Images."  No, Seriously

  • 8. Re: Messages not working (after crossing the ocean)
    chattphotos Level 4 Level 4 (1,440 points)

    Ah, I was on track with the time, just what I had was a contradiction to Messages.

     

    Thanks! Another trick to add to the book!

  • 9. Re: Messages not working (after crossing the ocean)
    Ralph Johns (UK) Level 9 Level 9 (67,505 points)

    No problem.

     

     

    3Sigcopy2.png
    8:54 PM      Wednesday; July 10, 2013

     

      iMac 2.5Ghz 5i 2011 (Mountain Lion 10.8.4)
     G4/1GhzDual MDD (Leopard 10.5.8)
     MacBookPro 2Gb (Snow Leopard 10.6.8)
     Mac OS X (10.6.8),
     Couple of iPhones and an iPad

    "Limit the Logs to the Bits above Binary Images."  No, Seriously