Skip navigation

DNS Server not working. Start Time "Not Available"

1023 Views 6 Replies Latest reply: Jul 10, 2013 4:30 PM by quarfie RSS
quarfie Calculating status...
Currently Being Moderated
Jul 10, 2013 9:07 AM

I lost power to my server last night in a power outage.

 

Today the DNS Server doesn't seem to be working. I verified that my server's IP is the primary name server on the clients, however all lookups are going to the secondary (public) name server and therefore giving the public IP address for LAN services.

 

To test it, I typed in Terminal (both on a client machine and on the server itself) "nslookup [myinternaldomain.com] [mydnsserverip]" and get ";; connection timed out; no servers could be reached"

 

When I load up Server Admin, I see that the DNS service is running but for Start Time it says "Not Available".

 

Tried stopping and starting the service.

iMac, Mac OS X (10.6.8)
  • MrHoffman Level 6 Level 6 (11,710 points)
    Currently Being Moderated
    Jul 10, 2013 10:35 AM (in response to quarfie)

    Are there any errors logged for the DNS server?  (Check the DNS server logs for diagnostics and details related to the server.  I've seen cases where the server is listed as running in Server Admin.app or in Server.app, but it really wasn't running, or wasn't running correctly.)

     

    As for the terminal, you can specify the IP address of the target DNS server with the dig command at the Terminal.app prompt:

     

    dig @8.8.8.8 www.apple.com

     

    That dig command asks Google DNS (the server at IP address 8.8.8.8) for an IP address of the Apple web servers.  Substitute your local IP address and your local host names for translation, and see what you get.

     

    I would not recommend the "secondary" be a public DNS server, as which DNS server gets selected for a DNS query is not particularly deterministic.  I much prefer to have "peer" servers specified; primary and secondary DNS servers that have the local address(es) and local DNS domain names, and to avoid referencing off-LAN DNS servers save via the root server and related queries generated from these local DNS servers.

  • MrHoffman Level 6 Level 6 (11,710 points)
    Currently Being Moderated
    Jul 10, 2013 12:31 PM (in response to quarfie)

    To confirm, you're using the @ notation on the dig, and you've specified the IP address of your DNS server, correct?

     

    You can see if the DNS server (named) is really running with the following Terminal.app command:

     

    sudo lsof -i -P | grep -i ":53"

     

    That'll report anything on TCP and UDP port 53 (which is used by DNS) (plus possibly a few ports beginning with 53 that you can ignore).  If things are working, you should see some named processes.

     

    In general, you'll want to post the specific command used, and the full text of the response, as a starting point.  While it is distinctly possible there's an IP networking or cabling or DNS error here, there's not enough information posted to hint at a direction.  (It would definitely appear that the DNS server is not running, though.)

     

    Here's some DNS server configuration reading for you.  That sequence is for Snow Leopard 10.6, but will work the same with OS X Server on Lion 10.7 and Mountain Lion 10.8, if you've selected Show All Records within Server.app.

  • MrHoffman Level 6 Level 6 (11,710 points)
    Currently Being Moderated
    Jul 10, 2013 3:50 PM (in response to quarfie)

    Yeah; your DNS server isn't running.  You'd see some "named" processes if it was.

     

    In OS X Server 10.6.8 in Server Admin.app (unlike in various newer versions ), you can crank up the DNS debugging level through the GUI.  Do that.  Launch Server Admin.app, select the server, select DNS, select settings, and set the DNS log level settings to "debug", and see if you can get something more logged.

     

    The default DNS log file can be found and displayed via Console.app (Applications > Utilities) or from Terminal.app via the /Library/Logs/named.log file. 

     

    You might also find some relevant errors in /var/log/system.log file, depending on why the DNS startup is cratering.

     

    Console.app can also show you a mass of messages, and you might also see where named is encountering error(s).  If it's the usual crash-restart schtick, you'll get the same block of restart message(s) logged in the Console.app messages every five or ten or fifteen seconds; whatever the restart interval for the DNS server.

     

    Though it's a little late here, I'd generally recommend configuring a less-interruptible power supply — a LIPS, as they're never truly uninterruptible — battery backup — as OS X Server doesn't really like having the power yanked out.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.