1 Reply Latest reply: Jul 10, 2013 3:12 PM by Klaus1
robertstroh@mac.com Level 1 Level 1 (0 points)

I have an old IMAC using 10.5, and it cannot use any newer operating system. I need a new printer, but I cannot find one that is compatible with this old system.

 

Is there a new printer out there that will work with 10.5?

 

Thanks,

 

Niles Stroh


imac power pc, Mac OS X (10.4.11)