Skip navigation

Poor resolution when plugged into 1080p 32" TV

156608 Views 168 Replies Latest reply: Mar 22, 2014 11:59 AM by Diesel Power JC RSS
  • turtleneck and beret Level 1 Level 1 (0 points)
    Currently Being Moderated
    May 12, 2013 11:38 PM (in response to H.M.J.)

    I'm glad to hear you got it working!

     

    I hope that you won't have to experience the full extent of the problem that people in this thread are having.

    That is, that the OS one day will forget the native resolution of the external display and automatically select a lower resolution or underscan. This can usually be fixed by manually setting the resolution (Use option (alt) while clicking "scaled" when selecting resolution in the display settings in OS X) but unfortunately, sometimes this doesn't show the desired (and sometimes even previously working) resolution(s).

     

    Enjoy your 1080p!

  • H.M.J. Level 1 Level 1 (0 points)

    Thanks. I haven't had exactly the problem you describe, but if the TV is not on with the HDMI channel selected, XBMC opens in Full Screen #1 mode, on the MBP screen. I then have to change the XBMC System settings to  Full Screen #2 after I turn on the TV. Once I also had to recalibrate XBMC output after a crash of the program. I don't know what you mean by "Use option (alt) while clicking "scaled" when selecting resolution in the display settings in OS X." I couldn't find anything like that. One thing I ran into is, when I disable 'mirroring' mode, I see 2 1080p choices but no frame rates for either. If I enable mirroring, I see 24fps and 60fps. That's no help because I'm not sure of the order when I turn mirroring back off. I find 24fps to drop frames so I don't want it. My TV only supports 60fps.

  • turtleneck and beret Level 1 Level 1 (0 points)
    Currently Being Moderated
    May 13, 2013 11:40 PM (in response to H.M.J.)

    Yeah, I suppose the name of the thread should better describe the issue people are having, which is not being able to output 1080p at all over (mDP to) HDMI. (Even if it worked previously.)

     

    OS X usually detects the native resolution (Best for display) but this is not the case for everyone experiencing this issue. Setting the resolution manually can work but sometimes OS X does not  display all the resolutions that your monitor actually support. (Like 1080p, for instance.)

    Pressing option(alt) and clicking "Scaled" should give you the full list of resolutions. (See screenshot)

    However, it doesn't for everyone... Which is why we have this thread.

    Screen Shot 2013-05-14 at 08.18.54 .png

     

    You usually can't have mirroring and 1080p unless both displays support it. (Mirroring usually won't allow a resolution that exceeds the native resolution of any of the mirrored displays, that's why it was limited to 1280x800 in your case.)

  • H.M.J. Level 1 Level 1 (0 points)

    OK, you must be using Lion. I am still using Snow Leopard because I always wait several updates before I update anything, since updating anything always breaks something. This is an example of that. I don't have the 'Scaled' option at all. But I do get all supported resolutions for both monitors, even when I turn mirroring on. It looks the same either way.

     

    Screen shot 2013-05-14 at 8.07.27 AM.png

    Screen shot 2013-05-14 at 8.22.23 AM.png

    Screen shot 2013-05-14 at 8.22.47 AM.png

     

    Of course, in mirrored mode, I can only set the TV to 1280x960 max, which is closest to the native 1280x800. Odd choice since this is 4:3. 1280x720 would have given 16:9, which is also what 1080p is, and hence, most people's TV.

     

    I talked about not seeing the refresh rate in unmirrored mode.

     

    Screen shot 2013-05-14 at 8.09.45 AM.png

     

    But I do see the option to change it in the settings dialog above, which was ending up on the TV so I never noticed it while working on the MBP screen. It's good to see that I can know which rate I am using without resorting to trial and error.

     

    That leads me to another dilemma I have. I would, naturally, like to see only the app of my choice appear on the external monitor, and everything else on the native screen. It is annoying, and in this case, misleading, to have a settings dialog like that split between two screens. Totally counter-intuitive and undesirable IMO. I have found no good way to do this. AFAIK there is no setting to associate an external monitor with a particular app. Or is there?

    MacBook Pro
  • turtleneck and beret Level 1 Level 1 (0 points)
    Currently Being Moderated
    May 15, 2013 4:35 AM (in response to H.M.J.)

    As late as last summer I was still running Leopard on my old MBP, but had to upgrade due to the OS not being supported by several developers. I don't know how, but there is a similar way to list all resolutions on previous versions of OS X. I bet the official answer on how to solve it is "Upgrade!"

     

    I'm not sure if I follow. Which display is the primary? (The one with the OS X menu bar or whatever it's called.)

    If you have XMBC full-screen on the external display everything else should use the (primary) MBP diaplay.

     

    I don't know if it is, but it should be!

    I suppose "It just works" at the expense of customisation / Job's way or the high way.

  • H.M.J. Level 1 Level 1 (0 points)

    The primary display is the one with 'Color LCD' in the title bar. If I open Display Preferences, I get the 'Color LCD' dialog box on the MBP and the 'Sony TV' one on the TV, which, as I mentioned, I didn't see before. If I click Gather Windows, the LCD one migrates over to the TV. That is, apparently, Stevie's idea of "just working", though illogical to an ordinary mortal like myself. BTW are you able to assign a monitor to an app in Lion?

  • Dave_D6 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jun 28, 2013 7:38 AM (in response to spark plugs)

    HI All,

     

    Just to throw in my two pennies worth .. I have just spent days try everything to get a crisp image on my Samsung TV 40" from my new Mini Mac via HDMI and it's been driving me mad.

     

    Finally, after reading everyone's thoughts, stumbled across the solution for me (it's probably already been mentioned and I've missed it but just in case)

     

    Leave the Mac set to 'Best for Display'

     

    Then, in the picture options set to 16:9 and in the source settings assign a name to the HDMI port by selecting PC DVI.

     

    Here's the key for me ... check the back of your TV. I have 4 HDMI ports and one of them is specifically marked DVI ... make sure you're using that port (thanks to 'someone' on here who mentioned that (sorry, forgotten who).

     

    If you still have problems make sure you're using a decent cable and not a cheap one off ebay.

     

    Happy days

     

    Thanks to everyone on this forum how had input. I got there in the end

  • billatyow Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 13, 2013 1:51 PM (in response to spark plugs)

    [SOLVED]

    I had the same issue, just replied another thread, forgive me if you believe I should not multiple post.

     

    Mac mini 2012 and SAMSUNG SyncMaster PX2370 display.

     

    1. HDMI to HDMI, bad

    2. HDMI to DVI adaptor to DVI on PX2370, good

     

    The problem is that my Samsung display treated HDMI as TV input. Once I switch the HDMI input to PC mode from Samsung display. The problem is gone. Obversed no difference between method 1 and 2.

     

    I don't disagree that you can fix it by using the stocked HDMI to DVI adaptor, the way I think is if it is designed as an output, it should work. so for my this is not a Mac mini problem, rather a setup issue. I don't know if the HDMI signal from Mac mini is capable or should tell my Samsung display, you should treat my like a PC not TV.

     

    And Samsung display is configured to accept PC signal from its HDMI input, there is no need to configure the overscan (at least my case).

  • Timmmp Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 15, 2013 2:13 AM (in response to PalNova)

    This fixed it for me.   Had to go to the Source menu -> Tools -> Edit Name.  Then select 'DVI PC'.   Setting the sharpness to 0 also helped.   But I think setting the input name is a better solution.   I guess there is a fair bit of image processing that goes on inside the TV.  If the input signal is already good, like from a PC at the right resolution, the input processing just distorts things.

  • billatyow Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 3, 2013 7:23 PM (in response to Timmmp)

    Glad it helped.

  • David TW Chiu Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 15, 2013 9:16 AM (in response to spark plugs)

    This is just plain wrong. How many months have passed? How many pages of pseudo solutions?

    If Apple decided to include a HDMI port as a display option, it should work with devices that come with HDMI inputs. TV with HDMI, I think, can't be a novelty that Apple couldnt test before rolling out the Mac Mini.

     

    Changing input's name? That works on Samsung TV but there are other brands of the market. It doesn't work on my Panasonic plasma. Buying DVI converter? No. My TV doesn't have a DVI port. And asking people to spend extra money to solve Apple's own problem isn't the way to do it.

     

    My system: i5, 10.8.5, Panasonic Viera plasma 1080p.

  • xjkfx Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 24, 2013 1:34 PM (in response to David TW Chiu)

    I have the same setup as you, and I think with the Panasonic you can turn me overscan off, and leave the overscan off on the Mac mini. It definitely helped me

  • terribletext Level 1 Level 1 (0 points)

    This is unacceptable.  I'm seriously considering looking into a class-action lawsuit in recognition of all the valuable time lost to people here, not to mention all the money spent, after basing buying decisions on Apple's misrepresentations. As I write this, Apple's web page is still touting HDMI as a way to use 3rd-party displays, saying "it just works".

     

    This is being typed on an older 2009 mini driving a cheap walmart 32" tv at 1080p, and the text and all else look glorious. It just worked. However, the machine has other problems which means I'll have to start using something else.

     

    I've bought several generations of mini from Apple since then and tried to get them displaying decent text that wouldn't cause my eyes to bleed. Huge number of hours wasted, tried different screens, different adapters; I took the machines into the local Apple-affiliate geniuses who claimed the issue didn't exist. "We can't see it". When clearly, from this discussion string, it has been a long-running problem since 2010. When one considers that only a tiny fraction of 1% of people will actually complain about such a thing, there's no reason to think that a huge number of people have been punked. As in, every person since 2010 who has tried to use one at 1920x1080 resolution on an HDTV.

     

    Pushing the problem back on the users - which is what I experienced - is pretty shaky, since Apple is clearly aware of this problem. I even have perhaps-overly-uncharitable thoughts wondering whether they intentionally crippled the text display because people using a mini and HDTV could get a better experience than those using an iMac. They have crippled features in low-end product before, and it's a reasonable business move - IF IT'S DISCLOSED. But Apple has touted these machines as being fully usable with HDMI monitors including HDTV's.  That's a lie, if one wishes to use them for text - and frankly, most of what many of us use a computer for is text-based.

     

    There are those within Apple who know that this defect exists and is being stonewalled. I'd just note to those of you who have posted here that you're owed some money - you didn't get what you paid for. The most profitable company on earth has seen fit to sell you a product that Just Doesn't Work.

  • mynameisboba Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 26, 2013 5:44 AM (in response to spark plugs)

    Hi all!

     

    I'm experiencing similar problems.

     

    I've bought a new Mac Mini (designated as a late 2012 model in 'About This Mac'.  When I hook it up to an also newly bought Sharp LC-22LE250K TV over HDMI, I get good video and images but text and desktop graphics are not up to scratch, and are somewhat grainy as many have described on this post.

     

    However, do the same with my older LG TV (using Game picture preset) and newish Samsung TV (just plug and play) and everything is perfect.

     

    To improve things on the Sharp I have reduced the picture sharpness to zero (which helps a bit to improve the icons) but the text is still not very good.  I've changed the input name to PC and that didn't do anything.

     

    What has made more of a difference on the Sharp is making very fine adjustments to underscan (System Preferences > Displays).

     

    Get a screen with lots of text (this one is pretty good) and look at the text as you make slight incremental adjustments up and down.  Some will be clearer than others.  What I've done is adjusted things so the stalk of the Apple logo in the top right hand corner is fully visable, then made moved the slider to the right, watching the text change until an optimum is found.

     

    This far from perfect, but is about as good as I think I'm going to get with this TV.

     

    I think the problem may lie in how the TV and the Mac Mini 'talk' to each other over HDMI. Some TV's are able to get it right first time, others (to quote C3PO) may be using a more "peculier dialect".

     

    Any other suggestions would be welcome.

  • mynameisboba Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 26, 2013 6:27 AM (in response to mynameisboba)

    EUREKA!

     

    1)  On your Mac Mini In System Preferences > Displays, set 'Underscan' to off (slider all the way to the left).

     

    2)  On your TV turn the sharpness settings to zero or minimal.

     

    3)  On your TV, access your menu settings for Picture and adjust the pitcure sie / zoom.  If it has an "Auto" selection, ignore this.  Select 'Full Screen' or full or whatever passes for that. On my Sharp TV it's Menu > Picture > Advance Settings > Picture Zoom > Full.  On my Samsung TV it's Tools > Picture Zoom > Screen Fit.    

     

    DO NOT SELECT 16:9 - THIS THE PROBLEM!

     

    Now everything is brill!

Actions

More Like This

  • Retrieving data ...

Bookmarked By (9)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.