Skip navigation

Restore Quicken from Time Machine - Permissions Problem

4722 Views 52 Replies Latest reply: Jul 15, 2013 3:59 PM by sirangler RSS
  • baltwo Level 9 Level 9 (59,235 points)

    This started with issues retrieving stuff from TM, specifically the Quicken data file. I've no a clue where all of this other stuff got involved. Since your running SL, follow these steps (from Kappy):

     

    1. Boot from your Snow Leopard DVD.
    2. Select your language and click on the Continue button.
    3. Wait for the installer's menubar to appear at the top of the screen.
    4. From the Utilities menu select Reset Password.
    5. Click on your main hard drive.
    6. From the dropdown menu under “Select the user account” select your username.
    7. Underneath where it says “Reset Home Directory Permissions and ACLs”, click the Reset button.
    8. Quit the Reset Password utility.
    9. Quit the Installer to restart.
    27" i7 iMac SL, Lion, OS X Mountain Lion (10.8.2), G4 450 MP w/Leopard, 9.2.2
  • Pondini Level 8 Level 8 (38,710 points)

    Hopefully baltwo will have an idea or two;  he's the permissions guru -- I know just enough to be dangerous. 

     

    Until then, one thing you might try is copying the files in question to the special Shared user folder (inside the Users folder at the top level of your internal HD).  Then create a new user account, log on to it, and copy the files from the Shared folder to the new user's home folder.  If that strips off the funky permissions, you should be able to copy back to the Shared folder, then log on to your normal account and copy to your home folder.'

  • baltwo Level 9 Level 9 (59,235 points)

    Wouldn't hurt. Give Pondini's suggestion a try. All the neighborhood goblins have taken to their beds, so must I, since I'm out of ideas.

    27" i7 iMac SL, Lion, OS X Mountain Lion (10.8.2), G4 450 MP w/Leopard, 9.2.2
  • Pondini Level 8 Level 8 (38,710 points)

    Lawrence Hammer wrote:

    . . .

    The only other thing I have tried that seemed to work is to copy the files to my NAS that has a non-Mac file format, then back to my Mac drive.  I was concerned about doing that en mass as I suspect that this strips away other information from the files.

    Yes, I believe that's true, at least in some cases.  Various metadata is stored separately, and extended attributes are, too.   What, if any, data that includes varies by the application that creates or changes the file.  I'm not familiar with Quicken, so what it might store that way, I have no idea.

     

     

    Is there any easy way to do a search to look for files that have this odd permissions quirk?  It seems only a minority of mine have this problem.

    Not that I know of, but that's a bit out of my area.

     

    Out of curiosity, I think one of you stated that permissions are not in the actual file itself, but somewhere else.  Where are permissions stored on the drive?

    That's my understanding (and would explain why the funky ones disappeared when you copied to your NAS -- defaults were added when you copied back to an OSX volume).

     

    I'm pretty sure you can't get to them separately via the normal user interface, but just how they're stored,  I don't know.   There are UNIX command that will show them to you, but only as associated with a file or folder, not separately.

  • sirangler Calculating status...

    I'm going to guess that this was never solved.

     

    I am using Quicken 2007 for Lion on a iMac running Lion. I have my Quicken data file inside my shared  "Public" folder because my wife and I access it from different computers in the house using our household network. This lets us have one Quicken file for about 50 accounts we have, everything from checking to credit cards to brokerage accounts.

     

    So here is what I did to solve the problem I had when I received the error message, "Quicken has found corrupt data in your file. If you continue to use this file you may experience program instability, further date corruption, and incorrect results."

     

    First, I have learned from decades of experience with Quicken for Mac that when you get an error message it almost never tells you what the real problem is. Quicken has a way of just popping up bogus messages and you need to figure out what is really wrong. Something is wrong, just not what it tells you is wrong.

     

    I selected the default, which said something to the effect that I could go to the Quicken help page to solve my problem. The other choices were, "Continue," and "Quit." The Quicken help page told me to delete the "Quotes" file located in the Package Contents of my data file. i did what I was told, but that did not solve the problem. I realize now that true to form, the error message was not even close to wha the real problem was.

     

    Then I went back and tried the "Continue" button. I got the error message that the file was locked (if I remember correctly). My next step was to use Time Machine to simply restore a backup. I LOVE TIME MACHINE. It has saved me from all kinds of problems. The problem I got with Time Machine was that it would try to restore my file, but would give me a message that I didn't have permission. This is garbage. I'm working on my own Mac, my own files, I'm the only user on the machine, how dare it tell me I don't have permission. This is another case of getting the wrong error message for the problem at hand.

     

    So I called Quicken. They dold me that the problem was indeed solvable, but that I needed to buy a support package. I said I'd think about it and hung up.

     

    Then I went back into Time Machine and instead of trying to restore only the Quicken data file, I restored the entire folder that the Quicken data file was in. That did it. No permission errors. Quicken opened just fine, albeit with a days worth of entries missing.

     

    I hope this saves somebody from a day of heartache and solves their problems fast.

     

    Good luck.

1 2 3 4 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.