Skip navigation

Apple TV not recognized by iTunes 11 on Windows 7

897 Views 2 Replies Latest reply: Jul 16, 2013 3:48 PM by El Morche RSS
mleonard1565 Calculating status...
Currently Being Moderated
Jul 11, 2013 5:35 PM

I have a second generation Apple TV running the newest software, version 5.3 and iTunes 11.0.4.4 on a PC running Windows 7. I have the Apple TV connected to ethernet and the laptop to wifi, but on the same home network. When Home Sharing is enabled on both devices, they do not recognize each other and Apple TV is not available as an Airplay speaker. However, if I switch the Apple TV to wifi, the devices recognize each other and Airplay works. Apple devices, such as iPhone, iPad, iPod Touch, and Macbook connected to wifi all recognize the Apple TV as an Airplay speaker when it is connected to ethernet, so I know they are on the same network. The issue is with iTunes on a PC when Apple TV is connect via ethernet. Would really appreciate some guidance on how I might solve this issue because I would prefer to have to Apple TV connected to ethernet. Thanks in advance to anyone who can assist.

AppleTV 2, Windows 7
  • sheila_m. Community Specialists Community Specialists (3,130 points)

    Hello mleonard1565,

     

    Thank you for providing so much information about the issue you are experiencing when your Apple TV is connected through an ethernet cable.  I recommend reviewing the following article for an issue like this:

     

    Troubleshooting Home Sharing

    http://support.apple.com/kb/ts2972

     

    Thank you for using Apple Support Communities.

     

    Best,

    Sheila M.

  • El Morche Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 16, 2013 3:48 PM (in response to sheila_m.)

    Hi

     

    I have roughly the same problem as the OP except that I have an Apple TV 3 running the latest version 5.3 (6105) and iTunes 11.0.4 (4) runs on my MacBook (late 2008) running OS X 10.8.4. When the Apple TV is connected by ethernet it will only show as an Airplay device after I have restarted it. Once it goes to sleep it will not wake up by itself when I try to use Airplay on my MacBook, iPhone or iPad. I've tried switching the Apple TV over to wifi and everything seems to work as expected but like the OP I would prefer to use ethernet.

     

    This behaviour has only manifested itself since the Apple TV was upgraded to software version 5.3 so I suspect that the fault was caused by this upgrade. I have looked at the documents suggested by Sheila M. but these have not been of any help as once the Apple TV has been restarted everything works OK.

     

    I have tried restoring the Apple TV and have restarted my router (one of the latest Time Capsules) and my older Time Capsule which extends the wifi at the other side of my house.

     

    I have reported the problem to Apple through the feedback pages so I hope that this issue will be investigated by them and cured in a future upgrade of the software.

     

    I would be interested in knowing if the OP still has the problem and if not how it was cured.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.