3 Replies Latest reply: Jun 1, 2014 8:31 AM by Dean from NY
imwatsonim Level 1 Level 1 (0 points)

Mac mini display connection will not come back after sleep, I have to shut down and restart the monitor.


Mac mini, OS X Mountain Lion (10.8.4)
  • 1. Re: Mac mini display connection will not come back after sleep, I have to shut down and restart the monitor.
    suchalove8 Level 1 Level 1 (40 points)

    Finder icon on dock, macintosh hd, library, launch agent - delete all files & restart sleep to test

     

    also

    Finder icon on dock, macintosh hd,

    Library/Preferences/SystemConfiguration/com.apple.PowerManagement.plist

    delete file & restart sleep to test.

  • 2. Re: Mac mini display connection will not come back after sleep, I have to shut down and restart the monitor.
    sut288 Level 1 Level 1 (0 points)

    I'm not sure if this is exaactly the same issue so let me elaborate for my situation:

     

    If I put my system to sleep, and it sleeps for some time greater than say 1-2 hrs, then when I go to wake it, the wake-up process starts, but my display (HDMI type) does not show the normal desktop - all is black - once saw a event notification upper right - however I do see the mouse cursur and can make it move on my screen.  Seems to be some video corruption of sorts.  No keystroke of any kind I tried do anything.  I simply hold down power button for >5sec and cold boot again (ouch!) then back in operation ok.

  • 3. Re: Mac mini display connection will not come back after sleep, I have to shut down and restart the monitor.
    Dean from NY Level 1 Level 1 (0 points)

    I have a Mac mini with the same problem.  The only way to get it to wake it up was with the volume keys.  Soon after that I realized that if I change the sound to the internal speakers instead of HDMI the problem would disappear.  The real problem for me was that if I wanted to use LogMeIn I needed someone home to hit the volume button to wake the computer.  I change the sound output to use HDMI only when watching a movie or something.  I always change it back to internal sound when done.  That doesn't explain the cause of the problem (sorry), but, that's a work-around.  I haven't had time, but, I have noticed that there are HDMI cables labeled with "Source" and "Display" on the ends.  I am going to get one of these to see if it works.