10 Replies Latest reply: Jul 18, 2013 4:52 PM by Chris CA
robertfromringwood Level 1 Level 1 (0 points)

I just got an ipod touch 5th gen. I own a Mac 10.5.8 system. I cannot install the new version of itunes on my Mac because it says I need 10.6.8 or later. I cannot sync my Mac itunes with my new ipod itunes. What do I do?


iMac, Mac OS X (10.5.8)