1 Reply Latest reply: Jul 18, 2013 11:54 PM by mende1
10popo10 Level 1 Level 1 (0 points)

Can I install my original disc OS X 10.5.2 on my iMAC G5?


iMac, Mac OS X (10.5.2), I get an error on the screen
  • 1. Re: Can I install OS X Leopard on iMAC G5?
    mende1 Level 10 Level 10 (89,570 points)

    Welcome to Apple Support Communities

     

    In theory, your Mac should be compatible with Mac OS X Leopard. See > http://support.apple.com/kb/sp517

     

    If the DVD came with a Mac different than yours, you can't use it to upgrade your Mac to Mac OS X Leopard. However, if you bought it at a shop, you can use it. Make a backup of your files, insert the DVD and upgrade. Note that Mac OS X Leopard is the most recent version for PowerPC-based Macs, so you can't upgrade further.

     

    If you have to buy Leopard, you can find it at eBay or Amazon. Apple doesn't sell it anymore because it's no longer supported for updates