Skip navigation

Suddenly, no YouTube sound

14909 Views 9 Replies Latest reply: Nov 20, 2013 11:12 PM by Idakathleen RSS
Carli8020 Level 1 Level 1 (0 points)
Currently Being Moderated
Nov 16, 2012 8:49 PM

I have iMac OS X 10.5.8 purchased 2009.   Today I find that YouTube videos, whether played through facebook or directly on YouTube, there is no sound at all.  I went to Flash website and uninstalled my Flash player, although I did have the current one.  I reinstalled it, and still no sound.  What do I do now?

iMac, Mac OS X (10.5.8)
  • BDAqua Level 10 Level 10 (114,800 points)
    Currently Being Moderated
    Nov 16, 2012 10:01 PM (in response to Carli8020)

    Open Audio Midi Setup in Applications>Utilities, see the input & output options & KHz setting there, some things will change it for their own use, then not set it back.

  • fatorangecat2013 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 3, 2013 4:50 PM (in response to BDAqua)

    I am having the same problem, I can hear the volume bar when i turn it on/off, games, but nothing on youtube. I did the above but when I a in applications>utilities>the area for "output" says output not supported. What does this mean? volume just stopped working the last couple of days.

  • turbolink Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jun 2, 2013 8:32 AM (in response to Carli8020)

    Before you start throwing any switches, removing files (as some help pages suggest) or anything else that alters your factory-set software, do this:

     

    System Preferences/Sounds:  Make sure your system is set to Internal Speakers and not AirPlay. 

     

    I have Apple TV and for whatever reason as I was setting up my new iMac it defaulted over to AirPlay.  I was going nuts until I notice that, reset it with one click to internal speakers, and all was well again.

     

    Maybe that's not your problem, but it's a very simple thing to check before you do increasingly risky or complex procedures.

  • Wide Rhino Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 19, 2013 11:39 AM (in response to Carli8020)

    I had something similar. Sound was fine, unless (like Youtube) it required Flash player.

     

    What fixed it was going to System Preferences => Other => Flash Player. In the flash player dialog box, I selected the "Camera and Mic" tab.  The button "Camera and Microphone Settings by Site" lists all the websites that have asked permission to use your camera or microphone. (A creepy concept in and of itself.)

     

    I selected the entire list, and deleted them with the "-" button. Presto! My FlashPlayer sound came back.

  • chappa-ai Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 5, 2013 8:02 AM (in response to Wide Rhino)

    Having the same problem, coincidentally after the Oct "update" of Flash Player. Now suddenly YouTube audio defaults to mute and must be manually reset for each and every video played on MacBook Pro running Mountain Lion. None of the following methods fixes the problem and I'm suspecting it's yet another Google bug in YouTube.

     

    1. Uninstalled Flash, rebooted, checked for any leftover preferences and cache files (there were none), reinstalled latest Flash Player - YouTube still defaults audio to mute.

    2. Updated Flash Player settings (both through System Preferences and through the online Flash app) and applied recommended fixes from multiple web sites (clear stored data, allow 3rd party content, etc) - YouTube still defaults audio to mute.

    3. Opened Audio MIDI Setup (output currently at 44.1 KHz), changed to 96 KHz, changed back to 44.1 KHz - YouTube still defaults audio to mute.

    4. Opened GarageBand and played a few notes on piano instrument - YouTube still defaults audio to mute.

     

    This is not a speaker setting. All audio works fine on the system, including non-YouTube videos. I've tried both the Flash and HTML5 options and they both have the same bug - YouTube audio defaults to mute. Hovering over the speaker icon in the video player shows it on mute. I have to click the icon, then drag the volume slider up in order to hear sound. But, the setting is not preserved. Next YouTube video has audio reset back to mute. Very damned annoying.

  • closereaching Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 6, 2013 6:25 PM (in response to chappa-ai)

    I'm seeing this bug with Chrome, but interestingly, not with FireFox. 

  • drumgayjr Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 7, 2013 4:15 PM (in response to Carli8020)

    I am getting it on both Safari and Firefox. For some reason the video are defaulting to mute. Not sure if iOS caused the issue, if it is a YouTube/HTML 5.0 issue, an adobe flash player issue, or some combination. You can work around it by just un-muting the videos, but defaulting to mute is **** annoying.

  • Cowboyinaf Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 13, 2013 1:50 PM (in response to drumgayjr)

    But what is the workaround for iPad?

  • Idakathleen Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 20, 2013 11:12 PM (in response to Carli8020)

    I have had the same weird problem on my ipad but just realized I had the mute ON in the Control Panel.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.