Skip navigation

External hard drive suddenly became "unreadable" and the disk utility offers not repair options.  The drive is visible in disk utility but may not be mounted... any suggestions?

513 Views 1 Reply Latest reply: Jul 20, 2013 8:37 PM by BDAqua RSS
clzweig Calculating status...
Currently Being Moderated
Jul 20, 2013 3:38 PM

I have a WD My Passport 070A Media 2.0 TB external hard drive that has suddenly become unreadable on my laptop (MacBook Pro circa 2006 with 10.4.11) and I have tried on a MacBook Pro 2011 running 10.6.8 with the same results.  I had tried opening disk utility to repair the drive, but on both machines the drive is visible in the left column, with no indentation below the drive.  When I select the drive in the first aid portion the only options highlighted are info and eject...  I was wondering if anyone had any suggestions to repair the drive.  I am currently in Belize and am not home for 3 weeks yet.  I'm hoping for a fix while I am down here, otherwise I may have to wait...  I appreciate any assistance!

-Christina

MacBook Pro (15-inch Late 2011), Mac OS X (10.7.5)

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.