Skip navigation

Safari Failed After Snow Leopard Install

454 Views 7 Replies Latest reply: Jul 22, 2013 12:19 AM by seventy one RSS
Sailorglc Calculating status...
Currently Being Moderated
Jul 20, 2013 3:28 PM

Swallowing pride and demonstrating my ignorance. Upgraded by wife's Macbook (Late 2008, Black Plastic, 2.4 Ghz Core 2 Duo, 3 gig) to Snow Leopard. All was well but Safari failed to open. Sent error report to Apple. Thinking it was just like any other application. I moved to Trash and thought I could just re-download it like FireFox. Of course, I can't do that.

 

Unfortunately, OS X seems to treat this like a system file. As a reult a part of the error report reads as follows: "Expected in: /System/Library/PrivateFrameworks/Safari.framework/Versions/A/Safari"

 

I tried moving the Safari app from the Trash to the destination shown in the path above knowing that it probably wouldn't work....and of course this time I was right about something.

 

I could reinstall....but don't want to do another thing to make things worse since I already have blood on my hands.

 

Any suggestions or should I just spend $19 and call Apple Support?

 

Please don't beat me up any more than I have already self inflicted.

 

NON COMPOS MENTIS USER

 

Process:    Safari [138]
Path:        /Users/Beth/Desktop/Safari.app/Contents/MacOS/Safari
Identifier:  com.apple.Safari
Version:    5.1.7 (6534.57.2)
Build Info:  WebBrowser-75345702~2
Code Type:  X86-64 (Native)

Parent Process:  launchd [101]

 

Date/Time:  2013-07-19 18:16:39.388 -0500
OS Version:  Mac OS X 10.6.3 (10D575)

Report Version:  6

 

Interval Since Last Report:      24 sec
Crashes Since Last Report:      1

Per-App Crashes Since Last Report:   1

 

Exception Type:  EXC_BREAKPOINT (SIGTRAP)

Exception Codes: 0x0000000000000002, 0x0000000000000000

Crashed Thread:  0  Dispatch queue: com.apple.main-thread

 

Dyld Error Message:

  Symbol not found: _SafariMain

  Referenced from: /Users/Beth/Desktop/Safari.app/Contents/MacOS/Safari

  Expected in: /System/Library/PrivateFrameworks/Safari.framework/Versions/A/Safari

 

Model: MacBook4,1, BootROM MB41.00C1.B00, 2 processors, Intel Core 2 Duo, 2.4 GHz, 3 GB, SMC 1.31f1

Graphics: Intel GMA X3100, GMA X3100, Built-In, 144 MB

MacBook, Mac OS X (10.6.3), 2.4 Ghz Core 2 Duo, 3 Gig, Mid '08

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.